Results 1 to 8 of 8

Thread: Latest "Ubuntu Base" package push won't install

  1. #1
    Join Date
    Feb 2008
    Beans
    72

    Latest "Ubuntu Base" package push won't install

    grub-efi-amd64-signed: Depends: grub2-common (>= 2.02~beta2-36ubuntu3.31) but 2.04-1ubuntu26.12 is to be installed
    grub2-common: Depends: grub-common (= 2.04-1ubuntu26.12) but 2.04-1ubuntu26.12 is to be installed
    Depends: libc6 (>= 2.28) but 2.31-0ubuntu9.3 is to be installed
    Depends: libdevmapper1.02.1 (>= 2:1.02.36) but 2:1.02.167-1ubuntu1 is to be installed
    Depends: libefiboot1 (>= 37) but 37-2ubuntu2.2 is to be installed
    Depends: libefivar1 (>= 37) but 37-2ubuntu2.2 is to be installed
    Depends: liblzma5 (>= 5.1.1alpha+20120614) but 5.2.4-1ubuntu1 is to be installed

    Current system is"

    $ lsb_release -a
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 20.04.2 LTS
    Release: 20.04
    Codename: focal

    $ uname -r
    5.8.0-55-generic

    What's the way around this?

  2. #2
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Latest "Ubuntu Base" package push won't install

    I don't understand what you are trying to do; what exactly are you attempting to install, and what is Ubuntu Base?

    If what you show above is the output of an install command please run it again but this time show us everything, including that command.

  3. #3
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Latest "Ubuntu Base" package push won't install

    Moved to General Help, as this is a request for support and not a chat subject.

    Please note the tagline in the Chat forum:
    Hello <username>, this sub-forum is for chat, not support – hence the name. If you need technical help, please post in an appropriate support sub-forum.
    Please read The Forum Rules and The Forum Posting Guidelines

    A thing discovered and kept to oneself must be discovered time and again by others. A thing discovered and shared with others need be discovered only the once.
    This universe is crazy. I'm going back to my own.

  4. #4
    Join Date
    Apr 2021
    Beans
    198
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Latest "Ubuntu Base" package push won't install


  5. #5
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Latest "Ubuntu Base" package push won't install

    Quote Originally Posted by dddman View Post
    Interesting!

    I have come across the Minimal system but not Ubuntu-Base so I can't add any more to this query.

  6. #6
    Join Date
    Feb 2008
    Beans
    72

    Re: Latest "Ubuntu Base" package push won't install

    "Ubuntu Base" is the name of one of the automatic updates that pop up under Ubuntu 20.04 when Ubuntu pushes them out. There, OS updates are packaged and referred to as "Ubuntu Base". I'm just trying to install the updates that they pushed to me. Not sure why they would push updates that cannot be installed. Still, I have pasted the error messages that occurred. Maybe someone can tell me what's wrong.
    Last edited by stevecoh1; June 9th, 2021 at 10:36 PM.

  7. #7
    Join Date
    Apr 2021
    Beans
    198
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Latest "Ubuntu Base" package push won't install


  8. #8
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Latest "Ubuntu Base" package push won't install

    It seems to me that the messages are nonsense. They say that to install a package it needs to have a dependency installed that is equal to ( = ) in one case. And greater than or equal to ( >= ) in all the other cases. As far as I can see these conditions are being met.

    I am guessing that there is a need (security?) to upgrade grub-efi-amd64-signed and its installation is causing a cascade of dependences. Packages that do not need to be upgraded are going to be upgraded in order for grub-efi-amd64-signed to be upgraded. I guess the user needs to be informed in these situations. Call it "Informed Consent."

    I seem to remember reading something about a security flaw on UEFI systems that required a fix to grub-efi. It did not apply to BIOS systems. I cannot find where I read it.

    Regards
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •