Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Intel Graphics Drivers not installing?

  1. #1
    Join Date
    Aug 2010
    Location
    NSW, Australia
    Beans
    28

    Intel Graphics Drivers not installing?

    Hello Everyone,

    I have just installed Ubuntu Desktop 20.04 on a brand new build, the CPU is an i5 11400. The machine seems to run fine except for the graphics drivers. I cam currently stuck at a resolution of 1024x768. Going to the screen resolution settings only shows one option. I've tried upgrading the kernel, or livebooting Ubuntu 21.04, no go. I've tried installing Oibaf graphics drivers, no good either.

    Code:
    root@muru1:/home/bob# inxi -G
    Graphics:
      Device-1: Intel driver: N/A 
      Display: server: X.Org 1.20.9 
      driver: fbdev,intel 
      unloaded: modesetting,vesa 
      resolution: 1024x768~76Hz 
      OpenGL: 
      renderer: llvmpipe (LLVM 12.0.0 256 bits) v: 4.5 
      Mesa 21.2.0-devel (git-db83dc6 2021-06-05 
      focal-oibaf-ppa)
    I've also tried adding resolutions using xrandr in a way similar to this: https://askubuntu.com/questions/1075...olution-higher
    However whenever I do that it says it can't find the connection type e.g. VGA-1, HDMI1. I've tried many iterations but it doesn't detect it.

    I'm completely out of ideas, I'd really appreciate some help.

    Thanks.

  2. #2
    Join Date
    May 2008
    Beans
    3,980
    Distro
    Ubuntu 22.04 Jammy Jellyfish

    Re: Intel Graphics Drivers not installing?

    Was your processor released in 2021?

    You may need a newer kernel, therefore, why not try Ubuntu 21.04.

    Whoops - I just noticed that you had tried 21.04
    Last edited by tea for one; June 6th, 2021 at 01:19 PM. Reason: Missed detail in OP's post

  3. #3
    GhX6GZMB is offline Iced Almond Soy Ubuntu, No Foam
    Join Date
    Jun 2019
    Beans
    1,093

    Re: Intel Graphics Drivers not installing?

    Running lshw will give you better information on the graphics hardware.

  4. #4
    Join Date
    Mar 2011
    Beans
    1,994

    Re: Intel Graphics Drivers not installing?

    What does lsmod show for video? The i915 would be what i'd expect. Maybe try adding i915 to /etc/modules to force its load.

  5. #5
    Join Date
    Aug 2010
    Location
    NSW, Australia
    Beans
    28

    Re: Intel Graphics Drivers not installing?

    Thanks for the reply. Here is some of my output from lshw. I'm guessing these are the only sections that are needed?

    Code:
    *-cpu
              description: CPU
              product: 11th Gen Intel(R) Core(TM) i5-11400 @ 2.60GHz
              vendor: Intel Corp.
              physical id: 50
              bus info: cpu@0
              version: 11th Gen Intel(R) Core(TM) i5-11400 @ 2.60GHz
              serial: To Be Filled By O.E.M.
              slot: U3E1
              size: 4363MHz
              capacity: 4400MHz
              width: 64 bits
              clock: 100MHz
              capabilities: lm fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp x86-64 constant_tsc art arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf tsc_known_freq pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm 3dnowprefetch cpuid_fault invpcid_single ssbd ibrs ibpb stibp ibrs_enhanced tpr_shadow vnmi flexpriority ept vpid ept_ad fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid mpx avx512f avx512dq rdseed adx smap avx512ifma clflushopt intel_pt avx512cd sha_ni avx512bw avx512vl xsaveopt xsavec xgetbv1 xsaves dtherm ida arat pln pts hwp hwp_notify hwp_act_window hwp_epp hwp_pkg_req avx512vbmi umip pku ospke avx512_vbmi2 gfni vaes vpclmulqdq avx512_vnni avx512_bitalg avx512_vpopcntdq rdpid fsrm md_clear flush_l1d arch_capabilities cpufreq
              configuration: cores=6 enabledcores=6 threads=12
    
    
    *-display UNCLAIMED
                 description: VGA compatible controller
                 product: Intel Corporation
                 vendor: Intel Corporation
                 physical id: 2
                 bus info: pci@0000:00:02.0
                 version: 04
                 width: 64 bits
                 clock: 33MHz
                 capabilities: pciexpress msi pm vga_controller bus_master cap_list
                 configuration: latency=0
                 resources: memory:50000000-50ffffff memory:40000000-4fffffff ioport:3000(size=64) memory:c0000-dffff

  6. #6
    Join Date
    Aug 2010
    Location
    NSW, Australia
    Beans
    28

    Re: Intel Graphics Drivers not installing?

    Quote Originally Posted by ubfan1 View Post
    What does lsmod show for video? The i915 would be what i'd expect. Maybe try adding i915 to /etc/modules to force its load.
    lsmod does show i915. So I'm guessing there's no point in adding it to modules?

    Code:
    video                  49152  1 i915

  7. #7
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    13,614
    Distro
    Ubuntu

    Re: Intel Graphics Drivers not installing?

    You seem to be running into the same problem as this user over at linuxmint's forums:
    https://forums.linuxmint.com/viewtop...61615#p2002372
    Solution there was installing the linux-oem kernel.
    See if that works.
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  8. #8
    Join Date
    Mar 2011
    Beans
    1,994

    Re: Intel Graphics Drivers not installing?

    You're right, no need to add i915 to modules if it's already loaded. My video does have in addition, a thinkpad_acpi, so maybe something along the lines of acpi=0 on the kernel boot line (edit grub to try it out). If that helps, you should try and refine what's minimally needed, since acpi=0 tends to clobber many desirable things, like using more than one core. There are many acpi options to try.

  9. #9
    Join Date
    Mar 2011
    Beans
    1,994

    Re: Intel Graphics Drivers not installing?

    Also, do check for any firmware updates from your motherboard mfg. Even a new machine may be several firmware versions behind, and those updates may fix these sorts of problems.

  10. #10
    Join Date
    Mar 2010
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Intel Graphics Drivers not installing?

    Just for my own comfort... You said you tried to use xrandr. I'm not trying to assume anything, so what was the output from:
    Code:
    xrandr -q
    I see it's a Intel 11th Gen i5... So I know it is a recent motherboard... What is the motherboard?

    Because in your output from
    Code:
    lshw -c video
    I see physical id #2... It's curious that that shows up as unclaimed(?) To find out more about that please do:
    Code:
    lspci | grep -i vga -A3
    Are you using the onboard graphics(?) or other, and with what Display? In 20.04, and you running on Xorg right?

    Did you go through the Trouble Shooting Flowchart in my "Graphics Resolution" sticky in this Section?

    Edit: The OpenSource Intel Graphics drivers are installed under Xorg XServer as a default. But in your first post, they were unloaded. Was that from your Xorg log file?
    Last edited by MAFoElffen; June 8th, 2021 at 10:47 AM.

    "Concurrent coexistence of Windows, Linux and UNIX..." || Ubuntu user # 33563, Linux user # 533637
    Sticky: Graphics Resolution | UbuntuForums 'system-info' Script | Posting Guidelines | Code Tags

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •