Results 1 to 4 of 4

Thread: Problem to connect to outside networks

  1. #1
    Join Date
    Jun 2021
    Beans
    2

    Exclamation Problem to connect to outside networks

    Well I have a problem I have freshly installed an Ubuntu legacy server 20.04 two times and I have problem with the networking, i have update the netplan config with a LAN static IP with the fallowing config file :



    the problem is that i can ping from the server to the router (192.168.69.1) and also I can ping from another pc to the server locally, also I can ssh via a local pc to the server but i cant see any other PC from the server and I cant ping to 8.8.8.8 .

    I pretty sure that i have done something wrong in the installation because i do not have used to use the legacy Ubuntu version of the installer.
    Never than less I am all ears to every suggestion.
    Last edited by dim800vt; June 2nd, 2021 at 06:17 PM.

  2. #2
    Join Date
    Nov 2007
    Location
    London, England
    Beans
    7,260
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Problem to connect to outside networks

    For the PCs you "can't see", are they local PCs on 192.168.69.*, or remote PCs?

    For some basic debuggung, can you post the output from the command "ip route", and "ip route get 8.8.8.8" please.
    Also, do you hae a firewall operating on the server? If so, please post the output of the command "sudo iptables-save -c".

  3. #3
    Join Date
    Jun 2021
    Beans
    2

    Re: Problem to connect to outside networks

    Thank you i will check it after work, thank you very much.

  4. #4
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Problem to connect to outside networks

    Minimal netplan:
    Code:
    network:
      version: 2
      renderer: networkd
      ethernets:
         ens3:
           addresses:
              - 172.22.22.3/24
           dhcp4: false
           dhcp6: false
           gateway4: 172.22.22.1
           nameservers:
             addresses: [ "172.22.22.80" ]
    I've always disabled DHCP and put in an exact renderer to prevent confusion.
    Don't forget to
    Code:
    sudo netplan generate
    sudo netplan apply --debug
    after any changes to the netplan YAML files.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •