Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: missing file

  1. #11
    Join Date
    Jun 2016
    Beans
    2,286
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: missing file

    Try
    Code:
    sudo apt-get install libunistring2/focal
    Xubuntu 20.04/Pop!_OS 21.04/System76 hardware ♦ Debian 10/Xubuntu/VirtualBox
    If your questions are resolved to your satisfaction, please use Thread Tools > "Mark this thread as solved..."

  2. #12
    Join Date
    Mar 2007
    Location
    Promiseland
    Beans
    1,204
    Distro
    Xubuntu 20.04 Focal Fossa

    Thumbs up Re: missing file

    OK, making some progress. These three commands were successful ....
    Code:
    $ sudo apt-get install libunistring2/focal
    ...
    ~/build/libunistring$ apt-cache policy libunistring2
    ...
    sudo apt-get install libunistring-dev
    However, another fatal error - missing file similar to the one documented in post #1.
    Code:
    hugh@b450m:~/build/boxes-master$ make && make test
    | For compilation info please refer to the boxes compilation FAQ
    | at https://boxes.thomasjensen.com/docs/faq.html#q5
    make -C src BOXES_PLATFORM=unix LEX=flex YACC=bison build
    make[1]: Entering directory '/home/hugh/build/boxes-master/src'
    make -C ../out -f ../src/Makefile BOXES_PLATFORM=unix ALL_OBJ="parser.o lex.yy.o boxes.o cmdline.o discovery.o generate.o input.o list.o parsecode.o parsing.o query.o regulex.o remove.o shape.o tools.o unicode.o" \
        CFLAGS_ADDTL="-O " STRIP=true flags_unix boxes
    make[2]: Entering directory '/home/hugh/build/boxes-master/out'
    make[2]: Nothing to be done for 'flags_unix'.
    gcc -I. -I../src -Wall -W -O    -c -o parser.o parser.c
    In file included from boxes.h:35,
                     from ../src/parser.y:27:
    ../src/regulex.h:42:10: fatal error: pcre2.h: No such file or directory
       42 | #include <pcre2.h>
          |          ^~~~~~~~~
    compilation terminated.
    make[2]: *** [<builtin>: parser.o] Error 1
    make[2]: Leaving directory '/home/hugh/build/boxes-master/out'
    make[1]: *** [Makefile:54: build] Error 2
    make[1]: Leaving directory '/home/hugh/build/boxes-master/src'
    make: *** [Makefile:41: build] Error 2
    I will close this thread as solved since the original missing file issue was successfully addressed. I will also follow the posts in this thread while attempting to address the current missing file.

    @halogen2 You have been so helpful and patient as we worked through this issue. Thank you. Should we ever meet in person, the beer or coffee (your choice) is on me. Have a nice day, you earned it
    Cheers,


    The Linux Command Line at http://linuxcommand.org/

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •