Results 1 to 4 of 4

Thread: Cannot make Realtek drivers

  1. #1
    Join Date
    May 2021
    Beans
    2

    Cannot make Realtek drivers

    Last post on this topic was in 2009 and the helpful script linked there no longer exists. ^_^

    Basically, I'm trying to install/make the Realtek ethernet card drivers but it seems to be getting caught on an infinite loop at the MAKE stage.

    I've tried using just the ./autorun.sh script, but that hangs at the build/install stage.

    Investigating further, I've tried running the various make stages by hand and have noted the following:
    1) When Makefile is executed it seems to be trying to do all of its work in /lib/.../build, rather than the directory the files are actually located it.
    2) Even if I create a /lib/.../build directory it then can't find a Makefile in there

    If I copy all of the contents into /lib/.../build and then try and execute it then, it traps itself in an infinite loop. Instead of building it just:
    1) Enters /src
    2) Executes Makefile there
    3) Enters /src from the root directory
    4) Executes Makefile there
    5) etcetera

    Is there something basic I'm missing? I'm using sudo to execute autorun or do the make files by hand, so it shouldn't be a rights issue... (I would think)

  2. #2
    Join Date
    Jun 2007
    Beans
    14,486

    Re: Cannot make Realtek drivers

    Most Realtek LAN drivers are already built into kernel. You probably don't need to 'make' them. What card/chipset do you have and what Ubuntu version are you running?
    Start here:
    Code:
    lspci
    or, if USB:
    Code:
    lsusb

  3. #3
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    7,929
    Distro
    Ubuntu Mate 20.04 Focal Fossa

    Re: Cannot make Realtek drivers

    Do you mean this one from the past? Its now available directly
    Code:
    sudo apt install r8168-dkms

  4. #4
    Join Date
    May 2021
    Beans
    2

    Re: Cannot make Realtek drivers

    Thank you both for the responses. ^_^

    I ended up just installing a new Intel ethernet card which was properly associated with the correct driver.

    And thank you, praseodym... will give that a try if I need to get the first network adapter up and running again.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •