Results 1 to 4 of 4

Thread: Unable to upgrade to Hirsute as invalid signature

  1. #1
    Join Date
    Nov 2009
    Location
    West Sussex (UK)
    Beans
    168
    Distro
    Ubuntu

    Unable to upgrade to Hirsute as invalid signature

    Hello,

    I am trying to upgrade to Hirsute from Groovy via GUI and am unable to do so.

    The installation process stops and shows the message below.

    I have followed the steps from this thread and installed y-ppa-manager -it discovered that I had one invalid ppa and two duplicate ones, but still find the message again.

    PHP Code:
    W:Updating from such a repository can't be done securely, and is therefore disabled by default., W:See apt-secure(8) manpage for repository creation and user configuration details., W:GPG error: https://packages.riot.im/debian default InRelease: The following signatures were invalid: EXPKEYSIG C2850B265AC085BD riot.im packages <packages@riot.im>, E:The repository 'https://packages.riot.im/debian default InRelease' is not signed. 
    Please could somebody help me to upgrade to Hirsute or should I download the new version from the Ubuntu website and start from there?

    Thank you kindly.
    Damn the torpedoes, full steam ahead!

  2. #2
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Unable to upgrade to Hirsute as invalid signature

    It is usually important to disable, or better remove all PPAs before attempting an upgrade from version to version, and then add the PPA repos you need again after the upgrade.

    I am fairly sure that the ppa:webupd8team has been completely discontinued so will no longer be of any use (unless it has been re-established recently) so I suggest that you forget that for now, remove any PPAs you have in groovy, upgrade by whatever means you wish.
    Once upgraded see if the PPAs you previously used are available for hirsute and enable them if you need to.

    I'm not sure if upgrades are being offered yet in the settings of the software and upgrades utility as I always clean install, and I run only LTS versions except for some VMs I have installed simply to check progress of the intermediate versions.

  3. #3
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Unable to upgrade to Hirsute as invalid signature

    I suggest that you uninstall the element desktop app and remove that riot.im repository from your sources.list file and then try to update. And reinstall Element desktop afterwards. You may find that riot.im does not yet have a version of element desktop for Ubuntu 21.04 and may wish to wait a bit longer on 20.10.

    Regards
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  4. #4
    Join Date
    Nov 2009
    Location
    West Sussex (UK)
    Beans
    168
    Distro
    Ubuntu

    Re: Unable to upgrade to Hirsute as invalid signature

    Thanks.
    Damn the torpedoes, full steam ahead!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •