Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: Not able to install some packages for LaTeX editor, why ?

  1. #11
    Join Date
    May 2021
    Beans
    13

    Re: Not able to install some packages for LaTeX editor, why ?

    Code:
    priyanshu@priyanshu-Inspiron-5593:~$ cat /etc/apt/sources.list
    # deb cdrom:[Ubuntu 20.04.1 LTS _Focal Fossa_ - Release amd64 (20200731)]/ focal main restricted
    
    # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
    # newer versions of the distribution.
    deb http://repos.del.extreme-ix.org/ubuntu/ focal main restricted
    # deb-src http://in.archive.ubuntu.com/ubuntu/ focal main restricted
    
    ## Major bug fix updates produced after the final release of the
    ## distribution.
    deb http://repos.del.extreme-ix.org/ubuntu/ focal-updates main restricted
    # deb-src http://in.archive.ubuntu.com/ubuntu/ focal-updates main restricted
    
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team. Also, please note that software in universe WILL NOT receive any
    ## review or updates from the Ubuntu security team.
    deb http://repos.del.extreme-ix.org/ubuntu/ focal universe
    # deb-src http://in.archive.ubuntu.com/ubuntu/ focal universe
    deb http://repos.del.extreme-ix.org/ubuntu/ focal-updates universe
    # deb-src http://in.archive.ubuntu.com/ubuntu/ focal-updates universe
    
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
    ## team, and may not be under a free licence. Please satisfy yourself as to 
    ## your rights to use the software. Also, please note that software in 
    ## multiverse WILL NOT receive any review or updates from the Ubuntu
    ## security team.
    deb http://repos.del.extreme-ix.org/ubuntu/ focal multiverse
    # deb-src http://in.archive.ubuntu.com/ubuntu/ focal multiverse
    deb http://repos.del.extreme-ix.org/ubuntu/ focal-updates multiverse
    # deb-src http://in.archive.ubuntu.com/ubuntu/ focal-updates multiverse
    
    ## N.B. software from this repository may not have been tested as
    ## extensively as that contained in the main release, although it includes
    ## newer versions of some applications which may provide useful features.
    ## Also, please note that software in backports WILL NOT receive any review
    ## or updates from the Ubuntu security team.
    deb http://repos.del.extreme-ix.org/ubuntu/ focal-backports main restricted universe multiverse
    # deb-src http://in.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse
    
    ## Uncomment the following two lines to add software from Canonical's
    ## 'partner' repository.
    ## This software is not part of Ubuntu, but is offered by Canonical and the
    ## respective vendors as a service to Ubuntu users.
    # deb http://archive.canonical.com/ubuntu focal partner
    # deb-src http://archive.canonical.com/ubuntu focal partner
    
    deb http://repos.del.extreme-ix.org/ubuntu/ focal-security main restricted
    # deb-src http://security.ubuntu.com/ubuntu focal-security main restricted
    deb http://repos.del.extreme-ix.org/ubuntu/ focal-security universe
    # deb-src http://security.ubuntu.com/ubuntu focal-security universe
    deb http://repos.del.extreme-ix.org/ubuntu/ focal-security multiverse
    # deb-src http://security.ubuntu.com/ubuntu focal-security multiverse
    
    # This system was installed using small removable media
    # (e.g. netinst, live or single CD). The matching "deb cdrom"
    # entries were disabled at the end of the installation process.
    # For information about how to configure apt package sources,
    # see the sources.list(5) manual.
    Last edited by slickymaster; May 17th, 2021 at 02:49 PM. Reason: code tags

  2. #12
    Join Date
    Aug 2011
    Location
    51.8° N 5.8° E
    Beans
    5,936
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Not able to install some packages for LaTeX editor, why ?

    Although your software sources appear to be OK and your mirror is on the list of official mirrors, the versions of those packages don't match the versions in the official repositories. It offers:
    texstudio 2.12.16+debian-1.1 instead of 2.12.22+debian-1build1;
    libpoppler-qt5-1 0.80.0-0ubuntu4 instead of 0.86.1-0ubuntu1;
    libqt5script5 5.12.5+dfsg-2 instead of 5.12.8+dfsg-0ubuntu1.
    There appears to be something wrong with that mirror.

    Can you change to a different mirror or the main server, then run
    Code:
    sudo apt update
    sudo apt upgrade
    If the problem persists, show again the output of
    Code:
    apt-cache policy texstudio libpoppler-qt5-1 libqt5script5
    apt show texstudio

  3. #13
    Join Date
    May 2021
    Beans
    13

    Re: Not able to install some packages for LaTeX editor, why ?

    so sorry to disturb you but i am not very much comfortable to work in Linux OS.
    can you please tell me the meaning of this
    "Can you change to a different mirror or the main server"
    How can i do this ? and will it affect to my other softwares that i have installed in my machine ?
    Thanks
    priyanshu

  4. #14
    Join Date
    Nov 2012
    Location
    Halloween Town
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Not able to install some packages for LaTeX editor, why ?

    @priyanshu-gif:

    Please use code tags when posting output because if posted as plain text loses its formatting and parts of it sometimes turn into smileys making it difficult to read and understand. The use of code tags makes the post clean, compact and more appealing, thus getting more attention from readers.

  5. #15
    Join Date
    Aug 2011
    Location
    51.8° N 5.8° E
    Beans
    5,936
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Not able to install some packages for LaTeX editor, why ?

    Go to your settings → Software and Updates → Ubuntu software, in the dropdown box for "Download from:" you pick a different server.

    This could lead to the system proposing to install a large number up upgrades. If it seems excessive, you can still abort.

  6. #16
    Join Date
    May 2021
    Beans
    13

    Re: Not able to install some packages for LaTeX editor, why ?

    Really thank you very very much.
    now my problem is solved and i able to install texstudio easily in just 2-3 seconds. before this i have spend so many hours in searching the solution of this problem.
    you fulfilled my purpose on coming this forum.
    thanks a lot!
    Regards
    Priyanshu

  7. #17
    Join Date
    May 2021
    Beans
    13

    Re: Not able to install some packages for LaTeX editor, why ?

    sorry for that. I don't know before this.
    and thank you very much for letting me know this.

  8. #18
    Join Date
    Aug 2011
    Location
    51.8° N 5.8° E
    Beans
    5,936
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Not able to install some packages for LaTeX editor, why ?

    Great.

    I must say that I didn't really expect this problem of a faulty mirror. Usually it's a user doing something not so smart, but there's no way you could have foreseen this.

  9. #19
    Join Date
    May 2021
    Beans
    13

    Re: Not able to install some packages for LaTeX editor, why ?

    yes, of course but with your help i did it.
    BTW how did you know, that could be the problem?
    Thanks a lot again.

  10. #20
    Join Date
    Aug 2011
    Location
    51.8° N 5.8° E
    Beans
    5,936
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Not able to install some packages for LaTeX editor, why ?

    It was mostly this post. I bolded the important bits:
    Quote Originally Posted by priyanshu-gif View Post
    Thank you very much for you help!
    i run this and getting this...
    Code:
    priyanshu@priyanshu-Inspiron-5593:~$ apt-cache policy texstudio libpoppler-qt5-1 libqt5script5
    texstudio:
      Installed: (none)
      Candidate: 2.12.16+debian-1.1
      Version table:
         2.12.16+debian-1.1 500
            500 http://repos.del.extreme-ix.org/ubuntu focal/universe amd64 Packages
    libpoppler-qt5-1:
      Installed: 0.80.0-0ubuntu4
      Candidate: 0.80.0-0ubuntu4
      Version table:
     *** 0.80.0-0ubuntu4 500
            500 http://repos.del.extreme-ix.org/ubuntu focal/universe amd64 Packages
            100 /var/lib/dpkg/status
    libqt5script5:
      Installed: (none)
      Candidate: 5.12.5+dfsg-2
      Version table:
         5.12.5+dfsg-2 500
            500 http://repos.del.extreme-ix.org/ubuntu focal/universe amd64 Packages
    On https://packages.ubuntu.com I could find the versions of those packages that are supposed to be in Ubuntu 20.04 by searching for the package name in distribution focal, giving for example this page, telling me that you should have version 2.12.22+debian-1build1. The output above showed 2.12.16+debian-1.1, so that was wrong. On https://launchpad.net/ubuntu/+archivemirrors I could find a list of Ubuntu mirrors and the server listed in your output in post 11 is on that list. All entries there are correctly formatted for software sources for Ubuntu 20.04. For example, the line
    Code:
    deb http://repos.del.extreme-ix.org/ubuntu/ focal main restricted
    tells us you use a deb source from the server on that url, version focal (=20.04) for the main and restricted repositories. But, as you see, the versions of software that repository has available don't match the official versions, so there must be a problem with that mirror.

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •