Results 1 to 8 of 8

Thread: Disable auto logout

  1. #1
    Join Date
    May 2021
    Beans
    1

    Disable auto logout

    Hi! i have a wierd problem. i have disabled auto logut in settings>privacy>screenlock. But it seems to auto logout after a few hours. Last time i touched my computer was before i was going to bed and when i woke up (7 hours of sleep) my user was logged out... any idea?

    I am mining on the computer so its not like it ideling either....

    //Jakob

    Ubuntu 20.04 Desktop

  2. #2
    Join Date
    Aug 2005
    Location
    Northern Michigan USA
    Beans
    2,323
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Disable auto logout

    Look at power manager settings and screensaver settings

  3. #3
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Disable auto logout

    You are disabling automatic screen lock. That is not the same as automatic logout. I am not sure if Ubuntu Desktop has automatic logout set. Maybe Ubuntu server has automatic logout set. I do not know. The instruction guides that I have just researched refer to the Bash terminal. Which would be applicable to a server installation.

    A person would need to change the tmout setting in either /etc/profile or /.bash_profile. Or, some other place. On my Ubuntu desktop I cannot find any file where the tmout setting is included. Except in some snap files.

    https://www.cyberciti.biz/faq/linux-...gout-variable/

    I do have show hidden files checked. I have looked in /etc/profile, /home/.bashrc, /home/.bash_logout, /.profile, /etc/bash.bashrc

    I am staring to suspect that the tmout command is not used in the Ubuntu desktop system environment. At least not on my Ubuntu 20.04. But it may be used in Ubuntu server.

    https://ostechnix.com/auto-logout-in...od-time-linux/

    Regards
    Last edited by grahammechanical; May 10th, 2021 at 01:17 PM.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  4. #4
    Join Date
    Dec 2007
    Location
    Western U.S.
    Beans
    187

    Re: Disable auto logout

    Quote Originally Posted by grahammechanical View Post
    You are disabling automatic screen lock. That is not the same as automatic logout. I am not sure if Ubuntu Desktop has automatic logout set. Maybe Ubuntu server has automatic logout set. I do not know. The instruction guides that I have just researched refer to the Bash terminal. Which would be applicable to a server installation.

    A person would need to change the tmout setting in either /etc/profile or /.bash_profile. Or, some other place. On my Ubuntu desktop I cannot find any file where the tmout setting is included. Except in some snap files.

    https://www.cyberciti.biz/faq/linux-...gout-variable/

    I do have show hidden files checked. I have looked in /etc/profile, /home/.bashrc, /home/.bash_logout, /.profile, /etc/bash.bashrc

    I am staring to suspect that the tmout command is not used in the Ubuntu desktop system environment. At least not on my Ubuntu 20.04. But it may be used in Ubuntu server.

    https://ostechnix.com/auto-logout-in...od-time-linux/

    Regards
    In other words, you are saying there is no way, in the settings, to disable screen lock, after waking a sleeping computer.

    We can set the system to log in without inputting the password, when powering up a computer, but when waking from sleep, we'll always have to log in....

  5. #5
    Join Date
    Aug 2005
    Location
    Northern Michigan USA
    Beans
    2,323
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Disable auto logout

    I don't get logged out after suspend, ever.

  6. #6
    Join Date
    Dec 2007
    Location
    Western U.S.
    Beans
    187

    Re: Disable auto logout

    Quote Originally Posted by cmcanulty View Post
    I don't get logged out after suspend, ever.
    I'm using Kubuntu 20.04. How can I set up my system so that it does not log me out after the computer goes to sleep?

  7. #7
    Join Date
    Aug 2005
    Location
    Northern Michigan USA
    Beans
    2,323
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Disable auto logout

    look in screensaver settings and power manager settings

  8. #8
    Join Date
    Dec 2007
    Location
    Western U.S.
    Beans
    187

    Re: Disable auto logout

    Quote Originally Posted by jegub View Post
    Hi! i have a wierd problem. i have disabled auto logut in settings>privacy>screenlock. But it seems to auto logout after a few hours. Last time i touched my computer was before i was going to bed and when i woke up (7 hours of sleep) my user was logged out... any idea?

    I am mining on the computer so its not like it ideling either....

    //Jakob

    Ubuntu 20.04 Desktop
    I had asked that question in my own thread, and found your thread on the same issue. This is the answer I got. I hope this is helpful to you.

    Quote Originally Posted by vidtek View Post
    Go to System-Settings->workspace behaviour->screen locking look at the options and understand them. It's one of the first things I do with a new install

    Cheers Tony

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •