Results 1 to 2 of 2

Thread: libc6 appear as locally installed/obsolete

  1. #1
    Join Date
    Apr 2006
    Beans
    43

    libc6 appear as locally installed/obsolete

    I was checking with synaptic for locally installed packages, and I discovered there libc6 (among other packages which should be from ubuntu repo).
    I think this could be from some added and removed PPA, but now I would lile to return most of them to ubuntu repo; how could I do that? I could force one by one package version, but there are quite a lot.

    Thanks

  2. #2
    Join Date
    Oct 2004
    Location
    33.4N -112.1W
    Beans
    2,435
    Distro
    Ubuntu Budgie

    Re: libc6 appear as locally installed/obsolete

    Can you first verify the source of this package?

    Issue the command shown below and scroll down to "APT-Sources".
    This will tell your from what repo the package originated.

    It's likely the libc6 package showing as local/obsolete is just a prior version no longer found in ubuntu's repos.
    If this is the case it can be safely removed.

    Code:
    apt show libc6
    Sample output will show as this:
    Code:
    apt show libc6
    .
    .
    .
    Original-Vcs-Browser: https://salsa.debian.org/glibc-team/glibc
    Original-Vcs-Git: https://salsa.debian.org/glibc-team/glibc.git
    Download-Size: 2,690 kB
    APT-Manual-Installed: no
    APT-Sources: http://us.archive.ubuntu.com/ubuntu hirsute/main amd64 Packages
    Last edited by Xian; May 5th, 2021 at 08:43 PM.
    /path/to/Truth

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •