Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Grub has made windows hdd unbootable

  1. #1
    Join Date
    Nov 2014
    Location
    Moskow region
    Beans
    40
    Distro
    Ubuntu Studio

    Grub has made windows hdd unbootable

    I have Mint 19.1 problem but I think its similar to Ubuntu, so I ask.
    2 HDD both were bootable, uefi bios. Mint and Windows. And grub made Windows unbootable, I can boot only from grub boot menue. Is it possible to make windows HDD bootable back without reformatting it?

  2. #2
    Join Date
    May 2014
    Location
    /home
    Beans
    9,375
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Grub has made windows hdd unbootable

    Moved to Mint

  3. #3
    Join Date
    Jun 2014
    Beans
    6,178

    Re: Grub has made windows hdd unbootable

    You haven't posted enough information for anyone to even begin to think about helping you. Mint and Ubuntu are similar in many ways. First, you mention that you have Mint 19.1 but make no mention of which release of windows you are using. Microsoft has been licensing its windows OS for 35 years so that is significant information. You indicate you are booting UEFI so if that is the case. you should be able to access the BIOS firmware on the computer and select to boot either Mint or windows. This method has nothing to do with Grub. What exactly is it that you thing Grub has done to render windows unbootable? In your next sentence you state that you can only boot from Grub boot menu. Those are conflicting statements, unless you mean you can now only boot Mint from Grub. Clarify please..

  4. #4
    Join Date
    Nov 2014
    Location
    Moskow region
    Beans
    40
    Distro
    Ubuntu Studio

    Re: Grub has made windows hdd unbootable

    Windows is 7 64 bit.

    Code:
    linux_user@MS-7850:~$ inxi -Fxz
    System:
      Host: MS-7850 Kernel: 4.15.0-20-generic x86_64 bits: 64 compiler: gcc 
      v: 7.3.0 Desktop: Cinnamon 4.0.10 Distro: Linux Mint 19.1 Tessa 
      base: Ubuntu 18.04 bionic 
    Machine:
      Type: Desktop Mobo: MSI model: B85-G41 PC Mate(MS-7850) v: 1.0 
      serial: <filter> UEFI: American Megatrends v: 2.8 date: 07/17/2014 
    CPU:
      Topology: Dual Core model: Intel Core i3-4150 bits: 64 type: MT MCP 
      arch: Haswell rev: 3 L2 cache: 3072 KiB 
      flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28000 
      Speed: 1032 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 978 2: 980 
      3: 982 4: 969 
    Graphics:
      Device-1: NVIDIA GK104 [GeForce GTX 760] vendor: Gigabyte driver: nouveau 
      v: kernel bus ID: 01:00.0 
      Display: x11 server: X.Org 1.19.6 driver: nouveau 
      unloaded: fbdev,modesetting,vesa resolution: 1280x1024~60Hz 
      OpenGL: renderer: NVE4 v: 4.3 Mesa 19.0.2 direct render: Yes 
    Audio:
      Device-1: Intel 8 Series/C220 Series High Definition Audio 
      vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
      Device-2: NVIDIA GK104 HDMI Audio vendor: Gigabyte driver: snd_hda_intel 
      v: kernel bus ID: 01:00.1 
      Sound Server: ALSA v: k4.15.0-20-generic 
    Network:
      Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
      vendor: Micro-Star MSI driver: r8169 v: 2.3LK-NAPI port: d000 
      bus ID: 03:00.0 
      IF: enp3s0 state: down mac: <filter> 
    Drives:
      Local Storage: total: 2.27 TiB used: 9.24 GiB (0.4%) 
      ID-1: /dev/sda vendor: Seagate model: ST3500418AS size: 465.76 GiB 
      ID-2: /dev/sdb vendor: Western Digital model: WD20EFRX-68EUZN0 
      size: 1.82 TiB 
    RAID:
      Hardware-1: VIA VT6421 IDE/SATA Controller driver: sata_via v: 2.6 
      bus ID: 05:00.0 
    Partition:
      ID-1: / size: 191.25 GiB used: 9.23 GiB (4.8%) fs: ext4 dev: /dev/sdb2 
    Sensors:
      System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nouveau temp: 34 C 
      Fan Speeds (RPM): N/A gpu: nouveau fan: 1380 
    Info:
      Processes: 196 Uptime: 2m Memory: 7.72 GiB used: 588.1 MiB (7.4%) 
      Init: systemd runlevel: 5 Compilers: gcc: 7.5.0 Shell: bash v: 4.4.20
    Last edited by slickymaster; May 7th, 2021 at 01:53 PM. Reason: code tags

  5. #5
    Join Date
    Nov 2014
    Location
    Moskow region
    Beans
    40
    Distro
    Ubuntu Studio

    Re: Grub has made windows hdd unbootable

    efimanager shows that windows boot manager is inactive. I made it active. And after that i see windows boot option in f11 boot menue, and i can boot from it. But i cant change boot sequense using efibootmanager.And i cant with editing bios. Bios editing makes windows boot inactive back.
    I use ~$ efibootmgr -o 0001, 000E, {my bootlist}
    where 0001 is win boot manager, but efibootmgr writes i write wrongly.

  6. #6
    tea for one is offline Iced Blended Vanilla Crème Ubuntu
    Join Date
    May 2008
    Beans
    1,527
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: How to modify boot sequence with efimanager?

    Have a look at Section 2 Changing Boot Order of this website:-

    https://www.linuxbabe.com/command-li...otmgr-examples

  7. #7
    Join Date
    May 2010
    Beans
    1,352

    Re: How to modify boot sequence with efimanager?

    Is this a dual boot and want Windows to be the default?

  8. #8
    Join Date
    Nov 2012
    Location
    Halloween Town
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Grub has made windows hdd unbootable

    Threads merged.

    Please do not create duplicate threads, it dilutes the community’s efforts to provide support and causes confusion.

  9. #9
    Join Date
    Jun 2014
    Beans
    6,178

    Re: Grub has made windows hdd unbootable

    Code:
    I use   ~$   efibootmgr -o 0001, 000E,  {my bootlist}
    Did you use the above command or did you preface it with sudo as required?

    Some systems are difficult to change with efibootmgr but you should be able to set either windows or Ubuntu to first boot priority in your BIOS firmware and change on boot if you wish. If you can't do that you need to read the manual for the particular computer you are using or look it up online, has nothing to do with Ubuntu or Linux.

  10. #10
    Join Date
    Nov 2014
    Location
    Moskow region
    Beans
    40
    Distro
    Ubuntu Studio

    Re: Grub has made windows hdd unbootable

    Of cause with sudo. Any linux will not allow such unless being a superuser.
    Some systems are difficult to change with efibootmgr but you should be able to set either windows or Ubuntu to first boot priority in your BIOS firmware and change on boot if you wish. If you can't do that you need to read the manual for the particular computer you are using or look it up online, has nothing to do with Ubuntu or Linux.
    When I try to change bootorder in BIOS it makes winbootloader inactive. So strange.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •