Hi, I'm new on the forum nad trying to get some help as nothing have worked for me. Situation is : I have upgraded from 16.04 to 18.04 and straight to 20.04. I can start metacity but not gnome3. I got used to gnome3 and would like to go back to it. I think long before upgrade I made some mods and symlinks to nvidia libraries when using cuda (not using any more) and now after upgrade I cannot run gnome3 or some apps like gnome-control-center, here's one of errors:

gnome-control-center: error while loading shared libraries: libnvidia-tls.so.418.87.01: cannot open shared object file: No such file or directory

and ldd:

ldd /usr/bin/gnome-control-center | grep 'not found'

libnvidia-tls.so.418.87.01 => not found
libnvidia-glcore.so.418.87.01 => not found

I have tried remove libGL.so symlinks and libs also, reinstalled nvidia driver 460. Thing is this 418 version is no longer on my system (and wasn't for a while even on 16.04) and I have no idea how to remove this error as I'm thinking it's the problem to run gnome3 also.

Need some help guys
(⊙▂⊙✖ )