Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Can't boot Lubuntu 20.04 after installation

  1. #1
    Join Date
    May 2021
    Beans
    11

    Can't boot Lubuntu 20.04 after installation

    Hello,

    I've combed through several similar posts and tried various things which have had little effect!

    My laptop is a HP ProBook 4540s. I've installed an ISO onto USB with Unetbootin.

    (It took me a while to get through all the BIOS to even install it!)

    The BIOS settings are UEFI hybrid, I've disabled Fast Boot and Security Keys, or whatever. I've also disabled booting from floppy and pxe, and ordered the boot sequence appropriately.

    I've tried Gnome Disk Utility - to make the sda1 bootable, I also did this through the KDE Partition Manager.

    Then I tried boot-repair, but it didn't give me any further instructions, except for this link:

    http://paste.ubuntu.com/p/C3jMp42K7d/

    I'm currently exploring GRUB - as you might guess, I'm quite new to Linux, and Lubuntu.



    Any assistance would be much appreciated. Trawling through similar but different problems can be confusing!
    Much gratitude,

    Duckwobble

  2. #2
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Can't boot Lubuntu 20.04 after installation

    A little bit of history. In the early days computer motherboards had an integrated circuit (chip) that held information about the hardware & boot order and all that stuff. It is called BIOS (Basic Input Output System). Then an improvement was made. BIOS was replaced with UEFI (Unified Extensible Firmware Interface). You have a UEFI motherboard. That means an operating system can be installed in EFI mode or BIOS/Legacy/CSM mode. CSM = Compatible Support Module.

    With UEFI motherboards we can run the Ubuntu installer ISO in either UEFI mode or BIOS/Legacy mode. Whichever mode we load the Ubuntu installer in that is the mode Ubuntu will be installed in.

    To quote Boot Repair

    This live-session is not in EFI-mode.
    To quote you

    The BIOS settings are UEFI hybrid,
    Lubuntu is installed in BIOS/Legacy mode but the motherboard is running UEFI hybrid. The two modes are incompatible.

    You have two options. 1) Enter the UEFI setting utility and change the setting from UEFI hybrid to BIOS/CSM/Legacy. 2) Keep the UEFI setting as UEFI hybrid or as UEFI and then re-install. Run the Ubuntu installer in UEFI mode. Let it format sda as GPT and install Ubuntu. This is the better option. In this way Ubuntu/Lubuntu will be installed in UEFI mode matching the setting in the UEFI. And the new OS should boot.

    Regards
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  3. #3
    Join Date
    May 2021
    Beans
    11

    Re: Can't boot Lubuntu 20.04 after installation

    Hehe, thank you for the little lesson!

    I am pretty sure I'm loading in UEFI hybrid - with CSM. I've reinstalled it since booting in UEFI, but I did also try installing it in Legacy. It's all been quite confusing and messy!

    In all attempts it hasn't booted. It is installed as sda though, rather than GPT.

    The way in which I've been installing it, is loading the usb drive from the BIOS menu which boots the live OS, and then I click the Install icon on the desktop.

    The only other option is to do the OEM install?

    Thank you for your help!

  4. #4
    Join Date
    May 2021
    Beans
    11

    Re: Can't boot Lubuntu 20.04 after installation

    I did see one more option - to load it with EFI (from the BIOS menu) but the one reference I found to this in other forums didn't work.

  5. #5
    Join Date
    May 2021
    Beans
    11

    Re: Can't boot Lubuntu 20.04 after installation

    I just ran the BIOS F10, and UEFI is definitely selected, and it's been reinstalled since I last switched it.

  6. #6
    Join Date
    May 2021
    Beans
    11

    Re: Can't boot Lubuntu 20.04 after installation

    Running in Legacy mode:
    https://paste.ubuntu.com/p/W5DPCMByjp/

  7. #7
    Join Date
    May 2021
    Beans
    11

    Re: Can't boot Lubuntu 20.04 after installation

    Ok, so.... I'm flummoxed. I think maybe I need to manually create a /boot partition. And maybe an LVM to host it?

    Calamares/the installer doesn't like my partitioning attempts. Not sure where to go from here.

  8. #8
    Join Date
    May 2021
    Beans
    11

    Re: Can't boot Lubuntu 20.04 after installation

    I'm also flummoxed as to why I'm in UEFI mode but the boot-repair says I'm not.

  9. #9
    Join Date
    Jun 2019
    Location
    Dirndl-land
    Beans
    749
    Distro
    Lubuntu 20.04 Focal Fossa

    Re: Can't boot Lubuntu 20.04 after installation

    How do you partition your disk during installation?

  10. #10
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Can't boot Lubuntu 20.04 after installation

    Both reports show grub installed correctly to MBR for BIOS boot.
    You just need to confirm your UEFI/BIOS is set for BIOS/CSM boot.

    My motherboard (Asus) would only boot in UEFI mode with UEFI only. It has a UEFI or BIOS boot mode, but any attempt to boot in UEFI mode with the dual option only tried to boot in BIOS mode. Since UEFI install, it failed.
    So better to have CSM or BIOS only boot mode, since install is BIOS.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •