Results 1 to 5 of 5

Thread: Kern.log is filling up with i2c errors

  1. #1
    Join Date
    Apr 2021
    Beans
    3

    Kern.log is filling up with i2c errors

    I've been installing a new Ubuntu Server 20.04 system and all is going fine, except there is a (apparently non fatal) i2c error flooding the kern.log

    Code:
    Apr 27 05:17:37 srv01 kernel: [31398.980494] i2c i2c-3: sendbytes: NAK bailout.
    Apr 27 05:17:57 srv01 kernel: [31419.460807] i2c i2c-3: sendbytes: NAK bailout.
    Apr 27 05:20:11 srv01 kernel: [31552.579808] i2c i2c-3: sendbytes: NAK bailout.
    Apr 27 05:20:31 srv01 kernel: [31573.059753] i2c i2c-3: sendbytes: NAK bailout.
    Apr 27 05:21:33 srv01 kernel: [31634.499618] i2c i2c-3: sendbytes: NAK bailout.
    Apr 27 05:22:03 srv01 kernel: [31665.219176] i2c i2c-3: sendbytes: NAK bailout.
    Apr 27 05:22:34 srv01 kernel: [31695.939112] i2c i2c-3: sendbytes: NAK bailout.
    Apr 27 05:23:05 srv01 kernel: [31726.659046] i2c i2c-3: sendbytes: NAK bailout.
    Apr 27 05:23:35 srv01 kernel: [31757.378968] i2c i2c-3: sendbytes: NAK bailout.
    Apr 27 05:24:57 srv01 kernel: [31839.298770] i2c i2c-3: sendbytes: NAK bailout.
    i2cdetect says it's a radeon thing
    Code:
    i2c-3   i2c             Radeon i2c bit bus 0x90                 I2C adapter
    I believe its a sensor, might be the fan? Thing is this is a fanless card (only really needed during installation as the system is headless most of the time).

    It doesn't seem to do any harm but I hate it filling the log this way, so:

    Can I disable this sensor somehow?


    Any help/pointers would be appreciated.

  2. #2
    Join Date
    Nov 2012
    Location
    Halloween Town
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Kern.log is filling up with i2c errors

    Thread moved to Server Platforms for a better fit

  3. #3
    Join Date
    Aug 2020
    Location
    Denmark
    Beans
    70
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Kern.log is filling up with i2c errors

    I gave an answer to this on AskUbuntu.com

    https://askubuntu.com/questions/1324...o-much/1324384

    Just replace the "contain" string with something else, for instance:

    Code:
    if $msg contains "i2c-3: sendbytes" then { stop }
    Last edited by slickymaster; April 27th, 2021 at 04:40 PM. Reason: code tags
    Supermicro Server :: Atom C3558 (4) @ 2.2 GHz :: 32 GB DDR4-2400 :: 512 GB NVMe :: 4x 2 TB SSD @ RAID-Z :: 1x Raspberry Pi 4 Server

    Scripts: directory-tools | rsync-backup | add-apt-key

  4. #4
    Join Date
    Apr 2021
    Beans
    3

    Re: Kern.log is filling up with i2c errors

    Quote Originally Posted by ameinild View Post
    I gave an answer to this on AskUbuntu.com
    Thanks.

    That is certainty a last resort option, but I was hoping on a more elegant solution.

    Also I read the i2c-3 label can change between boots.

    Anyone knows of a (kernel parameter) setting to exclude the 0x90 radeon sensor.

    Or a way to determine what is pulling that sensor and make it stop doing that.

    I'm not running lm-sensors but I did notice the /etc/sensors3.conf. It, however, does not contain an obvious reference to the problem sensor.

  5. #5
    Join Date
    Apr 2021
    Beans
    3

    Re: Kern.log is filling up with i2c errors

    Just an update, for people having similar issues.

    I still don't know what the core cause of this issue is, but it went away when I disconnected the monitor.

    So it seems it has nothing to do with sensors at all, maybe it doesn't like the monitor switch or the card has some problems with the old 'vga' port.

    Anyhow, as this is a headless system anyway it solves the issue for me.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •