Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Graphics issues even after fresh 20.04 install

  1. #1
    Join Date
    Apr 2021
    Beans
    9

    Graphics issues even after fresh 20.04 install

    Hey everybody, I'm struggling to resolve what seems to be a graphics problem. It started a few days ago, and I've done a fresh install to see if that resolves it, but I'm still having issues.

    I'm not really sure how to describe what I'm seeing, and I'm having trouble attaching a short video/gif to show it. Basically in Firefox text and images appear and disappear, and text changes into what looks like wingdings, and then changes back. The other day Zoom froze completely in a call, although the sound continued to work fine.

    If any of the above sounds familiar and you have a fix, I'd really appreciate it.

  2. #2
    Join Date
    May 2013
    Location
    Galiza
    Beans
    4,010
    Distro
    Ubuntu

    Re: Graphics issues even after fresh 20.04 install

    Welcome.

    Please post hardware specifications, particularly graphics.

  3. #3
    Join Date
    Nov 2009
    Beans
    Hidden!
    Distro
    Kubuntu 18.04 Bionic Beaver

    Re: Graphics issues even after fresh 20.04 install

    publish video on you tube, make it view with link only and post the link. though maybe you cant' post links since you are new.

    garbled image with text items could mean GPU is failing. does it go green or black when it does that? another thing it could happen is overheating.

    psensor can show the temperature in nice format. if it fails when hot, then you could try to clean it from dust using compressed air. make sure the fans spin well.
    phoronix test suite can strain the card with one of it's tests. if it fails under pressure during the test then it is time to change it. but nowadays they are pricy.

    if it's a laptop, then it's a problem.

    also make sure correct drivers are installed and card is recognised well.

    Code:
    inxi -Fz
    command will give all system info and you can copy it and paste it here. another one that is a bit less nice is but will do fine is
    Code:
    lshw -sanitize
    or there should be a GUI interface that dispalys hardware info (maybe infocenter or something like that - i use Kubuntu so i don't know what is on Ubuntu but we have kinfocenter)
    Read the easy to understand, lots of pics Ubuntu manual.
    Do i need antivirus/firewall in linux?
    Full disk backup (newer kernel -> suitable for newer PC): Clonezilla
    User friendly full disk backup: Rescuezilla

  4. #4
    Join Date
    Apr 2021
    Beans
    9

    Re: Graphics issues even after fresh 20.04 install

    Thank you for taking the time to respond, I appreciate it. I made a short video then thought perhaps I could turn it into a gif, but the gif wound up being more MB than the mp4!

    The video is here, hopefully the link will work - https://youtu.be/Dk7wJHwzpGI

  5. #5
    Join Date
    Apr 2021
    Beans
    9
    I can't seem to upload an image of the summary from Ubuntu, but basically it's as follows:

    Code:
    Memory - 3.8gb
    Processor - Intel Core i5-4200u CPU @ 1.60ghz x 4
    Graphics - Intel HD Graphics 4400 (HSW GT2)
    The machine is about 8 years old!
    Code:
    guy@guy-MMLP5AP-00:~$ inxi -Fz
    System:
      Kernel: 5.8.0-50-generic x86_64 bits: 64 Desktop: Gnome 3.36.7 
      Distro: Ubuntu 20.04.2 LTS (Focal Fossa) 
    Machine:
      Type: Laptop System: GIGABYTE product: MMLP5AP-00 v: 1.x serial: <filter> 
      Mobo: GIGABYTE model: MMLP5AP-00 v: 1.x serial: <filter> 
      UEFI: American Megatrends v: F4 date: 12/03/2013 
    CPU:
      Topology: Dual Core model: Intel Core i5-4200U bits: 64 type: MT MCP 
      L2 cache: 3072 KiB 
      Speed: 798 MHz min/max: 800/2600 MHz Core speeds (MHz): 1: 805 2: 798 
      3: 801 4: 836 
    Graphics:
      Device-1: Intel Haswell-ULT Integrated Graphics driver: i915 v: kernel 
      Display: x11 server: X.Org 1.20.9 driver: i915 resolution: 1920x1080~60Hz 
      OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) 
      v: 4.5 Mesa 20.2.6 
    Audio:
      Device-1: Intel Haswell-ULT HD Audio driver: snd_hda_intel 
      Device-2: Intel 8 Series HD Audio driver: snd_hda_intel 
      Device-3: Logitech OrbiCam type: USB driver: snd-usb-audio,uvcvideo 
      Sound Server: ALSA v: k5.8.0-50-generic 
    Network:
      Device-1: Realtek RTL8723AE PCIe Wireless Network Adapter 
      driver: rtl8723ae 
      IF: wlp2s0 state: down mac: <filter> 
      Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
      driver: r8169 
      IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
    Drives:
      Local Storage: total: 111.79 GiB used: 13.94 GiB (12.5%) 
      ID-1: /dev/sda vendor: Crucial model: CT120M500SSD3 size: 111.79 GiB 
    Partition:
      ID-1: / size: 105.18 GiB used: 13.93 GiB (13.2%) fs: ext4 dev: /dev/sda6 
    Sensors:
      System Temperatures: cpu: 56.0 C mobo: N/A 
      Fan Speeds (RPM): N/A 
    Info:
      Processes: 229 Uptime: 6h 09m Memory: 3.76 GiB used: 2.15 GiB (57.2%) 
      Shell: bash inxi: 3.0.38
    Last edited by deadflowr; April 18th, 2021 at 05:47 PM. Reason: merged posts; added code tags

  6. #6
    Join Date
    Nov 2009
    Beans
    Hidden!
    Distro
    Kubuntu 18.04 Bionic Beaver

    Re: Graphics issues even after fresh 20.04 install

    saw it on you tube. this is your GPU chip: Intel HD Graphics 4400

    it uses opensource driver supported &made by Intel which is in kernel.

    it look like a display issue. Are you using wayland or xorg? at the login you should be able to chose and try to switch to the old xorg. i also saw something similar at my kids computer, but let's first try the xorg.
    Read the easy to understand, lots of pics Ubuntu manual.
    Do i need antivirus/firewall in linux?
    Full disk backup (newer kernel -> suitable for newer PC): Clonezilla
    User friendly full disk backup: Rescuezilla

  7. #7
    Join Date
    Apr 2021
    Beans
    9

    Re: Graphics issues even after fresh 20.04 install

    Thanks for your reply. I just logged out and logged back in so I could check which of those two I was using, and it looks like I was using Xorg. I've now switched over to Wayland, and things are different, but still basically unusable once the graphics deteriorate past a certain point; stuff disappears, reappears, blocks of colour come and go. It's weird!

  8. #8
    Join Date
    Sep 2009
    Location
    Pennsylvania
    Beans
    3,434
    Distro
    Xubuntu

    Re: Graphics issues even after fresh 20.04 install

    Have yo tried pulling the cover and checking that all fans are clean and functioning?

  9. #9
    Join Date
    Nov 2009
    Beans
    Hidden!
    Distro
    Kubuntu 18.04 Bionic Beaver

    Re: Graphics issues even after fresh 20.04 install

    it can be caused by overheating but that one usually freezes or you would see it turn off and back on.

    another option really is failing chip or also something with RAM (since this GPU uses computer RAM). to test the ram, memtest is available on Ubuntu boot/install disk. does this happen immediately when you start it up or after some time of usage?

    for GPU i don't know hot to test it. i saw similar strange behaviour on Ryzen - for example the widnows won't display properly and this already showed at boot. but that issue is supposed to be only on AMD.and you have Intel.
    Read the easy to understand, lots of pics Ubuntu manual.
    Do i need antivirus/firewall in linux?
    Full disk backup (newer kernel -> suitable for newer PC): Clonezilla
    User friendly full disk backup: Rescuezilla

  10. #10
    Join Date
    Apr 2021
    Beans
    9

    Re: Graphics issues even after fresh 20.04 install

    Have yo tried pulling the cover and checking that all fans are clean and functioning?



    Yes I did. There was a surprising amount of dust in there, and it's something that I'll keep an eye on more closely in the future. Unfortunately, the cleaning didn't yield any ongoing benefits in terms of the problem I've been experiencing. But thanks!
    Last edited by guybutterworth; April 21st, 2021 at 09:19 AM.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •