Results 1 to 9 of 9

Thread: Package dependencies cannot be resolved

  1. #1
    Join Date
    Dec 2006
    Location
    Alsace
    Beans
    1,061
    Distro
    Ubuntu 20.04 Focal Fossa

    Package dependencies cannot be resolved

    Hi!

    13 April 2021, Software Updater offered me an update for my 20.10 including Kernel 5.8.0.49.54, which I tried to install, but the installation failed with the error message:
    Code:
    Package dependencies cannot be resolved
    This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.
    Transaction failed: Package dependencies cannot be resolved
     The following packages have unmet dependencies:
    
    grub-efi-amd64-signed: Depends: grub2-common (>= 2.02~beta2-36ubuntu3.31) but 2.04-1ubuntu35.6 is to be installed
    I decided to just wait, hoping the problem would be sorted out at the next update.

    Today I was offered the next update, including kernel 5.8.0.50.53 but I have the same error message...

    No idea how to handle this!

    Thanks for any help!
    Acer Aspire TC-100-007: Multi boot W10 / 20.10 / 18.04 LTS: Canon TS705: Epson V200: also Asus 1015PED: W7 / 18.04 Lubuntu

  2. #2
    Join Date
    May 2013
    Location
    Galiza
    Beans
    4,010
    Distro
    Ubuntu

    Re: Package dependencies cannot be resolved

    Please try, in terminal:
    Code:
    sudo apt update
    sudo apt full-upgrade
    Post back any errors.

  3. #3
    Join Date
    Aug 2011
    Location
    51.8° N 5.8° E
    Beans
    5,805
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Package dependencies cannot be resolved

    What does
    Code:
    apt-cache policy grub-efi-amd64-signed
    tell you?

    2.04-1ubuntu35.6 is the correct version for grub2-common on 20.10, so it looks like something strange is going on with your grub-efi-amd64-signed. It shouldn't depend on grub2-common at all – at least, not directly.

  4. #4
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Package dependencies cannot be resolved

    Have you in the past enabled any extra repos temporarily, eg third party PPAs or perhaps the "proposed" repos which have given you package versions that require dependencies that are now unavailable if those repos are no longer enabled.

  5. #5
    Join Date
    May 2010
    Beans
    1,270

    Re: Package dependencies cannot be resolved

    I'm betting this is PPA based

  6. #6
    Join Date
    Dec 2006
    Location
    Alsace
    Beans
    1,061
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Package dependencies cannot be resolved

    Well - thank you all for your contributions!

    I ran
    Code:
    sudo apt update
    sudo apt full-upgrade
    which worked OK with no error messages & I am now running 5.8.0.50.53 with no problems.

    I just wonder what the explanation is & whether that is the end of the story or not?

    On the PPA's (which I looked at before running apt) there has been no recent activity.
    Many years ago, I enabled the PPA for Grub Customizer.
    GC is still installed & active, and thought I had found something significant when I just noticed that that PPA had been disactivated at previous upgrades, but in fact it seems to be no longer required & GC is available directly in the repos, so I suppose that is not relevant?
    3 other old PPA's have also been disactivated at previous upgrades but they relate to programs no longer installed (Drawers, Variety, Canon printer) so I suppose are not relevant either.
    Finally the PPA for David lynch's Rapid-Photo-Downloader is also disactivated.
    RPD is installed & in use.
    David Lynch seems to have stopped using the PPA and started using some direct-installation method I had never heard about.
    I am not using the latest version of RPD on his site, but SynApt thinks my version is the latest so I suppose is not trying to take any action?

    As for Impavidus's question & statement - sorry, I don't begin to understand...

    Thanks again for your help!
    Acer Aspire TC-100-007: Multi boot W10 / 20.10 / 18.04 LTS: Canon TS705: Epson V200: also Asus 1015PED: W7 / 18.04 Lubuntu

  7. #7
    Join Date
    May 2021
    Beans
    1

    Re: Package dependencies cannot be resolved

    Quote Originally Posted by 2CV67 View Post
    Code:
    grub-efi-amd64-signed: Depends: grub2-common (>= 2.02~beta2-36ubuntu3.31) but 2.04-1ubuntu35.6 is to be installed
    Today I got the same error from the graphical Software Updater on my Ubuntu 20.04 (that had not been updated for a while). Only the version numbers are a bit different:
    Code:
    grub-efi-amd64-signed: Depends: grub2-common (>= 2.02~beta2-36ubuntu3.31) mutta 2.04-1ubuntu26.11 tullaan asentamaan
    But
    Code:
    sudo apt update
    sudo apt upgrade
    installed more updates than Software Updater would, and solved the problem.

    Only PPA I have is Google Chrome that had been disabled by an upgrade.

  8. #8
    Join Date
    May 2010
    Beans
    1,270

    Re: Package dependencies cannot be resolved

    I bet PPAs are afoot

  9. #9
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Package dependencies cannot be resolved

    If any PPAs are to blame for this, and we still don't really know, you could try installing ppa-purge and running it to remove the repositories and replace any packages from those errant PPAs with the default Ubuntu repo version, or if there is no default version just to remove the problem pakages.

    If this problem stems from a PPA or its packages you may solve it by getting rid of those packages.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •