Results 1 to 4 of 4

Thread: Touchpad hotkey toggle doesn't work

  1. #1
    Join Date
    Apr 2018
    Beans
    5

    Question Touchpad hotkey toggle doesn't work

    Hotkey toggle doesn't work with Ubuntu 20.10 on my Lenovo L340. I tried to use 2 workarounds I found online: creating a script* to manually switch xinput and xdotool, then creating a new shortcut. Both work in the terminal, but won't work properly once I create the shortcut!
    The shortcut using xinput only DISABLE the touchpad. But if a run the very same script on terminal, it will enable it back.
    The command xdotool key XF86TouchpadToggle seems to not work at all once set the shortcut, but works on the terminal.

    guides I followed:
    https://askubuntu.com/questions/1165...board-shortcut
    https://goinglinux.com/articles/Togg...ouchPad_en.htm

    *This is the exact script I used:

    if [[ $(xinput list 13 | grep -Ec "disabled") -eq 1 ]]; then
    xinput enable 13
    else
    xinput disable 13
    fi

    exit 0

  2. #2
    Join Date
    Apr 2007
    Beans
    2,912
    Distro
    Ubuntu

    Re: Touchpad hotkey toggle doesn't work

    Just use the standard "Keyboard settings" under "Settings" to assign the script to a shortcut key.

  3. #3
    Join Date
    Apr 2018
    Beans
    5

    Re: Touchpad hotkey toggle doesn't work

    Hi! I tried to use a script assigned to a shortcut, it works but only to deactivate the touchpad. When I run the very same script on the terminal, it works properly

  4. #4
    Join Date
    Apr 2007
    Beans
    2,912
    Distro
    Ubuntu

    Re: Touchpad hotkey toggle doesn't work

    Strange. IF the script runs well, it should run equally well from a shortcut. Can you activate the touchpad from a shortcut with only the command " xinput enable 13"?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •