Results 1 to 3 of 3

Thread: 20.04 LTS Server - ethernet randomly stopped working & I don't know how to restart it

  1. #1
    Join Date
    Apr 2021
    Beans
    3

    20.04 LTS Server - ethernet randomly stopped working & I don't know how to restart it

    My system boots OK, I can only access it via command line terminal keyboard/monitor as the ethernet connection is completely down. If I boot from USB, the hardware is fine and it gets allocated an IP address, so this is a config issue. I have no GUI's or copy/paste from another system, just what I can type on the terminal.

    Code:
    lshw -C network
    reports
    Code:
    *-network DISABLED
    Code:
    ip link set enp4s0 up
    enables it - at least DISABLED goes away and the lights start flashing on the ethernet port

    Code:
    ip addr
    tells me that enp4s0 has no inet4 IP address

    Code:
    netplan --debug get all
    reports:
    Code:
    DEBUG:enp4s0 not found in {}
    DEBUG:Merged config:
    network:
      ethernets:
        enp4s0:
          dhcp: true
      version: 2
    
    network:
      ethernets:
        enp4s0:
          dhcp: true
      version: 2
    Note - it's not {} above, but I don't know how to create the weird curly brackets that are there!

    As it's a 20.04 server, the renderer is systemd-networkd, but I'm not sure how to check if the files created there are correct. I've also read some stuff about needing to tell network that my ethernet is 'unmanaged'.

    Code:
    systemctl status systemd-networkd.service
    is running and restarting it doesn't change anything

    Code:
    netplan --debug try
    reports (sorry pasted image, as it's too much typing!)


    Clearly, I could just rebuild the server from scratch, but given that it's fundamentally working, there must be a simpler way to solve my problem?

    The system doesn't have WiFi and I don't have a PCI or USB network adapter to try either.

    Help gratefully received. Thanks, Mark

  2. #2
    Join Date
    Apr 2021
    Beans
    3

    Re: 20.04 LTS Server - ethernet randomly stopped working & I don't know how to restar

    Just read some more about this and it seems I'm not alone and it's down to a netplan.io and libnetplan0 update, where one updates to v.102 and not the other and being out of sync breaks things. If I download both to a USB stick, copy to my server and install both, it should fix my problem

  3. #3
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    7,929
    Distro
    Ubuntu Mate 20.04 Focal Fossa

    Re: 20.04 LTS Server - ethernet randomly stopped working & I don't know how to restar

    What hardware is it? Please show
    Code:
    lspci -nnk
    lsmod

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •