Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 33

Thread: Grub recovery not successful

  1. #21
    tea for one is offline Chocolate-Covered Ubuntu Beans
    Join Date
    May 2008
    Beans
    1,405
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Grub recovery not successful

    As indicated by oldfred, it looks like grub may need a tweak.
    If it is any help, here is a copy of /etc/default/grub, where grub appears after power on and provides a 10 second delay for OS selection.
    Code:
    GRUB_DEFAULT=0
    GRUB_TIMEOUT_STYLE=menu
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    #GRUB_DISTRIBUTOR="Ubuntu 20.04"
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""

  2. #22
    Join Date
    Mar 2006
    Location
    Cuddalore,India.
    Beans
    17
    Distro
    Ubuntu Breezy 5.10

    Re: Grub recovery not successful

    Quote Originally Posted by oldfred View Post
    I did not see this in your Boot-Repair summary report.
    Post this in code tags.

    cat /etc/default/grub
    cat /etc/default/grub displays the following:

    Code:
    superadmin@superadmin-Inspiron-7537:~$ cat /etc/default/grub
    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    # For full documentation of the options in this file, see:
    #   info -f grub -n 'Simple configuration'
    
    GRUB_DEFAULT="menuentry 'Windows Boot Manager (on /dev/sda2)' --class windows --class os  'osprober-efi-5E75-94AD' {"
    GRUB_TIMEOUT_STYLE=hidden
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""
    
    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
    
    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480
    
    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true
    
    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_RECOVERY="true"
    
    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"
    superadmin@superadmin-Inspiron-7537:~$
    Thank you!

  3. #23
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Grub recovery not successful

    Change this as also shown in tea for one's version:
    GRUB_TIMEOUT_STYLE=hidden
    to this:
    GRUB_TIMEOUT_STYLE=menu

    sudo nano -B /etc/default/grub
    Control x and save when exiting.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  4. #24
    tea for one is offline Chocolate-Covered Ubuntu Beans
    Join Date
    May 2008
    Beans
    1,405
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Grub recovery not successful

    After editing the grub file, do not forget to run:-
    Code:
    sudo update-grub

  5. #25
    Join Date
    Mar 2006
    Location
    Cuddalore,India.
    Beans
    17
    Distro
    Ubuntu Breezy 5.10

    Re: Grub recovery not successful

    I have changed and saved
    Code:
    GRUB_TIMEOUT_STYLE=menu
    and then ran
    Code:
    sudo update-grub
    unfortunately, still the menu is not displayed.

  6. #26
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Grub recovery not successful

    I do not know if it is going to show anything or not, but run a new copy of the report from Boot-Repair and post link.
    Do not run any suggested autofixes.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  7. #27
    Join Date
    Mar 2006
    Location
    Cuddalore,India.
    Beans
    17
    Distro
    Ubuntu Breezy 5.10

    Re: Grub recovery not successful

    The new Boot-Repair report summary is in the following link

    https://paste.ubuntu.com/p/J7RWc3Cyg2/

  8. #28
    tea for one is offline Chocolate-Covered Ubuntu Beans
    Join Date
    May 2008
    Beans
    1,405
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Grub recovery not successful

    Code:
    GRUB_DEFAULT="menuentry 'Windows Boot Manager (on /dev/sda2)' --class windows --class os  'osprober-efi-5E75-94AD' {"
    As an experiment, I would also change this line as follows:-
    Code:
    GRUB_DEFAULT=0
    Followed by
    Code:
    sudo-update-grub
    Worth a shot..............?

    Posted before your new boot-repair report
    Last edited by tea for one; 4 Weeks Ago at 08:27 PM. Reason: Posted before your new boot-repair report

  9. #29
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Grub recovery not successful

    https://help.ubuntu.com/community/Gr...ecific_Entries

    I think your description entry has too much. It should be just what os-prober would have grub menu show.
    Probably just
    'Windows Boot Manager (on /dev/sda2)'
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  10. #30
    Join Date
    Mar 2006
    Location
    Cuddalore,India.
    Beans
    17
    Distro
    Ubuntu Breezy 5.10

    Re: Grub recovery not successful

    Thank you so much for taking quiet a lot of effort in helping me! I really appreciate it!!

    When I tried
    Code:
    GRUB_DEFAULT=0
    it was still going into Ubuntu directly

    When I tried
    Code:
    GRUB_DEFAULT="Windows Boot Manager (on /dev/sda2)"
    it was booting Windows directly without giving any option.

    Interestingly, I found that irrespective of GRUB_DEFAULT, the grub menu is displayed when I press F12 and then select 'Ubuntu' while booting.

    I have a made a video recording of this to help understand it better. You can find it here
    https://youtu.be/5OS7qdgxdHI

    PS:
    1. I never saw the Grub menu from the time I installed Ubuntu as dual boot. The machine always used to boot into Windows by default (until I tried Boot Repair). If I wanted to go into Ubuntu, I used to press F12 while booting and then choose 'Hard Drive' under the Legacy Boot section (as if my Windows were present outside of my hard drive).
    2. My system time in Windows always resets (probably to GMT/UT) every time I go into Ubuntu and then I go back into Windows.


    Probably the Grub menu getting displayed after selecting Ubuntu, having to select 'Hard Drive' in boot options menu to go into Ubuntu, the time getting resetting in Windows every time I boot into Ubuntu are all connected.

Page 3 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •