Dear users,

happy easter!

Meantime, I'm delighting to set up a virtual host on apache2 server. My VPS has ubuntu server edition.

I have a directory which will be the root directory of a website. That is /srv/sites/fish

The VH configuration file is this:

Code:
User chandelier
Group chandelier

<Directory /srv/sites/fish/>
        Options Indexes FollowSymLinks
        AllowOverride All
        Require all granted
</Directory>

<VirtualHost *:80>
        # The ServerName directive sets the request scheme, hostname and port t$
        # the server uses to identify itself. This is used when creating
        # redirection URLs. In the context of virtual hosts, the ServerName
        # specifies what hostname must appear in the request's Host: header to
        # match this virtual host. For the default virtual host (this file) this
        # value is not decisive as it is used as a last resort host regardless.
        # However, you must set it for any further virtual host explicitly.
        ServerName mywebsite.com

        ServerAdmin me@here
        DocumentRoot /srv/sites/fish

        # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
        # error, crit, alert, emerg.
        # It is also possible to configure the loglevel for particular
        # modules, e.g.
        #LogLevel info ssl:warn

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/fish.log combined

        # For most configuration files from conf-available/, which are
        # enabled or disabled at a global level, it is possible to
        # include a line for only one particular virtual host. For example the
        # following line enables the CGI configuration for this host only
        # after it has been globally disabled with "a2disconf".
        #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
And the directory is this:

Code:
root@myvps:/srv/sites/fish# ls -ahl
total 16K
drwxrw----  3 chandelier chandelier    4,0K apr  4 17:52 .
drwxrwxr-x 13 peter  admin    4,0K mar 29 00:37 ..
-rwxrw----  1 chandelier chandelier   88 apr  4 17:50 index.htm
drwxrw---- 15 chandelier chandelier    4,0K apr  3 14:07 wiki
Now when I try to visit my website from browser, I get 403 error. I want to run apache2 as chandelier user in this virtual host.

I think this is a permission error. I did a mistake, but I don't know where.

How can I fix?

Thanks