Results 1 to 4 of 4

Thread: error while loading shared libraries: libssl.so.1.1: invalid ELF header

  1. #1
    Join Date
    Apr 2021
    Beans
    3

    error while loading shared libraries: libssl.so.1.1: invalid ELF header

    Ubuntu server 20.04.

    After a power outage I could not connect to Ubuntu server with webmin, and webmin reported that libnet-ssleay-perl was not installed. I know it is though.

    After more investigation I find that openssl must be corrupted. 'openssl version' reports 'error while loading shared libraries: /lib/x86_64-linux-gnu/libssl.so.1.1: invalid ELF header'.

    I've tried 'apt-get --reinstall -install' on openssl, libnet-ssleay-perl, etc. without any success and searches of invalid ELF header don't find anything helpful either.

    Can this issue be fixed?

    Thanks.

  2. #2
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    15,602
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: error while loading shared libraries: libssl.so.1.1: invalid ELF header

    libssl1.1 is a separate package. From "apt-cache search libssl"

    libssl1.1 - Secure Sockets Layer toolkit - shared libraries

    Try reinstalling that.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  3. #3
    Join Date
    Apr 2021
    Beans
    3

    Re: error while loading shared libraries: libssl.so.1.1: invalid ELF header

    Quote Originally Posted by SeijiSensei View Post
    libssl1.1 is a separate package. From "apt-cache search libssl"

    libssl1.1 - Secure Sockets Layer toolkit - shared libraries

    Try reinstalling that.

    Thank you much for the suggestion. That doesn't seem to have any effect.

    Without further ideas, I'm beginning to think I'm just going to have to reinstall Ubuntu completely.

  4. #4
    Join Date
    Apr 2021
    Beans
    3

    Re: error while loading shared libraries: libssl.so.1.1: invalid ELF header

    So, I finally fixed this and I thought I would post what fixed it for me in case it might be of assistance to others.

    Here is what I did to fix it:

    sudo rm /var/lib/apt/lists/lock
    sudo rm /var/lib/dpkg/lock
    sudo rm /var/lib/dpkg/lock-frontend
    sudo dpkg --configure -a
    sudo apt clean
    sudo apt update --fix-missing
    sudo apt install -f
    sudo dpkg --configure -a
    sudo apt upgrade
    sudo apt dist-upgrade
    sudo reboot
    sudo dpkg -P webmin
    sudo reboot
    sudo apt-get update
    sudo apt-get --reinstall install libapt-pkg-perl libnet-ssleay-perl libauthen-pam-perl libio-pty-perl apt-show-versions
    sudo apt-get install webmin
    sudo reboot

    Now everything seems to be working.
    Last edited by swcoffin; April 14th, 2021 at 10:49 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •