Ubuntu server 20.04.

After a power outage I could not connect to Ubuntu server with webmin, and webmin reported that libnet-ssleay-perl was not installed. I know it is though.

After more investigation I find that openssl must be corrupted. 'openssl version' reports 'error while loading shared libraries: /lib/x86_64-linux-gnu/libssl.so.1.1: invalid ELF header'.

I've tried 'apt-get --reinstall -install' on openssl, libnet-ssleay-perl, etc. without any success and searches of invalid ELF header don't find anything helpful either.

Can this issue be fixed?

Thanks.