Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 47

Thread: Fat32, UEFI, Reserved BIOS boot area?

  1. #21
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    8,315
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: Fat32, UEFI, Reserved BIOS boot area?

    Quote Originally Posted by webmanoffesto View Post
    Do I need to do all this?
    Not if you can invoke the Grub menu, no. Then you'd just edit the boot line to see if your fix works, then make it permanent if it does.

    Otherwise, you can make the change permanent without testing with the chroot environment. I think you do need the bind mounts to the pseudo-filesystems, too, so that the update-grub script knows where to find things to set them up properly.

    The process is quite straightforward: since your own install isn't booting, you use the infrastructure of the live USB, which can boot. Then you change the root of the commands that you're running, so that they take effect as if they were running on your install. It's a very useful troubleshooting thing.

    I have no idea if the fix you've found will have any effect, and I don't know how hard you've tried to bring up the Grub menu as an alternative, but the chroot method is a way that you can change your boot options without being able to boot and without having access to the Grub menu.

  2. #22
    Join Date
    May 2010
    Beans
    245

    Re: Fat32, UEFI, Reserved BIOS boot area?

    Quote Originally Posted by ActionParsnip View Post
    If it's not dual boot, why use UEFI ?
    I'm really confused about this whole UEFI thing. I got a good price on the laptop, but now I'm fed up with this whole UEFI thing.
    Following the advice in one of the comments above I enabled Secure Boot, and then all I could get was "Selected boot image did not authenticate." Then I disabled secure boot, but now I'm back to the endless scrolling "pcieport 0000:00:1c.5: AER: PCIE Bus Error"
    Last edited by webmanoffesto; April 4th, 2021 at 11:15 PM.

  3. #23
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    8,315
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: Fat32, UEFI, Reserved BIOS boot area?

    Quote Originally Posted by webmanoffesto View Post
    Following the advice in one of the comments above I enabled Secure Boot, and then all I could get was "Selected boot image did not authenticate."
    No one here told you to enable Secure Boot.

  4. #24
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Fat32, UEFI, Reserved BIOS boot area?

    Since you did not install in UEFI Secure Boot mode, do not turn that on.

    This says it may be an UEFI setting.
    https://askubuntu.com/questions/8631...0e5receiver-id

    With UEFI, you press escape key, perhaps more than once as finding the correct time between UEFI screen & when grub normally appears can be tricky. You then should get grub menu.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  5. #25
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    8,315
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: Fat32, UEFI, Reserved BIOS boot area?

    Quote Originally Posted by webmanoffesto View Post
    I'm really confused about this whole UEFI thing.
    UEFI is the replacement for BIOS. It's the firmware for your computer. It overcomes a lot of the limitations that BIOS had. Because BIOS is so ancient and limited, your UEFI can emulate BIOS. That's what the Compatibility Support Module does. Booting in Legacy mode enables the CSM.

  6. #26
    Join Date
    May 2010
    Beans
    245

    Re: Fat32, UEFI, Reserved BIOS boot area?

    Okay, I have it set to Disable Secure Boot
    then I selected Legacy Boot when booting the Flash Drive which has the Ubuntu 20 image.
    I chose minimal install, don't upload updates, don't install 3rd party items. The install seemed to go very well. All the stages went quickly.
    I have sda1: efi, boot, sda2: root (ext4, reformat), sda3 home (ext4, don't reformat)
    Now when I try to boot the laptop I do F9 Boot menu, I select the legacy boot option.
    And I get a grub prompt: "Gnu Grub version 2.04 Minimal Bash like line editing is supported ... grub>"
    After that I get "Boot Device not found. Please install an operating system on your hard disk. Hard Disk - (3F0)"

    So I tried running Boot Repair Disk. But it said "The current session is in BIOS-compatability mode. Please disable BIOS-compatability/CSM/Legacy mode in your UEFI firmware and use this software from a live CD or live usb that is compatible with uefi booting mode. for example use a live usb of boot repair disk 64 bit ... after making sure your BIOS is in EFI mode. This will enable this feature." What feature? Updating Boot Repair Disk?

    And I was running it off a flash drive (live USB). That is weird.

    And when I Enable Secure Boot then I only get "Selected boot image did not authenticate" and I'm stuck on that screen.
    Last edited by webmanoffesto; April 5th, 2021 at 02:45 AM.

  7. #27
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Fat32, UEFI, Reserved BIOS boot area?

    Did we not say "Do not turn on UEFI Secure Boot". That is just a waste of your time.
    You have to install in UEFI Secure boot mode, which you cannot do if legacy mode is on.

    Please review post #5.
    If you want Legacy you will need a bios_grub partition.
    If you want UEFI you need an ESP. (your FAT32 with boot flag).

    Grub will not properly install to a gpt partitioned drive in BIOS/legacy/CSM mode, unless you have the bios_grub partition.
    And then if you reinstalled in BIOS boot mode and try to boot, you get a grub boot error. You either booted in BIOS mode to a grub that was not fully installed, or booted in UEFI mode and old grub in UEFI mode is then not correct.

    You have to decide if you want UEFI or BIOS/CSM/Legacy. And then always boot installer in that mode and then make sure system is set to boot installed system in that mode.
    And understand what are requirements for your chosen boot mode.

    CSM - UEFI Compatibility Support Module (CSM), which emulates a BIOS mode, only available with secure boot off.

    Note many new systems, now are eliminating CSM. That will simplify installs as then only UEFI installs will work.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  8. #28
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    8,315
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: Fat32, UEFI, Reserved BIOS boot area?

    Quote Originally Posted by webmanoffesto View Post
    And when I Enable Secure Boot
    You seem confused on this point. Secure Boot is designed to make things not work. That is its function. Specifically, it is to prevent the execution of any code that has not been signed by someone that is trusted by the UEFI.

    If something is not working, enabling Secure Boot will not make it work. If something is working, enabling Secure Boot may make it no longer work.

  9. #29
    Join Date
    May 2010
    Beans
    245

    Re: Fat32, UEFI, Reserved BIOS boot area?

    Trying to be more precise, I think someone pointed out that it didn't make sense that I created a mismatch when I 1. disabled Secure Boot but then 2. at the boot menu I booted the flash drive UEFI. Also, I don't really know what I'm doing. I'm hacking on this laptop and hoping that I can get it working.

  10. #30
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    8,315
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: Fat32, UEFI, Reserved BIOS boot area?

    Quote Originally Posted by webmanoffesto View Post
    Trying to be more precise, I think someone pointed out that it didn't make sense that I created a mismatch when I 1. disabled Secure Boot but then 2. at the boot menu I booted the flash drive UEFI. Also, I don't really know what I'm doing. I'm hacking on this laptop and hoping that I can get it working.
    No, you created a mismatch by enabling Legacy and then booting the installer in UEFI mode, which will install in UEFI mode. That combination will not boot after installation. Disabling Legacy and booting the installer in Legacy mode also will not boot after installation.

    Quote Originally Posted by CatKiller View Post
    Use UEFI or use Legacy. Don't mix and match, it won't work.

Page 3 of 5 FirstFirst 12345 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •