I used Oracle VM about 4 years ago ( https://ubuntuforums.org/showthread....2#post13580112 ) and didn't encounter the types of problems with not being able to do file sharing. Seems things have changed since then.

Kubuntu 20.04
Oracle VM Virtual Box Version 6.1.18 r142142 (Qt5.12.8)
Windows 8.1 as the Guest

I can't get shared folders to work at all. They need the "guest additions". Have downloaded the ISO, added that under Virtual box; it recognises the ISO in the settings keep getting a message that the Virtual box guest additions doe snot appear to be available on this virtual machine. Have even tried

sudo apt install virtualbox-guest-dkms
still no go. In further desperation (LOL) I tried adding a USB to see if Windows 8.1 recognises that - nope. The shared folder is setup correctly and is shown under the settings. To be able to use this VM I need to either get shared folders going via Guest Additions or solve the problem of the usb not being recognised.

Reading through a few posts here, there is mention of a product called VMWare, and no doubt there are other tools available. Although I really don't want to have to install Windows 8.1, plus MS Works plus MS Money again in another VM environment, if there is an easier and better tool that "works out of the box" then I will do that.

One other thing, performance is terrible running Windows 8.1 in this VM. It has 40 Gb of hard drive space and only uses about 12 Gb, plus there is 2 Gb ram and have checked whilst it is running and not much over 15% memory being used by it, plus CPU use is low. yet it is so SLOW.