Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: I'm in trouble with the ubuntu upgrade

  1. #1
    Join Date
    Mar 2021
    Beans
    6

    I'm in trouble with the ubuntu upgrade

    Hi all!!!!
    I'm a newbie and i'm approached Ubuntu for my plex server because in windows environment i've got a ransonware and wasted all my precious films.... After that disaster i've chosen to migrate to Ubuntu, but when I try to upgrade the system, somethings goes wrong and i'm stuck to this version:

    Code:
    No LSB modules are available.
    Distributor ID:	Ubuntu
    Description:	Ubuntu 19.10
    Release:	19.10
    Codename:	eoan
    When I try to upgrade Ubuntu from Software Update, the 20.04 Focal fossa starts, I click on "Upgrade", and the procedures stucks at first step, and nothing appears... Could you please help me to made my system up to date?
    I don't know why i'm in this situation, but I need to upgrade my system.
    Thanks in advance.

    Please, remember I'm a newbie!!!!
    Last edited by howefield; March 6th, 2021 at 04:08 PM. Reason: removed obfuscated profanity.

  2. #2
    Join Date
    Oct 2006
    Beans
    57,551

    Re: I'm in trouble with the ubuntu upgrade

    19.10 isn't the version to use given it has reached End of Life. Probably better to clean install 20.04.2 which has a bit more than 4 years of support left.

  3. #3
    Join Date
    Mar 2021
    Beans
    6

    Re: I'm in trouble with the ubuntu upgrade

    Yes, I know. But i've this version and a plex server full of items... It's possible to upgrade this version to focal fossa?

  4. #4
    Join Date
    May 2010
    Beans
    1,360

    Re: I'm in trouble with the ubuntu upgrade

    If you run
    Code:
    sudo do-release-upgrade
    Is it OK? If not then please give the full output. You can upgrade to 20.04 from 19.10 so a reinstall isn't required.

  5. #5
    Join Date
    May 2013
    Location
    Galiza
    Beans
    4,010
    Distro
    Ubuntu

    Re: I'm in trouble with the ubuntu upgrade

    Quote Originally Posted by ActionParsnip View Post
    You can upgrade to 20.04 from 19.10 so a reinstall isn't required.
    Yes and no.
    19.10 is EoL already. The method is different than a release upgrade within the proper time to do it:
    https://help.ubuntu.com/community/EOLUpgrades

  6. #6
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: I'm in trouble with the ubuntu upgrade

    When a Ubuntu release reaches End of Life its repositories or sources are moved to a new location and that is old-releases.ubuntu.com/ubuntu/

    You need to edit a file found at etc/apt/sources.list. You will need to be root to edit that text file. Lines prefixed by a # are comments and can be left alone. Lines like this one have to be changed

    to something like

    After saving that file you should be able to run

    Code:
    sudo apt update
    sudo apt upgrade
    then

    Code:
    sudo do-release-upgrade
    should trigger the upgrade.

    Regards
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  7. #7
    Join Date
    Mar 2021
    Beans
    6

    Re: I'm in trouble with the ubuntu upgrade

    Quote Originally Posted by grahammechanical View Post
    When a Ubuntu release reaches End of Life its repositories or sources are moved to a new location and that is old-releases.ubuntu.com/ubuntu/

    You need to edit a file found at etc/apt/sources.list. You will need to be root to edit that text file. Lines prefixed by a # are comments and can be left alone. Lines like this one have to be changed



    to something like



    After saving that file you should be able to run

    Code:
    sudo apt update
    sudo apt upgrade
    then

    Code:
    sudo do-release-upgrade
    should trigger the upgrade.

    Regards

    Thank for all your help, but I'm stuck in trouble. Yes, I know, the script attached is in italian, I don't know how to change default language to made one in english, but I hope you'll find the problem also if it's in italian...

    I've made the changes requested , but something goes wrong...

    Code:
    root@LHS3200:/etc/apt# sudo apt-get upgrade
    Lettura elenco dei pacchetti... Fatto
    Generazione albero delle dipendenze       
    Lettura informazioni sullo stato... Fatto
    Calcolo dell'aggiornamento... Fatto
    0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
    root@LHS3200:/etc/apt# sudo do-release-upgrade
    Verifica un nuovo rilascio di ubuntu
    Il rilascio di Ubuntu in uso non è più supportato.
    ERROR:root:incorrect translation for message 'For upgrade information, please visit:
    %(url)s
    ' to 'Per informazioni sull'avanzamento consultare:
    $(url)s
    ' (wrong number of arguments)
    For upgrade information, please visit:
    http://www.ubuntu.com/releaseendoflife
    
    
    Scaricamento di:1 Firma dello strumento di avanzamento versione [1.554 B]      
    Scaricamento di:2 Strumento di avanzamento versione [1.341 kB]                 
    Recuperati 1.343 kB in 0s (0 B/s)                                              
    autenticazione di «focal.tar.gz» con «focal.tar.gz.gpg» 
    estrazione di «focal.tar.gz»
    
    
    Lettura della cache
    
    
    Controllo gestore dei pacchetti
    Lettura elenco dei pacchetti... Fatto
    Generazione albero delle dipendenze        
    Lettura informazioni sullo stato... Fatto 
    Trovato http://old-releases.ubuntu.com/ubuntu eoan InRelease                   
    Trovato http://old-releases.ubuntu.com/ubuntu eoan-security InRelease          
    Trovato http://old-releases.ubuntu.com/ubuntu eoan-updates InRelease           
    Recuperati 0 B in 0s (0 B/s)                                                   
    Lettura elenco dei pacchetti... Fatto     
    Generazione albero delle dipendenze        
    Lettura informazioni sullo stato... Fatto 
    
    
    Ripristino dello stato originale del sistema
    
    
    Interruzione
    Lettura elenco dei pacchetti... Fatto     
    Generazione albero delle dipendenze        
    Lettura informazioni sullo stato... Fatto 
    root@LHS3200:/etc/apt#
    with nano I've quoted all the previous dev and leaved only the old one... It's correct?
    Last edited by cereale979; March 7th, 2021 at 02:39 PM.

  8. #8
    Join Date
    Aug 2011
    Location
    51.8° N 5.8° E
    Beans
    5,874
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: I'm in trouble with the ubuntu upgrade

    To change language from the localised version to the default, prefix the command with LANG=C . You can make it permament (somewhat) using
    Code:
    export LANG=C
    Then all further commands you run in that terminal will give output in English. And if you're root already, there's no need for sudo.

  9. #9
    Join Date
    Mar 2021
    Beans
    6

    Re: I'm in trouble with the ubuntu upgrade

    Code:
    root@LHS3200:/home/cereale979# LANG=C apt-get update
    Hit:1 http://old-releases.ubuntu.com/ubuntu eoan InRelease
    Hit:2 http://old-releases.ubuntu.com/ubuntu eoan-security InRelease
    Hit:3 http://old-releases.ubuntu.com/ubuntu eoan-updates InRelease
    Reading package lists... Done
    root@LHS3200:/home/cereale979# LANG=C apt-get upgrade
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Calculating upgrade... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    root@LHS3200:/home/cereale979# LANG=C do-release-upgrade
    Checking for a new Ubuntu release
    Your Ubuntu release is not supported anymore.
    For upgrade information, please visit:
    http://www.ubuntu.com/releaseendoflife
    
    
    Get:1 Upgrade tool signature [1554 B]                                          
    Get:2 Upgrade tool [1341 kB]                                                   
    Fetched 1343 kB in 0s (0 B/s)                                                  
    authenticate 'focal.tar.gz' against 'focal.tar.gz.gpg' 
    extracting 'focal.tar.gz'
    
    
    Reading cache
    
    
    Checking package manager
    Reading package lists... Done
    Building dependency tree        
    Reading state information... Done
    Hit http://old-releases.ubuntu.com/ubuntu eoan InRelease                       
    Hit http://old-releases.ubuntu.com/ubuntu eoan-security InRelease              
    Hit http://old-releases.ubuntu.com/ubuntu eoan-updates InRelease               
    Fetched 0 B in 0s (0 B/s)                                                      
    Reading package lists... Done    
    Building dependency tree          
    Reading state information... Done
    
    
    Restoring original system state
    
    
    Aborting
    Reading package lists... Done    
    Building dependency tree          
    Reading state information... Done
    Now in english but ever in trouble.... Where is located the upgrade log? Peraps it contain some useful informations
    Last edited by cereale979; March 7th, 2021 at 09:42 PM.

  10. #10
    Join Date
    May 2013
    Location
    Galiza
    Beans
    4,010
    Distro
    Ubuntu

    Re: I'm in trouble with the ubuntu upgrade

    Please try (assuming you're still with root console):
    Code:
    apt update && apt full-upgrade
    then try again
    do-release-upgrade

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •