Results 1 to 7 of 7

Thread: Wifi (rtl8811au) no longer auto-connects after login (Ubuntu 20.04 LTS)

  1. #1
    Join Date
    Mar 2021
    Beans
    6

    Question Wifi (rtl8811au) no longer auto-connects after login (Ubuntu 20.04 LTS)

    Until a few weeks ago, my wifi connection has been absolutely reliable, and in particular, it has always connected automatically on login. Now, it fails to connect automatically, and I have to re-enter my wifi password each time, and that is becoming very tedious. I can see that others have reported something very similar (eg. https://ubuntuforums.org/showthread.php?t=2458231), but I haven't found a solution to the problem.

    I have run the wireless-info script, and the output can be found here: https://paste.ubuntu.com/p/FQB2wJh3GJ/

    Any ideas on how to resolve this, please?
    Last edited by gigabyte56; March 9th, 2021 at 09:55 PM.

  2. #2
    Join Date
    Feb 2020
    Beans
    96

    Re: Wifi (rtl8811au) no longer auto-connects after login (Ubuntu 20.04 LTS)

    I did not see anything obvious in the script output. If it were me, I would uninstall the existing driver and go to the following site:

    https://github.com/morrownr/8821au

    This driver is modern and is solid. It is a clean compile and leaves a clean log. Installation instructions and a lot of good information is included at the site.

    Good luck.

  3. #3
    Join Date
    Mar 2021
    Beans
    6

    Re: Wifi (rtl8811au) no longer auto-connects after login (Ubuntu 20.04 LTS)

    Thanks for the advice, morrownr. The new driver works fine, but sadly it doesn't resolve the auto-connect problem.

  4. #4
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Wifi (rtl8811au) no longer auto-connects after login (Ubuntu 20.04 LTS)

    Have a look at the settings for network-manager, assuming that is what you are using, and make sure it is still set to autocennect and for all users if that's what you want.
    I have absolutely no idea why they might have changed but it's worth a quick look-see.

    All those settings are in the General Tab- see my screenshot.
    Attached Images Attached Images

  5. #5
    Join Date
    Mar 2021
    Beans
    6

    Re: Wifi (rtl8811au) no longer auto-connects after login (Ubuntu 20.04 LTS)

    Thanks ajgreeny. Yes, it is still set to 'autoconnect for all users'. In the past, I've changed this value to other possible values and applied my changes, before finally reverting to 'all users', but this has not helped.

    I've just posted a comment to the thread at https://ubuntuforums.org/showthread.php?t=2458231, to say that I too see a different output from iwconfig after each boot, which may provide a clue. That is, the device identifier (?) changes, for example, from wlx00e04c508a9a to wlx00e04c050c6f. This may explain why I see multiple entries in the list of known networks which are all prefixed with my SSID, followed by a unique integer that increases after each connection is made. If my computer never sees the same network twice, then this may be why I have to enter my password each time I connect?

  6. #6
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Wifi (rtl8811au) no longer auto-connects after login (Ubuntu 20.04 LTS)

    It almost sounds like a router problem.

    Might be worth rebooting the router and double checking the settings of that.

  7. #7
    Join Date
    Mar 2021
    Beans
    6

    Re: Wifi (rtl8811au) no longer auto-connects after login (Ubuntu 20.04 LTS)

    It does look like the problem was due to Ubuntu renaming the network interface each boot, from "wlan0" to something variable of the form "wlx00e04c508a9a". My googling activity took me to https://unix.stackexchange.com/quest...-being-renamed, which suggested that interface renaming could be disabled by updating /etc/default/grub. The guidance stated the following:

    Put "net.ifnames=0" into the kernel command line (e. g. in /etc/default/grub's GRUB_CMDLINE_LINUX_DEFAULT, then run "update-grub")

    Having made this change and rebooted the machine, the wifi interface now remains "wlan0", and my password is being saved.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •