Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: Excessive Memory & Processor Usage

  1. #1
    Join Date
    Mar 2009
    Beans
    77

    Excessive Memory & Processor Usage

    First off my "Disk Cache" is using 74% of my RAM, but even when I clear it my processor is still lagging due to process called:
    "kcmshell5 kcm_memory" which is taking an average of 55% of my processor even when I have no apps open.

    I see no other posts that reference this process. In fact I'm having difficulty figuring out what it even is...google is no help. Though apparently there is a K-POP band of the same name.

    Kubuntu 20.04.2

    Thoughts?
    Last edited by malfindin; March 1st, 2021 at 06:32 PM.

  2. #2
    Join Date
    May 2010
    Beans
    1,210

    Re: Excessive Memory & Processor Usage

    This is normal. You permanent storage is super slow compared to the system RAM. The OS is keeping files in there to make the system faster for you. As real applications are ran then cache will make way and reduce itself.

    Are you seeing system slowness?

  3. #3
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Excessive Memory & Processor Usage

    We need some facts

    Code:
    inxi -Fz
    free -hm
    Please help us to help you.

  4. #4
    Join Date
    Mar 2009
    Beans
    77

    Re: Excessive Memory & Processor Usage

    Oh my YES. Slowness to the point of the system being unusable. If I open one single page in a browser, any browser, I type and it takes 10 seconds for the text to appear on the screen.

  5. #5
    Join Date
    Mar 2009
    Beans
    77

    Re: Excessive Memory & Processor Usage

    I'll post those in 30 min. It'll take me that long to boot it, log in to the forums, and post the info...at least. 1 hour might be a more realistic estimate. I am currently on my other computer.

  6. #6
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Excessive Memory & Processor Usage

    Quote Originally Posted by malfindin View Post
    Oh my YES. Slowness to the point of the system being unusable. If I open one single page in a browser, any browser, I type and it takes 10 seconds for the text to appear on the screen.
    I'd go with a very light GUI to start. No DE, just a window manager. openbox, fvwm, fluxbox are light.

  7. #7
    Join Date
    Mar 2009
    Beans
    77

    Re: Excessive Memory & Processor Usage

    I'm still working on it. It's going to take about 30 to install inxi.
    P.S. I have gigabyte fiber...BTW

  8. #8
    Join Date
    Mar 2009
    Beans
    77

    Re: Excessive Memory & Processor Usage

    I am partial to Lubuntu...

    But there should be no need for a lighter OS. The system is not all that bad. It runs Win 10 very fast...

  9. #9
    Join Date
    Mar 2009
    Beans
    77

    Re: Excessive Memory & Processor Usage

    Well that took forever. Please NOTE this system runs Kubuntu very fast from USB stick. It's only after installing it that the slowness occurs.

    OUTPUT of inxi
    Code:
    System:    Kernel: 5.8.0-44-generic x86_64 bits: 64 Desktop: KDE Plasma 5.18.5 
               Distro: Ubuntu 20.04.2 LTS (Focal Fossa) 
    Machine:   Type: Laptop System: TOSHIBA product: Satellite C855D v: PSCBUU-006005 serial: <filter> 
               Mobo: TOSHIBA model: Portable PC v: MP serial: <filter> UEFI: Insyde v: 6.20 date: 11/07/2012 
    Battery:   ID-1: BAT0 charge: 34.4 Wh condition: 34.4/48.6 Wh (71%) 
    CPU:       Topology: Dual Core model: AMD A6-4400M APU with Radeon HD Graphics bits: 64 type: MCP 
               L2 cache: 1024 KiB 
               Speed: 2695 MHz min/max: 1400/2700 MHz Core speeds (MHz): 1: 2695 2: 2695 
    Graphics:  Device-1: AMD Trinity 2 [Radeon HD 7520G] driver: radeon v: kernel 
               Display: x11 server: X.Org 1.20.9 driver: radeon FAILED: ati unloaded: fbdev,modesetting,vesa 
               resolution: 1366x768~60Hz 
               OpenGL: renderer: AMD ARUBA (DRM 2.50.0 / 5.8.0-44-generic LLVM 11.0.0) v: 4.3 Mesa 20.2.6 
    Audio:     Device-1: AMD Trinity HDMI Audio driver: snd_hda_intel 
               Device-2: AMD FCH Azalia driver: snd_hda_intel 
               Sound Server: ALSA v: k5.8.0-44-generic 
    Network:   Device-1: Qualcomm Atheros AR8162 Fast Ethernet driver: alx 
               IF: enp1s0 state: down mac: <filter> 
               Device-2: Realtek RTL8723AE PCIe Wireless Network Adapter driver: rtl8723ae 
               IF: wlp2s0 state: up mac: <filter> 
    Drives:    Local Storage: total: 698.64 GiB used: 25.99 GiB (3.7%) 
               ID-1: /dev/sda vendor: Seagate model: ST750LX003-1AC154 size: 698.64 GiB 
    Partition: ID-1: / size: 457.35 GiB used: 25.95 GiB (5.7%) fs: ext4 dev: /dev/sda2 
               ID-2: swap-1 size: 3.81 GiB used: 13.5 MiB (0.3%) fs: swap dev: /dev/sda5 
    Sensors:   System Temperatures: cpu: 55.8 C mobo: N/A gpu: radeon temp: 56 C 
               Fan Speeds (RPM): N/A 
    Info:      Processes: 163 Uptime: 2h 49m Memory: 3.32 GiB used: 934.5 MiB (27.5%) Shell: bash inxi: 3.0.38
    OUTPUT of free
    Code:
                  total        used        free      shared  buff/cache   available
    Mem:          3.3Gi       823Mi       909Mi        19Mi       1.6Gi       2.3Gi
    Swap:         3.8Gi        13Mi       3.8Gi
    Last edited by deadflowr; March 1st, 2021 at 07:41 PM. Reason: code tags

  10. #10
    Join Date
    Mar 2009
    Beans
    77

    Re: Excessive Memory & Processor Usage

    Thank you all for your help. I've been using and installing Linux for clients since 2007 and never seen anything like this.

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •