Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25

Thread: Kernel 5.12 RC (Release Candidate) series

  1. #21
    Join Date
    Apr 2019
    Beans
    19

    Re: Kernel 5.12 RC (Release Candidate) series

    Code:
    5.12.0-051200rc5daily20210404-generic #202104032200 SMP Sun Apr 4 02:03:49 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

  2. #22
    Join Date
    Feb 2011
    Location
    Coquitlam, B.C. Canada
    Beans
    3,040
    Distro
    Ubuntu Development Release

    Re: Kernel 5.12 RC (Release Candidate) series

    kernel 5.12-rc6 has been released. Observe these kernel configuration differences between Ubuntu mainline PPAs -rc5 and -rc6:

    Code:
    doug@s19:~/temp-k-git/linux$ scripts/diffconfig .config-5.12.0-051200rc5-lowlatency .config-5.12.0-051200rc6-lowlatency
     ATH11K_DEBUGFS n -> y
     ATH11K_TRACING n -> y
     KFENCE n -> y
    +ATH11K_SPECTRAL y
    +KFENCE_NUM_OBJECTS 255
    +KFENCE_SAMPLE_INTERVAL 0
    +KFENCE_STATIC_KEYS y
    +KFENCE_STRESS_TEST_FAULTS 0
    I still get dependency warning during compile:
    Code:
    doug@s19:~/temp-k-git/linux$ time make -j13 olddefconfig bindeb-pkg LOCALVERSION=-stock
    
    WARNING: unmet direct dependencies detected for ADI_AXI_ADC
      Depends on [n]: IIO [=m] && HAS_IOMEM [=y] && OF [=n]
      Selected by [m]:
      - AD9467 [=m] && IIO [=m] && SPI [=y]
    #
    # configuration written to .config
    #
      SYNC    include/config/auto.conf.cmd
    
    WARNING: unmet direct dependencies detected for ADI_AXI_ADC
      Depends on [n]: IIO [=m] && HAS_IOMEM [=y] && OF [=n]
      Selected by [m]:
      - AD9467 [=m] && IIO [=m] && SPI [=y]
    
    WARNING: unmet direct dependencies detected for ADI_AXI_ADC
      Depends on [n]: IIO [=m] && HAS_IOMEM [=y] && OF [=n]
      Selected by [m]:
      - AD9467 [=m] && IIO [=m] && SPI [=y]
    
    WARNING: unmet direct dependencies detected for ADI_AXI_ADC
      Depends on [n]: IIO [=m] && HAS_IOMEM [=y] && OF [=n]
      Selected by [m]:
      - AD9467 [=m] && IIO [=m] && SPI [=y]
      UPD     include/config/kernel.release
    sh ./scripts/package/mkdebian
    dpkg-buildpackage -r"fakeroot -u" -a$(cat debian/arch)  -b -nc -uc
    dpkg-buildpackage: info: source package linux-5.12.0-rc6-stock
    Last edited by Doug S; April 5th, 2021 at 12:46 AM.
    Any follow-up information on your issue would be appreciated. Please have the courtesy to report back.

  3. #23
    Join Date
    Apr 2019
    Beans
    19

    Secure Boot Collapse rc-7 Today's Updates

    https://bugzilla.kernel.org/show_bug.cgi?id=212675

    Code:
    dpkg --list | grep linux-image
    ii  linux-image-5.11.0-14-generic                 5.11.0-14.15                                                         amd64        Signed kernel image generic
    ii  linux-image-generic                           5.11.0.14.15                                                         amd64        Generic Linux kernel image
    ii  linux-image-unsigned-5.12.0-051200rc7-generic 5.12.0-051200rc7.202104112331                                        amd64        Linux kernel image for version 5.12.0 on 64 bit x86 SMP

  4. #24
    Join Date
    Feb 2011
    Location
    Coquitlam, B.C. Canada
    Beans
    3,040
    Distro
    Ubuntu Development Release

    Re: Secure Boot Collapse rc-7 Today's Updates

    Was that bug report entered by you, i.e. are you "Mik"? I ask because it is an upstream bug report, but refers to things like "Proposed", which is a distro specific reference.
    Any follow-up information on your issue would be appreciated. Please have the courtesy to report back.

  5. #25
    Join Date
    Feb 2011
    Location
    Coquitlam, B.C. Canada
    Beans
    3,040
    Distro
    Ubuntu Development Release

    Re: Kernel 5.12 RC (Release Candidate) series

    Mainline Kernel 5.12 seems to have a dependency change which is problem for my main 20.04 test server.
    I am a bit behind and didn't know until I saw this question over on askubuntu.

    Requires libc >=2.33

    but focal is at 2.31-0ubuntu9.2

    However, if I compile myself, it installs fine. I.E. the dependency is compiler version dependent.
    Any follow-up information on your issue would be appreciated. Please have the courtesy to report back.

Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •