Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: "[Errno 5] Input/output error" during installation

  1. #1
    Join Date
    Jan 2021
    Beans
    8

    "[Errno 5] Input/output error" during installation

    I've spent 5 hours browsing the web for this, trying out things... I am out of ideas...

    New Clevo laptop with NVMe. This model is sold elsewhere with Ubuntu pre-installed. So, I believe the model is somewhat supported.

    1] Downloaded '20.04.2.0 LTS' from ubuntu.com
    2] Verified download: "ubuntu-20.04.2.0-desktop-amd64.iso: OK"
    3] Created bootable USB stick with that ISO using Rufus. USB boots fine and loads installer (GUI, not terminal)

    Installer passes "checking disk" and lets me through the installation options wizard dialogues.
    While the screen says "almost finished copying files", I get: "[Errno 5] Input/output error"

    ~ Tried different USB sticks. All my disk-on-keys are quality brands bought from reputable retailers and used carefuly
    ~ Tried different USB ports
    ~ Wanted to test my RAM but memtest86+ is not available in grub
    ~ Wanted to test my SSD SMART but that option was grayed-out in Disks
    ~ Instead of SMART from GUI, ran the 'smartctl -a ___' command on all my devices: "No Errors Logged"

    I have a "magical gut feeling" that nothing is wrong with ISO/USB/RAM/SSD... Could it be some BIOS setting that Ubuntu does not support?

    Any ideas what could be wrong? What to try?
    Last edited by draxdomax; February 25th, 2021 at 10:37 AM.

  2. #2
    Join Date
    May 2013
    Location
    Galiza
    Beans
    3,863
    Distro
    Ubuntu

    Re: "[Errno 5] Input/output error" during installation

    Does it have Windows?

  3. #3
    Join Date
    Jan 2021
    Beans
    8

    Re: "[Errno 5] Input/output error" during installation

    It came with a non-registered "for testing" windows, which the Ubuntu installer removed.
    Now, I am stuck with no OS...

  4. #4
    Join Date
    May 2013
    Location
    Galiza
    Beans
    3,863
    Distro
    Ubuntu

    Re: "[Errno 5] Input/output error" during installation

    Are you selecting to "erase and install.." or did you partitioned in advance? If so, did you created the EFI partition?

  5. #5
    Join Date
    Jan 2021
    Beans
    8

    Re: "[Errno 5] Input/output error" during installation

    "Erase disk and install Ubuntu".

    Now, that you mention it, I think the first time I tried, GParted gave an error.

    Does this mean that the "Erase disk..." still keeps some "state" of the disk?

    How to really obliterate everything and start from absolute zero?

  6. #6
    Join Date
    May 2008
    Beans
    1,327
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: "[Errno 5] Input/output error" during installation

    Quote Originally Posted by draxdomax View Post
    How to really obliterate everything and start from absolute zero?
    After you have booted into the live session:-

    Open gparted > Device > Create partition Table > Select gpt

  7. #7
    Join Date
    Aug 2011
    Location
    51.8° N 5.8° E
    Beans
    5,758
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: "[Errno 5] Input/output error" during installation

    To start from absolute zero, you could write zeros to the drive. Typically, just the first megabyte should suffice. That will destroy partition table etc. and stop any confusion gparted or the installer might have. Then create a fresh partition table.

    Have you actually executed the smart test? smartctl -a displays the result of the last test. To execute the test, use
    Code:
    sudo smartctl -t [test] [device]
    where [test] is the test you want to run (I always run the long test, taking about an hour on my hardware) and [device] the device you want to test. See
    Code:
    man smartctl
    for details.

  8. #8
    Join Date
    Jan 2021
    Beans
    8

    Re: "[Errno 5] Input/output error" during installation

    OK Guys I am out of the woods!

    What did it for me is super crazy: I am trying all sorts and finally gave up and just tried a REGULAR way, while taking screenshots to... I don't know, maybe bother someone at work about this
    While taking screenshots, I fumbled the wifi password and the installer proceeded without internet ("download updates" was disabled)

    Installation proceeded without problems.

    I didn't stop there!

    I went through another installation cycle, got the internet on - bam, errno 5!

    Tried again, without internet - no problems

  9. #9
    Join Date
    Jan 2021
    Beans
    8

    Re: "[Errno 5] Input/output error" during installation

    Thanks for all your time and valuable advice!
    It turned out to be something different but without your support, I wouldn't even have bothered so much and I would have given up a long time ago!

  10. #10
    Join Date
    May 2010
    Beans
    1,180

    Re: "[Errno 5] Input/output error" during installation

    Please mark as solved if the issue is gone

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •