Results 1 to 7 of 7

Thread: Passthrough audio doesn't work unless pavucontrol is open

  1. #1
    Join Date
    Oct 2006
    Location
    Kansas City, MO
    Beans
    257
    Distro
    Kubuntu

    Passthrough audio doesn't work unless pavucontrol is open

    Using Kubuntu 20.04. I have a ham radio tranceiver that has its audio output connected to the rear mic input. In alsamixer (from command line), I've got its volume set and passthrough enabled with auto-mute disabled. However, no audio comes through the speakers unless I open pavucontrol. This is just plain old analog output, not using HDMI, surround sound, or anything fancy. Output devices in pavucontrol is set to LineOut (which connect to amplified speakers). Input devices is Monitor of Built-in Audio Analog Stereo. Configuration tab has Built-in Audio set to Analog Stereo Output and the HDMI output is turned off.

    If I close pavucontrol, the audio is still there for about 5 seconds and then disappears. All I have to do to get it back is open pavucontrol. I've had this configuration going for years but I guess a recent update broke something and I cannot seem to find the right setting(s) to make it happy. Amy ideas?

  2. #2
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    8,284
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: Passthrough audio doesn't work unless pavucontrol is open

    Quote Originally Posted by scottbomb View Post
    If I close pavucontrol, the audio is still there for about 5 seconds and then disappears. All I have to do to get it back is open pavucontrol.
    There's a setting in the PulseAudio config file for whether you want devices to automatically mute when they aren't being used. You could try turning that off.

  3. #3
    Join Date
    Oct 2006
    Location
    Kansas City, MO
    Beans
    257
    Distro
    Kubuntu

    Re: Passthrough audio doesn't work unless pavucontrol is open

    If such a setting exists, I haven't found it. It seems that pulseaudio will only allow the passthrough to come through the speakers if I have an audio-related application open (like pavucontrol), or a song playing in vlc, adjusting the system volume, etc. Otherwise, it mutes the speakers because it assumes I don't want to hear what's on line-in (I changed it from mic to line-in and it didn't make any difference). Tomorrow I'll experiment with some of these settings in /etc/pulse/default.pa:

    ### Load audio drivers statically
    ### (it's probably better to not load these drivers manually, but instead
    ### use module-udev-detect -- see below -- for doing this automatically)
    #load-module module-alsa-sink
    #load-module module-alsa-source device=hw:1,0
    #load-module module-oss device="/dev/dsp" sink_name=output source_name=input
    #load-module module-oss-mmap device="/dev/dsp" sink_name=output source_name=input
    #load-module module-null-sink
    #load-module module-pipe-sink

    I tried un-commenting

    load-module module-alsa-sink
    load-module module-alsa-source device=hw:1,0

    ..but it made no difference.

    I wish I could find some documentation on these options. I find it odd that the first line in the file is ".fail" From the standpoint of someone with some programming experience, it's like telling the thing to crash right off the bat

    I'll check out http://pulseaudio.org/ tomorrow and see if I can get some hints there, too.

  4. #4
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    8,284
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: Passthrough audio doesn't work unless pavucontrol is open

    It's the line that says
    Code:
    load-module module-suspend-on-idle
    Just comment that out and then restart PulseAudio (pulseaudio -k is the quick way).

  5. #5
    Join Date
    Oct 2006
    Location
    Kansas City, MO
    Beans
    257
    Distro
    Kubuntu

    Re: Passthrough audio doesn't work unless pavucontrol is open

    Aha! That was it! A million thank yous.

  6. #6
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    8,284
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: Passthrough audio doesn't work unless pavucontrol is open

    Just one is fine And you're welcome.

  7. #7
    Join Date
    May 2010
    Beans
    1,204

    Re: Passthrough audio doesn't work unless pavucontrol is open

    Please remember to mark as solved

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •