Results 1 to 10 of 24

Thread: Unable to fix, reinstall, or remove package.

Threaded View

  1. #1
    Join Date
    Mar 2007
    Beans
    973

    Unable to fix, reinstall, or remove package.

    I just upgrade a 16.04 LTS to 18.04 LTS and I'm stuck. One package won't fix, install reinstall or remove.
    I have never seen this error before . I wonder if I should simple delete or rename '/usr/lib/libpt.so.2.10.11' to see if it will work.

    Code:
    # apt --fix-broken install
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... Done
    The following packages were automatically installed and are no longer required:
      account-plugin-facebook account-plugin-flickr appmenu-qt5 gir1.2-gnomekeyring-1.0
      gnome-icon-theme-symbolic gnome-user-share hardening-includes kate-data katepart
      libaccount-plugin-generic-oauth libapache2-mod-dnssd libautodie-perl libcapnp-0.5.3
      libevent-2.0-5 libgcr-3-common libgfortran3 libgnutls-openssl27 libjs-sphinxdoc libjs-underscore
      libkatepartinterfaces4 libllvm6.0 libnm-gtk-common libopencc1 librpmbuild3 libsub-identify-perl
      libtxc-dxtn-s2tc0 libustr-1.0-1 libxcb-xf86dri0 libxerces-c3.1 python-debianbts python-pyatspi
      python-reportbug signon-plugin-password
    Use 'apt autoremove' to remove them.
    The following additional packages will be installed:
      libpt2.10.11
    The following NEW packages will be installed:
      libpt2.10.11
    0 upgraded, 1 newly installed, 0 to remove and 598 not upgraded.
    3 not fully installed or removed.
    Need to get 0 B/1,128 kB of archives.
    After this operation, 4,030 kB of additional disk space will be used.
    Do you want to continue? [Y/n] Y
    (Reading database ... 395310 files and directories currently installed.)
    Preparing to unpack .../libpt2.10.11_2.10.11~dfsg-2.1_i386.deb ...
    Unpacking libpt2.10.11 (2.10.11~dfsg-2.1) ...
    dpkg: error processing archive /var/cache/apt/archives/libpt2.10.11_2.10.11~dfsg-2.1_i386.deb (--unpack):
     trying to overwrite '/usr/lib/libpt.so.2.10.11', which is also in package libpt2.10.10v5 2.10.11~dfsg-1ubuntu1
    dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
    Errors were encountered while processing:
     /var/cache/apt/archives/libpt2.10.11_2.10.11~dfsg-2.1_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Last edited by rsteinmetz70112; February 15th, 2021 at 06:41 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •