Page 3 of 3 FirstFirst 123
Results 21 to 24 of 24

Thread: Unable to fix, reinstall, or remove package.

  1. #21
    Join Date
    Mar 2007
    Beans
    964

    Re: Unable to fix, reinstall, or remove package.

    OK moving on:

    The following packages could not be reinstalled and I was able to remove and purge them:
    • cdrecord Dummy transition package for wodim
    • libdb4.3 Berkeley v4.3 Database Libraries [runtime]
    • libdb4.4 Berkeley v4.4 Database Libraries [runtime]
    • libnetcdf3 An interface for scientific data access to large binary d
    • php4-pear PHP Extension and Application Repository (transitional package)
    • sysvutils System-V-like utilities (transitional package)
    • x-window-system-core transitional package for Debian etch


    I was unable to reinstall or remove or purge this package using apt or dpkg:
    • libreadline4 GNU readline and history libraries, run-time libraries


    Researching it appears that this library is from the previous version of Ubuntu. The current version also appears to have some dependency problems.
    I think I can probably leave this alone.
    Actually I edited libreadline4.prerm to remove the install-info line. I was then able to remove libread4 and purge it.

    I then ran
    Code:
    #apt update
    #apt upgrade
    Both ran clean.
    I don't know that I've fixed everything but at least the error messages are gone.
    Last edited by rsteinmetz70112; February 18th, 2021 at 08:11 PM.

  2. #22
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    13,806
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Unable to fix, reinstall, or remove package.

    rsteinmetz70112; Yay

    Again - good work -
    I still have reservations as to what
    "x-window-system-core transitional package for Debian etch
    may have done to the GUI, as it is not an ubuntu package:
    https://packages.ubuntu.com/search?k...ic&section=all >> Sorry, your search gave no results

    Maybe just leave well enough alone and live with the miss-used disk space ?

    If required to delve into the Debain Window-system; I just do not have the experience to know.

    a know it all I am not
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  3. #23
    Join Date
    Mar 2007
    Beans
    964

    Re: Unable to fix, reinstall, or remove package.

    OK I have now
    Code:
    install deborphan
    and removed all orphan programs.

    It took several iterations and created a number of autoremoveable file.

    Once I got to no orphan files and no autoremoveable files I updated and upgraded.

    I then reinstalled ubuntu-desktop.

    Things seem to be working although I'm still testing.

    I've uncovered two linked library issues, but they don't seem to be critical.
    Last edited by rsteinmetz70112; February 19th, 2021 at 07:15 AM.

  4. #24
    Join Date
    Mar 2007
    Beans
    964

    Re: Unable to fix, reinstall, or remove package.

    I got this error:

    Code:
    /etc/ld.so.conf.d/i386-linux-gnu_EGL.conf: No such file or directory
    checking on the files I get a bunch of links
    Code:
    # ls -l /etc/ld.so.conf.d/i386-linux-gnu_EGL.conf
    lrwxrwxrwx 1 root root 41 Apr 18  2015 /etc/ld.so.conf.d/i386-linux-gnu_EGL.conf -> /etc/alternatives/i386-linux-gnu_egl_conf
    # ls -l  /etc/alternatives/i386-linux-gnu_egl_conf
    lrwxrwxrwx 1 root root 48 Feb 14 16:55 /etc/alternatives/i386-linux-gnu_egl_conf -> /usr/lib/i386-linux-gnu/libhybris-egl/ld.so.conf
    # ls -l /usr/lib/i386-linux-gnu/libhybris-egl/ld.so.conf
    -rw-r--r-- 1 root root 0 Feb 19 10:37 /usr/lib/i386-linux-gnu/libhybris-egl/ld.so.conf
    This file doesn't exist on other computers.
    Googling it seems to be a broken link from a previous Nvidia driver.

Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •