Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24

Thread: Unable to fix, reinstall, or remove package.

  1. #11
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    13,809
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Unable to fix, reinstall, or remove package.

    rsteinmetz70112; OK

    Looking at the https://packages.ubuntu.com/bionic/gnupg-utils tree, looks like all is supported under the gpgconf package.

    Let's try:
    Code:
    sudo apt clean
    sudo apt remove --purge gpgconf
    sudo apt update
    sudo apt upgrade
    sudo apt install gpgconf
    sudo dpkg --configure -a
    sudo dpkg -C
    If all is good then "dpkg -C" will only return to prompt.

    good things can happen
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  2. #12
    Join Date
    Mar 2007
    Beans
    972

    Re: Unable to fix, reinstall, or remove package.

    I plan to rebuild this with 64 bit, but I decided to upgrade to 18.04 first.
    That may not have ben a good decision .
    It now boots but I have processes taking up 100% of the CPU and the console locking up.

  3. #13
    Join Date
    May 2013
    Location
    Galiza
    Beans
    4,010
    Distro
    Ubuntu

    Re: Unable to fix, reinstall, or remove package.

    That may not have ben a good decision .
    Definitely.

  4. #14
    Join Date
    Mar 2007
    Beans
    972

    Re: Unable to fix, reinstall, or remove package.

    Ok

    Code:
    sudo apt remove --purge gpgconf --simulate
    Wants to remove a whole bunch of stuff.

    Code:
    The following packages will be REMOVED:
      apturl* dirmngr* duplicity* fwupd* fwupd-signed* fwupdate* fwupdate-signed*
      gir1.2-rb-3.0* gnome-software* gnome-software-plugin-snap* gnupg* gpg*
      gpg-agent* gpg-wks-client* gpg-wks-server* gpgconf* gpgsm* gthumb*
      kactivitymanagerd* kde-runtime* kinit* kio* kpackagelauncherqml*
      libblockdev-crypto2* libbrasero-media3-1* libgmime-3.0-0* libgpgme++2v5*
      libgpgme11* libgpgmepp6* libgrilo-0.3-0* libkf5akonadicontact5abi1*
      libkf5akonadimime5* libkf5calendarcore5* libkf5calendarutils-bin*
      libkf5calendarutils5abi1* libkf5contacteditor5* libkf5declarative5*
      libkf5identitymanagement5abi1* libkf5imap5* libkf5kcmutils5*
      libkf5kdelibs4support5* libkf5kdelibs4support5-bin*
      libkf5kdepimdbusinterfaces5* libkf5kontactinterface5* libkf5notifyconfig5*
      libkf5parts-plugins* libkf5parts5* libkf5pimtextedit5abi2* libkf5plasma5*
      libkf5plasmaquick5* libkf5quickaddons5* libkf5tnef5* libkf5wallet-bin*
      libkf5wallet5* libkwalletbackend5-5* libreoffice-avmedia-backend-gstreamer*
      libreoffice-base-core* libreoffice-calc* libreoffice-core* libreoffice-draw*
      libreoffice-gnome* libreoffice-gtk3* libreoffice-help-en-us*
      libreoffice-impress* libreoffice-math* libreoffice-ogltrans*
      libreoffice-pdfimport* libreoffice-presentation-minimizer*
      libreoffice-writer* librhythmbox-core10* libtotem-plparser18*
      libvolume-key1* nautilus-share* plasma-framework* python-apt*
      python-aptdaemon* python-aptdaemon.gtk3widgets* python-gnupginterface*
      python-oneconf* python3-gnupg* python3-software-properties* python3-uno*
      qml-module-org-kde-kconfig* qml-module-org-kde-kirigami2*
      qml-module-org-kde-kquickcontrols* qml-module-org-kde-kquickcontrolsaddons*
      rhythmbox* rhythmbox-plugin-alternative-toolbar* rhythmbox-plugin-zeitgeist*
      rhythmbox-plugins* samba-dsdb-modules* software-center*
      software-properties-common* software-properties-gtk* system-image-common*
      system-image-dbus* ubuntu-extras-keyring* ubuntu-software*
    The following NEW packages will be installed:
      gnupg1 gnupg1-l10n
    And it tells me I have a lot of unused packages

    Code:
    The following packages were automatically installed and are no longer required:
      apturl-common brasero-common fonts-opensymbol gir1.2-snapd-1 gnupg-l10n
      gnupg-utils gstreamer1.0-gtk3 gthumb-data icoutils kde-runtime-data
      kdelibs-bin kdelibs5-plugins kdoctools libabw-0.1-1 libboost-iostreams1.65.1
      libboost-locale1.65.1 libburn4 libdmapsharing-3.0-2 libdmtx0a
      libepubgen-0.1-1 libexttextcat-2.0-0 libfwupd2 libical2 libisofs6 libjte1
      libkactivities6 libkcmutils4 libkde3support4 libkdeclarative5 libkdesu5
      libkdewebkit5 libkdnssd4 libkemoticons4 libkf5akonadicontact-data
      libkf5akonadimime-data libkf5calendarcore5abi1 libkf5calendarutils-data
      libkf5contacteditor-data libkf5doctools5 libkf5identitymanagement-data
      libkf5imap-data libkf5kirigami2-5 libkf5pimtextedit-data libkf5prison5
      libkf5syntaxhighlighting-data libkf5syntaxhighlighting5 libkf5tnef-data
      libkfile4 libkhtml5 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4
      libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4 libkpty4
      libkrosscore4 libktexteditor4 libkxmlrpcclient4 libmythes-1.2-0
      libntrack-qt4-1 libntrack0 liborcus-0.13-0 libphonon4 libplasma3
      libpolkit-qt-1-1 libqrencode3 libqt4-opengl libqt4-qt3support
      libqt5quickcontrols2-5 libqt5quicktemplates2-5 libqtwebkit4 librsync1
      libsmbios-c2 libsolid4 libthreadweaver4 libxmlb1 lp-solve
      ntrack-module-libnl-0 oneconf oneconf-common phonon phonon-backend-gstreamer
      phonon-backend-gstreamer-common plasma-scriptengine-javascript python-cups
      python-debian python-debtagshw python-defer python-fasteners
      python-monotonic python-piston-mini-client python-urllib3 python-xapian
      python3-mako python3-oneconf python3-piston-mini-client
      qml-module-qtqml-models2 qml-module-qtquick-controls2
      qml-module-qtquick-templates2 rhythmbox-data
      software-center-aptdaemon-plugins
    Use 'apt autoremove' to remove them.
    But

    Code:
    # apt autoremove
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Basically everything works, as long as I don't try to use the GUI.

    Maybe I should let it run and reinstall just unbuntu-desktop

  5. #15
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    13,809
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Unable to fix, reinstall, or remove package.

    rsteinmetz70112 - Yukkie-poo

    Not ready to throw in the towel yet. All's insights into this matter are appreciated
    As "autoremove" shows discrepancies in the outputs, let's suppose that mergelist is messed up.
    MergeLists are a working tool of apt, part of the way it keeps track of which packages are in which repositories. It's the gears of a text-based database that apt relies upon. When corrupted, they can be safely deleted. Apt will recreate them during the next apt update.

    Code:
    sudo apt clean
    sudo rm -fr /var/lib/apt/lists
    sudo mkdir -pv /var/lib/apt/lists/partial
    sudo apt update
    sudo apt upgrade
    sudo dpkg -C
    what now ?
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  6. #16
    Join Date
    Mar 2007
    Beans
    972

    Re: Unable to fix, reinstall, or remove package.

    It didn't change the results.

    but:
    Code:
     dpkg -C
    The following packages are missing the md5sums control file in the
    database, they need to be reinstalled:
     cdrecord             Dummy transition package for wodim
     libdb4.3             Berkeley v4.3 Database Libraries [runtime]
     libdb4.4             Berkeley v4.4 Database Libraries [runtime]
     libnetcdf3           An interface for scientific data access to large binary d
     libreadline4         GNU readline and history libraries, run-time libraries
     php4-pear            PHP Extension and Application Repository (transitional pa
     sysvutils            System-V-like utilities (transitional package)
     x-window-system-core transitional package for Debian etch
    I'll try reinstalling those packages tomorrow.

  7. #17
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    13,809
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Unable to fix, reinstall, or remove package.

    rsteinmetz70112 ; Ouch

    Houston, we have a problem >>
    Code:
    apt list x-window-system-core
    https://wiki.debian.org/DontBreakDebian <- Advice On Not Breaking Their System - Don't - just don't ! The same applies to Ubuntu.

    I have no experience in cleaning up a Debianstien system. I be pleased to watch the advise of others here.

    exit stage left
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  8. #18
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Unable to fix, reinstall, or remove package.

    B-om I think he is still using Ubuntu.
    I myself would probably start with:>>(I'll use aptitude as a rule in these cases)
    Code:
    aptitude install pkg-config xserver-xorg-dev
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

  9. #19
    Join Date
    Mar 2007
    Beans
    972

    Re: Unable to fix, reinstall, or remove package.

    Yes This is Ubuntu18.04 LTS

    Code:
    # apt list x-window-system-core
    Listing... Done
    x-window-system-core/now 1:7.2-5ubuntu13 all [installed,local]
    I typically use apt to do such things. aptitude is not installed on this computer and I'm hesitant to start installing new stuff until I can get it straightened out.

    Looking at the packages which are rceccomended for reinstallations starting at teh top of the list
    Code:
    # apt install cdrecord --reinstall --simulate
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Reinstallation of cdrecord is not possible, it cannot be downloaded.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Code:
    # apt remove cdrecord --reinstall --simulate
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages will be REMOVED:
      cdrecord
    0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
    Remv cdrecord [9:1.1.2-1ubuntu1]
    I guess I'll remove it. If I need something else I'll install it later

  10. #20
    Join Date
    May 2010
    Beans
    1,270

    Re: Unable to fix, reinstall, or remove package.

    What is the output of:
    Code:
    apt-cache policy ekiga libpt2.10.11
    thanks

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •