Page 23 of 25 FirstFirst ... 132122232425 LastLast
Results 221 to 230 of 250

Thread: 32-Bit Chroot How-To

  1. #221
    Join Date
    Sep 2007
    Ubuntu 7.10 Gutsy Gibbon

    Re: 32-Bit Chroot How-To

    I did everything in the howto

    when I do ./rolauncher game load and then I got a black screen with error: out of range ??
    Last edited by allorder; September 16th, 2007 at 03:53 AM.

  2. #222
    Join Date
    Sep 2007

    Re: 32-Bit Chroot How-To

    How do I actually install 32 bit apps now I've set this up?

    Ahhh help! Ever since I did this, my CD/DVD drive won't mount! Is there anything I can do?
    Last edited by innocenceisdeath; October 1st, 2007 at 07:17 PM.

  3. #223
    Join Date
    Aug 2008

    Re: 32-Bit Chroot How-To

    Brilliant - thank you for these instructions! Now I have a fully working 32-bit environment on my 64-bit MacBook Pro. I was at my wits end dealing with problems compiling programs that had to be compiled in a 32-bit environment, and now those problems are gone!

    You rock!

  4. #224
    Join Date
    Jul 2008

    Re: 32-Bit Chroot How-To

    I have problems with step 5.

    When I type in sudo apt-get install synaptic in terminal

    W: Couldn't stat source package list hoary-security/multiverse Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_hoary-security_multiverse_binary-i386_Packages) - stat (2 No such file or directory)
    W: You may want to run apt-get update to correct these problems
    E: Sub-process /usr/bin/dpkg returned an error code (2)

    So I tried to run apt-get update, but no luck!


  5. #225
    Join Date
    Oct 2008

    Re: 32-Bit Chroot How-To

    thx gonna use it to compile 32 bit progs then install on my 64 bit system. see if it works

  6. #226
    Join Date
    Nov 2006

    How to fix font issue, install codecs, and automate this script for Intrepid

    I mostly followed these instructions, but of course updated them for using Intrepid. I also fixed the locale problem that this tutorial leaves you with. I'm sure this is all in the thread, but I don't care to search through it, so I'm bumping this solution.

    There were some things missing from the instructions and they were
    needlessly complicated, so I made my own. This is how I setup a
    32 bit chroot jail in ubuntu (intrepid specifically).

    There are exactly three times in these instructions where the distribution
    being used (intrepid) is mentioned. To use a different (possibly newer version,
    or a debian version) change those three places to the next distribution codename.
    For the next version of ubuntu replace all instances (3) of intrepid with jaunty.

    To install proprietary codecs use the following lines:

    echo "## Medibuntu
    ## Please report any bug on
    deb intrepid free non-free
    deb-src intrepid free non-free" >> /etc/apt/sources.list
    aptitude update
    aptitude install medibuntu-keyring
    aptitude update
    aptitude install w64codecs # for AMD64 systems
    aptitude install w32codecs # for 32 bit i386 systems

    To install the 32 bit chroot jail use the following:

    cd /
    aptitude install schroot debootstrap
    mkdir /chroot/
    cd /chroot
    debootstrap --arch=i386 intrepid /chroot
    unalias cp
    cp /var/lib/locales/supported.d/* /chroot/var/lib/locales/supported.d/
    cp -f /etc/apt/sources.list /chroot/etc/apt/
    cp -f /etc/passwd /chroot/etc/
    cp -f /etc/shadow /chroot/etc/
    cp -f /etc/group /chroot/etc/
    cp -f /etc/sudoers /chroot/etc/
    cp -f /etc/hosts /chroot/etc/
    echo "##chroot
    /home /chroot/home none rbind 0 0
    /dev /chroot/dev none rbind 0 0
    /etc /chroot/etc/.root none bind 0 0
    /proc /chroot/proc none rbind 0 0
    /media /chroot/media none rbind 0 0
    /mnt /chroot/mnt none rbind 0 0
    /tmp /chroot/tmp none rbind 0 0" >> /etc/fstab
    mkdir /chroot/etc/.root
    mount -a
    chroot /chroot
    dpkg-reconfigure locales
    apt-get update
    apt-get upgrade
    apt-get install aptitude mplayer firefox
    apt-get install w32codecs flashplugin-nonfree

    # ...


  7. #227
    Join Date
    Dec 2008
    Xubuntu 8.10 Intrepid Ibex

    Re: 32-Bit Chroot How-To

    Wow, this really worked. You are great. I think this should be moved to the first topic. I almost closed the window and then thought let's take a look at the last posts.

    Great job! Thanks a lot! I managed to run Lightscribe Simple Labeler on my 64bit intrepid with your help.

  8. #228
    Join Date
    Jan 2007

    Re: 32-Bit Chroot How-To

    I have fought my way to a working schroot installation, but there are two lingering issues I'm hoping to get help with:


    I'm seeing an explosion of bind mounts in the root environment's /proc/mounts file. Looks like every schroot session is creating new ones and never cleaning them up.


    My home directory is automounted from NFS and I simply cannot figure out how to bind mount the root environment's /net directory such that it appears in the chroot session. All documentation for bind mounting seems to be aimed at developers who already understand it intimately and simply need a reminder of syntax. For folks coming in fresh, it's just a lot of handwaving and jargon with few concrete examples - IMHO.

    Is there a mailing list for schroot that anyone knows of?

    Update 6/3/2009:

    It does not appear possible to bind mount autofs controlled mount points. I ended up having to start a second instance of the automounter from inside the chroot. There is no way to have this happen automatically, since the various schroot scripts execute prior to the kernel chroot() call. I discussed adding capability for this with the maintainer, but he didn't feel it was something he wanted to see in the code. Ended up hacking it in for myself.

    The explosion of mounts results from abended chroot sessions. Wrote a little script to remove them automatically.
    Last edited by shirsch; June 3rd, 2009 at 11:32 PM. Reason: More Information:

  9. #229
    Join Date
    Mar 2007

    Re: HOWTO: 32-Bit Chroot on 64-Bit Installs

    Quote Originally Posted by Crad View Post
    Most of this comes from but I wanted to put together a cleaned up version that worked for me here (There are typos and inaccuracies on the wiki page).

    At this point you should have a 32 bit environment setup with synaptic setup. When you run synaptic32 from your main environment it will chroot execute it and all installations will be made to your 32 bit environment. If you want to be able to easily launch 32 bit chroot apps from your 64 bit environment symlink the app name to /usr/local/bin/do_dchroot. If you're using this as desktop system you'll probably want to use synaptic to install x, gnome, ubuntu specific themes, etc.

    Please let me know of any errors, enhancements, or corrections
    line ---> dpkg-reconfigure locales change for:

    from main
    line1 ---> cp /var/lib/locales/supported.d/local /chroot/var/lib/locales/supported.d/
    line2 ---> dpkg-reconfigure locales

    it's ok now.

  10. #230
    Join Date
    Aug 2007
    Xubuntu 8.04 Hardy Heron

    Re: 32-Bit Chroot How-To

    Can someone tell me how to actually enter into the 32-bit environment? I've followed all the instructions on this tutorial, yet it is still utterly unclear how I run or compile 32-bit programs. I do
    sudo chroot /chroot/
    and run
    uname -a
    but all I get is
    Linux mavaddat-desktop 2.6.24-23-generic #1 SMP Wed Apr 1 21:43:24 UTC 2009 x86_64 GNU/Linux
    . Doesn't this mean I'm not in a 32-bit environment?

    It's all very frustrating. I just want a command line (shell) prompt that allows 32-bit compilation. (I know about the '-m32' flag in gcc, but my make depends on objects that are already pre-compiled as 64-bit).

    I'm getting errors when linking. Here's my terminal output:
    /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux-gnu/4.2.4/../../../ when searching for -lgdbm
    /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux-gnu/4.2.4/../../../libgdbm.a when searching for -lgdbm
    /usr/bin/ld: skipping incompatible /usr/bin/../lib/ when searching for -lgdbm
    /usr/bin/ld: skipping incompatible /usr/bin/../lib/libgdbm.a when searching for -lgdbm
    /usr/bin/ld: skipping incompatible /usr/lib/ when searching for -lgdbm
    /usr/bin/ld: skipping incompatible /usr/lib/libgdbm.a when searching for -lgdbm
    /usr/bin/ld: cannot find -lgdbm
    collect2: ld returned 1 exit status
    make[1]: *** [obj/manager] Error 1
    Last edited by mavaddat; June 4th, 2009 at 10:12 AM.

Page 23 of 25 FirstFirst ... 132122232425 LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts