Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Resolution 5040x1050 with Triplehead2Go / Nvidia graphic board

  1. #1
    Join Date
    Jul 2010
    Beans
    7

    Resolution 5040x1050 with Triplehead2Go / Nvidia graphic board

    Hello all, I am going to become desperate.

    I installaled current Ubuntu version (20.04) on my PC with success. I am using 3x22" screens and having a Matrox triplehead2go adapter in between. Graphic board is GeForce GTX 275 and Nvidia-340 driver is installed.
    Current resolution is 3840x1024. Because of using windows on the same PC I know a higher resolution is possible. Target is 5040x1050.
    Some side Infos:
    Code:
    lspci -nnk | grep -iA2 VGA 01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GT200b [GeForce GTX 275] [10de:05e6] (rev a1)
        Subsystem: ZOTAC International (MCO) Ltd. GT200b [GeForce GTX 275] [19da:3109]
        Kernel driver in use: nvidia
    Code:
    Screen 0: minimum 8 x 8, current 3840 x 1024, maximum 8192 x 8192
    DVI-I-0 disconnected (normal left inverted right x axis y axis)
    DVI-I-1 disconnected (normal left inverted right x axis y axis)
    TV-0 disconnected (normal left inverted right x axis y axis)
    DVI-I-2 disconnected (normal left inverted right x axis y axis)
    DVI-I-3 connected primary 3840x1024+0+0 (normal left inverted right x axis y axis) 2352mm x 806mm
       3840x1024     60.00*+
       3072x768      60.00  
       2400x600      60.32  
       1920x480      59.94  
       1600x1200     60.00  
       1280x1024     75.02    60.02  
       1024x768      75.03    60.00  
       800x600       75.00    60.32  
       640x480       75.00    59.94
    Code:
    cvt 5040 1050
    # 5040x1050 59.98 Hz (CVT) hsync: 65.31 kHz; pclk: 441.00 MHz
    Modeline "5040x1050_60.00"  441.00  5040 5360 5896 6752  1050 1053 1063 1089 -hsync +vsync
    Code:
    xrandr --newmode "5040x1050_60.00"  441.00  5040 5360 5896 6752  1050 1053 1063 1089 -hsync +vsync
    Code:
    xrandr --addmode DVI-I-3 "5040x1050_60.00"
    I am always getting the error:
    Code:
    X Error of failed request:  BadMatch (invalid parameter attributes)
      Major opcode of failed request:  140 (RANDR)
      Minor opcode of failed request:  18 (RRAddOutputMode)
      Serial number of failed request:  31
      Current serial number in output stream:  32
    Does anybody have any clue how to solve this issue?

  2. #2
    Join Date
    Mar 2011
    Location
    19th Hole
    Beans
    Hidden!
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Resolution 5040x1050 with Triplehead2Go / Nvidia graphic board

    I don't use nVidia, so I'm of limited help, but:

    1. Try this modeline instead:
      Code:
      # 5040x1050 @ 60.00 Hz (GTF) hsync: 65.22 kHz; pclk: 440.37 MHz
      Modeline "5040x1050_60.00" 440.37 5040 5352 5896 6752 1050 1051 1054 1087 -HSync +Vsync
    2. Though posted in the Arch forum, this link may still be of some help. **WARNING** It deals with nvidia-settings that I am not at all familiar with.
    3. Web search also found this. Apparently, the nVidia driver is picky about modelines that it sees as nonexistent on your monitor. Given that you are funnelling your video signal through an aggregator/splitter, it is probably not forwarding the proper EDID. You have to work around this issue by disabling the nVidia check. As stated, I know little about nVidia GPUs, so please take this observation with a heavy dose of salt.

  3. #3
    Join Date
    Jul 2010
    Beans
    7

    Re: Resolution 5040x1050 with Triplehead2Go / Nvidia graphic board

    Thanks for quick response.

    1. Getting an error. I am not such familiar with the format:
    Code:
    xrandr --newmode Modeline "5040x1050_60.00" 440.37 5040 5352 5896 6752 1050 1051 1054 1087 -hSync +vsync
    xrandr: unrecognized option '-hSync'
    Try 'xrandr --help' for more information.
    2. I changed the resolution as it was described in your mentioned thread by using the graphical interface. I was not able to change ViewPortOut. It always jumped back to 3840x1025
    Bildschirmfoto vom 2021-01-24 23-18-09.jpg
    Something changed, but the resolution is not such as expected
    3. I added
    Code:
    Option "UseEDID" "False"
    . Complete xorg.conf:
    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 440.82
    
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
        Load           "dbe"
        Load           "extmod"
        Load           "type1"
        Load           "freetype"
        Load           "glx"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
    
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Matrox"
        HorizSync       31.0 - 79.0
        VertRefresh     59.0 - 75.0
        ModeLine       "5040x1050_59.98" 440.22 5040 5352 5896 6752 1050 1051 1054 1087 -hsync +vsync
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce GTX 275"
    EndSection
    
    Section "Screen"
    
    # Removed Option "metamodes" "nvidia-auto-select +0+0"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "ExactModeTimingsDVI" "True"
        Option       "UseEDID" "False"
        Option         "Stereo" "0"
        Option         "nvidiaXineramaInfoOrder" "DFP-1"
        Option         "metamodes" "nvidia-auto-select +0+0 {viewportin=5040x1050, ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
        Option         "SLI" "Off"
        Option         "MultiGPU" "Off"
        Option         "BaseMosaic" "off"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    In the link it was mentioned to disable the Option "ModeValidation". I am not such familiar with, thats why I am not able set the proper argument.

  4. #4
    Join Date
    Mar 2011
    Location
    19th Hole
    Beans
    Hidden!
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Resolution 5040x1050 with Triplehead2Go / Nvidia graphic board

    Quote Originally Posted by shuo_ka View Post
    1. Getting an error. I am not such familiar with the format:
    Code:
    xrandr --newmode Modeline "5040x1050_60.00" 440.37 5040 5352 5896 6752 1050 1051 1054 1087 -hSync +vsync
    xrandr: unrecognized option '-hSync'
    Try 'xrandr --help' for more information.
    My bad. I just copied/pasted the output from this site which has been reliable for me in the past. Everything should be in lower case, so:
    Code:
    xrandr --newmode Modeline "5040x1050_60.00" 440.37 5040 5352 5896 6752 1050 1051 1054 1087 -hsync +vsync
    Linux is case sensitive. hSync will not work.

    As for the rest, while I can point you in directions suggested through my web search, as mentioned, I do not use nVidia so cannot advise further. Perhaps you can wait for a nVidia user to provide further guidance.

  5. #5
    Join Date
    Jul 2010
    Beans
    7

    Re: Resolution 5040x1050 with Triplehead2Go / Nvidia graphic board

    Thanks for your reply.

    Would be really great if somebody with nVidia experience can support.....

  6. #6
    Join Date
    Jul 2010
    Beans
    7

    Re: Resolution 5040x1050 with Triplehead2Go / Nvidia graphic board

    Quote Originally Posted by DuckHook View Post
    My bad. I just copied/pasted the output from this site which has been reliable for me in the past. Everything should be in lower case, so:
    Code:
    xrandr --newmode Modeline "5040x1050_60.00" 440.37 5040 5352 5896 6752 1050 1051 1054 1087 -hsync +vsync
    Linux is case sensitive. hSync will not work.

    As for the rest, while I can point you in directions suggested through my web search, as mentioned, I do not use nVidia so cannot advise further. Perhaps you can wait for a nVidia user to provide further guidance.
    Same error:

    Code:
    ~$ xrandr --newmode Modeline "5040x1050_60.00" 440.37 5040 5352 5896 6752 1050 1051 1054 1087 -hsync +vsync
    xrandr: unrecognized option '-hsync'
    Try 'xrandr --help' for more information.

  7. #7
    Join Date
    May 2013
    Location
    Galiza
    Beans
    3,615
    Distro
    Ubuntu

    Re: Resolution 5040x1050 with Triplehead2Go / Nvidia graphic board

    According to xrand help this are the valid flags:
    Valid flags: +HSync -HSync +VSync -VSync
    +CSync -CSync CSync Interlace DoubleScan

  8. #8
    Join Date
    Jul 2010
    Beans
    7

    Re: Resolution 5040x1050 with Triplehead2Go / Nvidia graphic board

    I dont get your point since its still showing an error message. Obviously its not case sensitive....

  9. #9
    Join Date
    May 2013
    Location
    Galiza
    Beans
    3,615
    Distro
    Ubuntu

    Re: Resolution 5040x1050 with Triplehead2Go / Nvidia graphic board

    It is case sensitive.

  10. #10
    Join Date
    Jul 2010
    Beans
    7

    Re: Resolution 5040x1050 with Triplehead2Go / Nvidia graphic board

    I am not moving forward. does nobody has an idea or clue what could I do more?

    I am sure somebody is using a Nvidia graphic board?

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •