Results 1 to 1 of 1

Thread: Sudden "Invalid MIT-MAGIC-COOKIE-1" when I run mpirun

  1. #1
    Join Date
    Jan 2021
    Beans
    1

    Sudden "Invalid MIT-MAGIC-COOKIE-1" when I run mpirun

    Suddenly whenever I run mpirun I get the error
    Code:
    Invalid MIT-MAGIC-COOKIE-1 key
    . I think this might have started after I killed a command using mpirun that had been launched from a python console.
    I looked at $XAUTHORITY and found noXauthority file. I also tried
    Code:
    xhost +local:
    in the terminal since it was suggested somewhere but the problem remains.

    I have only used mpirun to run things locally on my pc.
    For the most part mpirun does still seem to do what it is supposed to, but I believe it also now creates errors in things that were working perfectly before.
    Simply running the below shows the warning for example (nonsense minimal example):

    Code:
    /usr/bin/mpirun -n 1 echo "bla"
    I tried many things suggested on various websites such as creating a new .Xauthority file by the steps described in https://superuser.com/a/941244/728074 and setting the $DISPLAY value to :0 or :0. Nothing helped. When I created a new .Xauthority file and then deleted it did give me instead the error
    Code:
    No protocol specified
    instead. I can go back to the magic cookie error by recreating the .Xauthority according to the steps in the above link.

    System: Ubuntu 20.04 LTS

    P.S.: I also asked the question on
    https://unix.stackexchange.com/questions/630428/invalid-mit-magic-cookie-1-when-i-run-mpirun
    Last edited by kvothetheraven; January 22nd, 2021 at 07:50 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •