Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Rebooting the wifi

  1. #1
    Join Date
    Dec 2020
    Beans
    29

    Rebooting the wifi

    I'm running 20.04 on an older HP Compaq laptop.
    Every so often, the wifi will suddenly shut down. I'll be on the internet, and suddenly there's no connection, and I'll see that the wifi LED has stopped blinking. I don't think it's an OS issue, because I seem to recall that this was also happening when I was running Windows on this machine. So, I assume that it's either a hardware or firmware problem. The only way I know to get the wifi back up and running, is to reboot the computer. Is there some way just to reboot the wifi without completely rebooting the computer?
    Last edited by robert99999; January 16th, 2021 at 10:12 AM.

  2. #2
    Join Date
    May 2008
    Beans
    1,242
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Rebooting the wifi

    Quote Originally Posted by robert99999 View Post
    So, I assume that it's either a hardware or firmware problem. The only way I know to get the wifi back up and running, is to reboot the computer. Is there some way just to reboot the wifi without completely rebooting the computer?
    Yes, there is a little shortcut.

    You have to find the driver which is used by your wifi:-
    Code:
    sudo lshw -C network 2>&1 | grep wireless | grep driver
    My result is:-
    Code:
    redact@redact:~$ sudo lshw -C network 2>&1 | grep wireless | grep driver
    [sudo] password for redact: 
           configuration: broadcast=yes driver=iwlwifi driverversion=5.4.0-62-generic firmware=29.1654887522.0 latency=0 link=no multicast=yes wireless=IEEE 802.11
    Then, via the terminal:-
    Code:
    sudo modprobe -r iwlwifi && sudo modprobe iwlwifi
    The second command will unload and reload the kernel module iwlwifi (Intel wifi in this example)

    Substitute the answer from step one in step two.

    Any joy?

  3. #3
    Join Date
    Dec 2020
    Beans
    29

    Re: Rebooting the wifi

    Thanks. In my case I get iwl3945. I modified the terminal command line accordingly. When I run the command line (while wifi is working), the wifi LED goes out, then a few seconds later it comes back on, and everything is working. So, it appears to be doing what it's supposed to. I won't know if this fixes it for sure until the problem actually crops up. It only occurs every one or two days, but picks the most inopportune time to happen.

  4. #4
    Join Date
    May 2008
    Beans
    1,242
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Rebooting the wifi

    Yes, it sounds like it's behaving as expected.
    Last edited by tea for one; January 16th, 2021 at 11:46 PM.

  5. #5
    Join Date
    Dec 2020
    Beans
    29

    Re: Rebooting the wifi

    Unfortunately, it didn't work. A few minutes ago, the wifi shut down, and I tried the modprobe command, but it didn't do anything. I had to reboot the computer to get it going. I was curious about the wifi hardware interface, i.e., pci, internal usb, etc. So, I ran the lshw command again, but without the grep, and got this:

    *-network
    description: Wireless interface
    product: PRO/Wireless 3945ABG [Golan] Network Connection
    vendor: Intel Corporation
    physical id: 0
    bus info: pci@0000:10:00.0
    logical name: wlp16s0
    version: 02
    serial: 00:19:d2:2f:30:56
    width: 32 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=iwl3945 driverversion=5.8.0-38-generic firmware=15.32.2.9 ip=192.168.1.104 latency=0 link=yes multicast=yes wireless=IEEE 802.11
    resources: irq:30 memory:f4000000-f4000fff

    So now I'm wondering if there's something with the PCI bus that needs to be reset.

  6. #6
    Join Date
    May 2008
    Beans
    1,242
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Rebooting the wifi

    Not quite the right solution - that's a pity.

    I notice that you use the 5.8 kernel in your output.
    There are some recent forum posts about this kernel causing problems with Internet, Sound, Virtual machines etc.

    Do you have another kernel that you can pick when booting the device?

  7. #7
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,443
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Rebooting the wifi

    I'd much rather diagnose and fix the reason it's dropping rather than slapping a band-aid on it. May we see:

    Code:
    sudo dmesg | grep -e iwl -e wlp
    You might also look at the settings in your router.

    Your wireless may be dropping because of power management; that is, the feature where the card partially powers down to save battery power during periods of inactivity and then, ideally, powers back up seamlessly when activity resumes. Let's disable pwer saving to see if it helps. From the terminal:

    Code:
    sudo sed -i 's/3/2/' /etc/NetworkManager/conf.d/*
    Your wireless may be dropping because the channel to which it was connected has suddnely changed.

    Please check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I recommend a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred.

    Your wireless may be dropping because there are two wireless access points with the same name and password. This is typical when you have a 2.4 gHz segment and a 5 gHz segment of the same router. Your wireless may be roaming, looking for a better connection. If this is the case, I suggest that you rename the access points; something like myrouter2.4 and myrouter5.

    After making these changes, reboot the router.

    Next, I recommend that your regulatory domain be set explicitly. Check yours:

    Code:
    sudo iw reg get
    If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

    Code:
    sudo iw reg set IS
    Of course, substitute your country code if not Iceland. Set it permanently:

    Code:
    sudo nano /etc/default/crda
    Change the last line to read:

    Code:
    REGDOMAIN=IS
    Proofread carefully, save and close the text editor.

    Is there any improvement?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  8. #8
    Join Date
    Dec 2020
    Beans
    29

    Re: Rebooting the wifi

    Thanks for the suggestions. Here's what I get from the dmesg command:

    sudo dmesg | grep -e iwl -e wlp
    [ 21.163361] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:s
    [ 21.163364] iwl3945: Copyright(c) 2003-2011 Intel Corporation
    [ 21.163365] iwl3945: hw_scan is disabled
    [ 21.163441] iwl3945 0000:10:00.0: can't disable ASPM; OS doesn't have ASPM control
    [ 21.217154] iwl3945 0000:10:00.0: Tunable channels: 11 802.11bg, 13 802.11a channels
    [ 21.217158] iwl3945 0000:10:00.0: Detected Intel Wireless WiFi Link 3945ABG
    [ 21.217526] ieee80211 phy0: Selected rate control algorithm 'iwl-3945-rs'
    [ 23.825839] iwl3945 0000:10:00.0 wlp16s0: renamed from wlan0
    [ 84.321984] iwl3945 0000:10:00.0: loaded firmware version 15.32.2.9
    [ 129.461967] wlp16s0: authenticate with 00:1c:10:46:3c:4b
    [ 129.465028] wlp16s0: send auth to 00:1c:10:46:3c:4b (try 1/3)
    [ 129.466856] wlp16s0: authenticated
    [ 129.467762] iwl3945 0000:10:00.0 wlp16s0: disabling HT/VHT/HE as WMM/QoS is not supported by the AP
    [ 129.469271] wlp16s0: associate with 00:1c:10:46:3c:4b (try 1/3)
    [ 129.471902] wlp16s0: RX AssocResp from 00:1c:10:46:3c:4b (capab=0x411 status=0 aid=5)
    [ 129.474945] wlp16s0: associated
    [ 129.754956] IPv6: ADDRCONF(NETDEV_CHANGE): wlp16s0: link becomes ready
    [ 129.755672] iwl3945 0000:10:00.0: Enabling power save might cause firmware crashes


    Hmm, that last line looks rather ominous.
    I had also wondered if it might be a power management issue, but didn't know where to look. I'll try disabling the power saving and report back later. I'll also check the router settings and report back.

  9. #9
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,443
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Rebooting the wifi

    May we also see the results of the wireless script? https://ubuntuforums.org/showthread.php?t=370108
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  10. #10
    Join Date
    Dec 2020
    Beans
    29

    Re: Rebooting the wifi

    Here is the router configuration info:

    Mode: Mixed 11/54Mbps
    SSID: xxxxxxxxx
    DHCP Server: Enable
    Channel: 6
    Encryption Function: Enabled, WPA2-personal AES (was previously TKIP+AES)
    Wireless Network Mode: Auto (B or G, N not available)
    Wireless Network Name (SSID): xxxxxxxxx
    Wireless Channel: 6 - 2.437GHz
    Wireless SSID Broadcast: Enabled


    I also ran the wireless script, but it produces a huge file, which I'd rather not post in its entirety, because I'd have to go through it and edit out some private information. Which info do you need to see from it?

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •