I just installed Ubuntu for the first time & don't have a lot of experience with it yet so... Am I doing something wrong or is it just not compatible with Ubuntu?