Results 1 to 2 of 2

Thread: Cannot change the CPU governor. It always goes back to “ondemand” after reboot

  1. #1
    Join Date
    Jan 2021
    Beans
    2

    Cannot change the CPU governor. It always goes back to “ondemand” after reboot

    Hi! I'm running Xubuntu 20.10. I'm trying to change the CPU scaling governor to "conservative". But it always goes back to "ondemand" after reboot.


    I have a Ryzen 7 4800H. So, my CPU scaling driver is acpi-cpufreq. The kernel is 5.8.0-40-generic


    I tried with:
    # sudo cpupower frequency-set --governor conservative

    # for GOVERNOR in /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor; \ ─╯
    do \
    echo "conservative" | sudo tee $GOVERNOR; \
    done

    # sudo cpufreq-set -c 0 -g conservative
    Without success in any case. That's very hot...


    Do anybody knows what happen?

  2. #2
    Join Date
    Jan 2021
    Beans
    2

    Re: Cannot change the CPU governor. It always goes back to “ondemand” after reboot

    Finally, I solved editing the file
    Code:
    /etc/init.d/cpufrequtils

    And setting the variable
    Code:
    GOVERNOR="conservative"

    Note: Maybe you need to install
    Code:
    cpufrequtils
    first
    Last edited by marcesdan; January 28th, 2021 at 04:18 AM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •