Results 1 to 4 of 4

Thread: No ethernet connection in dual boot with Windows 10 and Kubuntu

  1. #1
    Join Date
    Jan 2021
    Beans
    2

    No ethernet connection in dual boot with Windows 10 and Kubuntu

    I already posted this qustion here: https://askubuntu.com/questions/1305...10-and-kubuntu but got no useful answers.
    This is the question:


    I am currently dual booting Kubuntu (20.04.1 LTS) and Windows 10 (should be up to date).
    I only started doing this yesterday and at the beginning everything worked fine. However after switching to Windows to export some config files and then switching back to Kubuntu I had no Internet (at all) and no Sound (USB Headset). Both of these still work as of right now (typing this in Windows 10).


    Im on a Ethernet connection with a Realtek controller (on my motherboard), Windows won't say much more but this is the driver version: 10.37.1028.2019
    My Headset is a Sound blaster XH6, also working fine on Windows but getting Ethernet working is my priority right now.


    Here is the (probably incomplete list) of what I tried:

    • Shutting down Windows instead of restarting
    • Disabling "Allow the computer to turn off this device to save power" in Device Manager
    • Enabling/Disabling "Shutdown Wake-On-Lan" in Device Manager
    • Running ipconfig /release before exiting Windows
    • Setting up a new Ethernet connection in Kubuntu



    I am out of ideas from myself and already looked at tons of questions, none having an answer that also helped me.

    Please tell me if I need to provide more information.


    Output of running lscpi on Kubuntu: https://pastebin.com/shmkpzRc

  2. #2
    Join Date
    Dec 2020
    Beans
    41

    Re: No ethernet connection in dual boot with Windows 10 and Kubuntu

    Hi,

    Seems that you have same ethernet card as me. After upgrading kernel today I also had problem with my ethernet card, which has worked yesterday. Check out my solution here:
    https://ubuntuforums.org/showthread.php?t=2456227

  3. #3
    Join Date
    Jan 2021
    Beans
    2

    Re: No ethernet connection in dual boot with Windows 10 and Kubuntu

    Thanks, I already fixed it by using an older kernel at boot but im going to take a look at your post.

  4. #4
    Join Date
    Jun 2008
    Location
    Baytown, TX
    Beans
    51
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: No ethernet connection in dual boot with Windows 10 and Kubuntu

    I had a similar problem after kernel update with a Broadcom Wi-Fi/Bluetooth adapter in my laptop. I had performed a couple of workarounds already with previous kernels but it finally gave up entirely in Ubuntu (still worked in Windows). $15 and one laptop disassembly/reassembly later I installed an Intel adapter and my issues went away. Support for Linux is not always assured.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •