Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: TP-LINK Archer T9UH in 20.04 (kernel 5.4.0-58)

  1. #1
    Join Date
    Jan 2021

    TP-LINK Archer T9UH in 20.04 (kernel 5.4.0-58)

    Hey to all!

    I have 2 OS on my desktop, so I have tested TP-LINK Archer T9UH wifi adapter in the Windows 10 and it works fine.

    However in the Ubuntu I don't able even to see it via lsusb: I received empty response. After reboot, lsusb works, but it freezes after the adapter inserted into any of USB slots.
    I have tried to use and but it seems like there is no effect.

    What should I do, any ideas? Mb I need to clean old drivers in some way. I could even install the another Ubuntu version if I was sure that this would help.

    PS: my previous wi-fi adapter was TP-LINK TL-WN727N and it worked as expected.

    System info: Linux version 5.4.0-58-generic (buildd@lcy01-amd64-004) (gcc version 9.3.0 (Ubuntu 9.3.0-17ubuntu1~20.04))
    Last edited by wildmanne39; January 4th, 2021 at 09:05 PM. Reason: Reset fonts

  2. #2
    Join Date
    Jan 2021

    Re: TP-LINK Archer T9UH in 20.04 (kernel 5.4.0-58)

    modinfo 8812au:

    filename:       /lib/modules/5.4.0-58-generic/updates/dkms/8812au.ko
    version:        v4.3.8_12175.20140902
    author:         Realtek Semiconductor Corp.
    description:    Realtek Wireless Lan Driver
    license:        GPL
    srcversion:     A1B4B8FF70567B29CF1C971
    alias:          usb:v056Ep4007d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v0411p0242d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v2019pAB32d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v0846p9052d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v0E66p0023d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v2001p3318d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v2001p3314d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v04BBp0953d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v7392pA813d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v7392pA812d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v7392pA811d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v0BDAp0820d*dc*dsc*dp*icFFiscFFipFFin*
    alias:          usb:v0BDAp8822d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v0BDAp0821d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v0BDAp0811d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v0411p025Dd*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v2357p0103d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v2357p0101d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v20F4p805Bd*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v2001p3316d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v2001p3315d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v07B8p8812d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v2019pAB30d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v1740p0100d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v148Fp9097d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v13B1p003Fd*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v1058p0632d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v2001p3313d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v0586p3426d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v0E66p0022d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v0B05p17D2d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v0409p0408d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v0789p016Ed*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v04BBp0952d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v0DF6p0074d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v7392pA822d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v2001p330Ed*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v050Dp1109d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v050Dp1106d*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v0BDAp881Cd*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v0BDAp881Bd*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v0BDAp881Ad*dc*dsc*dp*ic*isc*ip*in*
    alias:          usb:v0BDAp8812d*dc*dsc*dp*ic*isc*ip*in*
    depends:        cfg80211
    retpoline:      Y
    name:           8812au
    vermagic:       5.4.0-58-generic SMP mod_unload 
    sig_id:         PKCS#7
    signer:         alex-pc Secure Boot Module Signature key
    sig_key:        40:D1:86:70:0C:3B:FA:48:61:F6:7A:29:C5:99:E9:97:80:97:23:B9
    sig_hashalgo:   sha512
    signature:      86:65:3D:01:18:72:75:CA:36:2E:3C:F2:78:29:08:1A:33:62:36:BF:
    parm:           rtw_ips_mode:The default IPS mode (int)
    parm:           rtw_usb_rxagg_mode:int
    parm:           rtw_qos_opt_enable:int
    parm:           ifname:The default name to allocate for first interface (charp)
    parm:           if2name:The default name to allocate for second interface (charp)
    parm:           rtw_initmac:charp
    parm:           rtw_channel_plan:int
    parm:           rtw_special_rf_path:int
    parm:           rtw_chip_version:int
    parm:           rtw_rfintfs:int
    parm:           rtw_lbkmode:int
    parm:           rtw_network_mode:int
    parm:           rtw_channel:int
    parm:           rtw_mp_mode:int
    parm:           rtw_wmm_enable:int
    parm:           rtw_vrtl_carrier_sense:int
    parm:           rtw_vcs_type:int
    parm:           rtw_busy_thresh:int
    parm:           rtw_ht_enable:int
    parm:           rtw_bw_mode:int
    parm:           rtw_ampdu_enable:int
    parm:           rtw_rx_stbc:int
    parm:           rtw_ampdu_amsdu:int
    parm:           rtw_vht_enable:int
    parm:           rtw_lowrate_two_xmit:int
    parm:           rtw_rf_config:int
    parm:           rtw_power_mgnt:int
    parm:           rtw_smart_ps:int
    parm:           rtw_low_power:int
    parm:           rtw_wifi_spec:int
    parm:           rtw_antdiv_cfg:int
    parm:           rtw_antdiv_type:int
    parm:           rtw_enusbss:int
    parm:           rtw_hwpdn_mode:int
    parm:           rtw_hwpwrp_detect:int
    parm:           rtw_hw_wps_pbc:int
    parm:           rtw_max_roaming_times:The max roaming times to try (uint)
    parm:           rtw_mc2u_disable:int
    parm:           rtw_80211d:Enable 802.11d mechanism (int)
    parm:           rtw_notch_filter:0:Disable, 1:Enable, 2:Enable only for P2P (uint)
    parm:           rtw_hiq_filter:0:allow all, 1:allow special, 2:deny all (uint)
    parm:           rtw_adaptivity_en:0:disable, 1:enable, 2:auto (uint)
    parm:           rtw_adaptivity_mode:0:normal, 1:carrier sense (uint)
    parm:           rtw_nhm_en:0:disable, 1:enable (uint)
    parm:           rtw_amplifier_type_2g:BIT3:2G ext-PA, BIT4:2G ext-LNA (uint)
    parm:           rtw_amplifier_type_5g:BIT6:5G ext-PA, BIT7:5G ext-LNA (uint)
    parm:           rtw_RFE_type:default init value:64 (uint)
    parm:           rtw_TxBBSwing_2G:default init value:0xFF (uint)
    parm:           rtw_TxBBSwing_5G:default init value:0xFF (uint)
    parm:           rtw_tx_pwr_lmt_enable:0:Disable, 1:Enable, 2: Depend on efuse (int)
    parm:           rtw_tx_pwr_by_rate:0:Disable, 1:Enable, 2: Depend on efuse (int)
    parm:           rtw_phy_file_path:The path of phy parameter (charp)
    parm:           rtw_load_phy_file:PHY File Bit Map (int)
    parm:           rtw_decrypt_phy_file:Enable Decrypt PHY File (int)
    Last edited by en1i; January 4th, 2021 at 09:08 PM.

  3. #3
    Join Date
    Feb 2008
    Ubuntu 20.04 Focal Fossa

    Re: TP-LINK Archer T9UH in 20.04 (kernel 5.4.0-58)

    Hello and welcome to the forum en1i.

    Thread moved to Networking & Wireless for a more appropriate fit.

    Please use the default font color and properties unless you need to highlight or draw attention to a part of your post.

  4. #4
    Join Date
    Jan 2021

    Re: TP-LINK Archer T9UH in 20.04 (kernel 5.4.0-58)

    sure, thanks

    Okay, by some reason lsusb started to work. What I have done: reboot -> mount old wifi adapter -> unmount it -> mount Archer T9UH
    for now the lsusb is:
    Bus 002 Device 002: ID 0bc2:61b6 Seagate RSS LLC Maxtor HX-M101TCB/GM [M3 Portable 1TB]
    Bus 002 Device 003: ID 174c:3074 ASMedia Technology Inc. ASM1074 SuperSpeed hub
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 007: ID 1c4f:0026 SiGma Micro Keyboard
    Bus 001 Device 005: ID 1a40:0101 Terminus Technology Inc. Hub
    Bus 001 Device 003: ID 041e:3256 Creative Technology, Ltd Sound BlasterX G6
    Bus 001 Device 004: ID 2357:0106 TP-Link Archer T9UH v1 [Realtek RTL8814AU]
    Bus 001 Device 002: ID 174c:2074 ASMedia Technology Inc. ASM1074 High-Speed hub
    Bus 001 Device 008: ID 12d1:4321 Huawei Technologies Co., Ltd. UVC Camera
    Bus 001 Device 006: ID 09da:9090 A4Tech Co., Ltd. XL-730K / XL-750BK / XL-755BK Mice
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    But still no Wi-fi icon. And the interesting thing: u can see that it detects T9UH - under the version 1. However, the adapter has label in the back side with a version 2

  5. #5
    Join Date
    Jan 2021

    Re: TP-LINK Archer T9UH in 20.04 (kernel 5.4.0-58)

    dkms status:

    nvidia, 450.80.02, 5.4.0-56-generic, x86_64: installed
    nvidia, 450.80.02, 5.4.0-58-generic, x86_64: installed
    realtek-rtl88xxau, added
    rtl8812au,, 5.4.0-58-generic, x86_64: installed
    rtl8814au, 4.3.21, 5.4.0-58-generic, x86_64: built
    so I have 3 different wireless drivers in the system. I think I should leave only one

  6. #6
    Join Date
    Jan 2021

    Re: TP-LINK Archer T9UH in 20.04 (kernel 5.4.0-58)

    Okay, I moved to "/lib/modules/5.4.0-58-generic/updates/dkms" , checked that I have "8812au.ko" folder inside.

    Than I run
    sudo dkms uninstall rtl8812au/
    checked that "8812au.ko" no longer exists
    and "rtl8812au" no longer installed:
    "dkms status"
    nvidia, 450.80.02, 5.4.0-56-generic, x86_64: installed
    nvidia, 450.80.02, 5.4.0-58-generic, x86_64: installed
    realtek-rtl88xxau, added
    rtl8812au,, 5.4.0-58-generic, x86_64: built
    rtl8814au, 4.3.21, 5.4.0-58-generic, x86_64: built
    Then install rtl8814:
    sudo dkms install rtl8814au/4.3.21
    But it is not working. After the reboot "lsusb" didn't respond again. So I think rtl8812au is the correct version, but by some reason it doesn't work
    Last edited by en1i; January 4th, 2021 at 10:21 PM.

  7. #7
    Join Date
    Jan 2021

    Re: TP-LINK Archer T9UH in 20.04 (kernel 5.4.0-58)

    Seems like TP-LINK adapters in not working with the latest kernel versions (from 5.3.42)
    How to downgrade to another version?)

  8. #8
    Join Date
    May 2014
    Ubuntu 18.04 Bionic Beaver

    Re: TP-LINK Archer T9UH in 20.04 (kernel 5.4.0-58)

    You actually need the rtl8814au version from the aircrack-ng repo on github. They took that one out of rtl8812au recently

  9. #9
    Join Date
    Jan 2021

    Re: TP-LINK Archer T9UH in 20.04 (kernel 5.4.0-58)

    Kicked it working.
    What I have done: downgraded kernel version, reboot in it and reinstall drivers for adapter

    Working kernel:
    Instruction how to install another kernel:
    Reboot after installation
    Select in grub loader "Additional", then select chosen kernel version
    Then u need to reinstall drivers for wifi adapter. In my case, working repository is
    cd ~/Downloads
    git clone
    sudo dkms add  ~/Downloads/rtl8814au
    sudo dkms install rtl8814au/4.3.21
    Last edited by en1i; January 5th, 2021 at 01:01 AM.

  10. #10
    Join Date
    May 2014
    Ubuntu 18.04 Bionic Beaver

    Re: TP-LINK Archer T9UH in 20.04 (kernel 5.4.0-58)

    I see this in the source code {code] {USB_DEVICE(0x2357, 0x0106), .driver_info = RTL8814A}, /* TP-LINK Archer T9UH */[/code]
    The aircrack-ng/rtl8812au repo doesn't support the rtl8814au any more, but if your download in /Downloads is old enough it might work. Post URL from terminal for
    cat /Downloads/rtl8812au/Makefile | nc 9999

Page 1 of 3 123 LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts