Results 1 to 10 of 10

Thread: Migrating touchpad settings into xfconf ignores "Synaptics Move Speed"?

  1. #1
    Join Date
    Jun 2016
    Beans
    2,151
    Distro
    Xubuntu 20.04 Focal Fossa

    Migrating touchpad settings into xfconf ignores "Synaptics Move Speed"?

    I have for a long time used custom configuration method for my touchpad: synclient -l output is stored in a file, and a script is run on login to restore it back through synclient. I would like to move these settings into xfconf as described here.

    I wrote a script to convert the xinput list-props output into xfconf, that part works fine.

    But unplugging & plugging in my touchpad does not correctly apply "Synaptics Move Speed"?

    Comparing xinput list-props output for my touchpad:

    • Default of this setting, without any config -
      Code:
      Synaptics Move Speed (576):	1.000000, 1.750000, 0.112296, 0.000000
    • Desired -
      Code:
      Synaptics Move Speed (576):	2.000000, 9.000000, 0.000000, 0.000000
    • What xfce sets -
      Code:
      Synaptics Move Speed (576):	2.000000, 0.000000, 0.112296, 0.000000



    All other settings seem applied correctly. Settings Editor shows the correct value for "Synaptics_Move_Speed".

    How to get Xfce to apply "Synaptics Move Speed" correctly?

  2. #2
    Join Date
    Jun 2016
    Beans
    2,151
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Migrating touchpad settings into xfconf ignores "Synaptics Move Speed"?

    bump

  3. #3
    Join Date
    Jun 2016
    Beans
    2,151
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Migrating touchpad settings into xfconf ignores "Synaptics Move Speed"?

    bump

  4. #4
    Join Date
    Jun 2016
    Beans
    2,151
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Migrating touchpad settings into xfconf ignores "Synaptics Move Speed"?

    bump

  5. #5
    Join Date
    Jun 2016
    Beans
    2,151
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Migrating touchpad settings into xfconf ignores "Synaptics Move Speed"?

    bump

  6. #6
    Join Date
    Jun 2016
    Beans
    2,151
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Migrating touchpad settings into xfconf ignores "Synaptics Move Speed"?

    bump

  7. #7
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Migrating touchpad settings into xfconf ignores "Synaptics Move Speed"?

    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

  8. #8
    Join Date
    Jun 2016
    Beans
    2,151
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Migrating touchpad settings into xfconf ignores "Synaptics Move Speed"?

    Sorry 1fallen I don't understand what you're suggesting? Are you suggesting I try to put this property in a xorg.conf.d file instead of trying to set it through Xfce?

  9. #9
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Migrating touchpad settings into xfconf ignores "Synaptics Move Speed"?

    Both, it's a bit trial and error though I'm afraid.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

  10. #10
    Join Date
    Jun 2016
    Beans
    2,151
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Migrating touchpad settings into xfconf ignores "Synaptics Move Speed"?

    Sorry for the unexpected delay in being able to get back to this. Something else fishy is going on with that property - though applying it in a xorg.conf.d file did apply it, that made my touchpad WAY too fast. Anyway I think with this I should be able to achieve what I want, just will take some fiddling to get it right for me, so considering this solved. Thanks 1fallen!

    * After some more playing with this property, I conclude I actually don't want to explicitly set it at all. I got the desired effect by leaving "Synaptics Move Speed" alone, instead going to Xfce Mouse & Touchpad settings and set Acceleration to 0 and Sensitivity to 1px. Can't believe I didn't think of trying those settings sooner
    Last edited by halogen2; March 22nd, 2021 at 11:14 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •