Results 1 to 9 of 9

Thread: [18.04.5] Grub Menu Timeout

  1. #1
    Join Date
    Jan 2007
    Beans
    327
    Distro
    Ubuntu 20.04 Focal Fossa

    Question [18.04.5] Grub Menu Timeout

    Is it possible to change the timeout that grub uses at the menu to boot Ubuntu? I think the default is around 20-30 seconds but I would like to change this to 5 seconds if possible.

    Last edited by Graham1; January 2nd, 2021 at 09:26 AM.

  2. #2
    Join Date
    May 2013
    Location
    Galiza
    Beans
    3,597
    Distro
    Ubuntu

    Re: [18.04.5] Grub Menu Timeout

    Yes, it is possible but personally I don't recommend it. If you're seeing the Grub menu it's because you have a dual-boot or multi-boot. 5 seconds is probably very short for comfortably select another OS. BTW, the default is 10 seconds.

    But if you want to do it then:
    Code:
    sudoedit /etc/default/grub
    and change
    Code:
    [COLOR=var(--highlight-color)]GRUB_TIMEOUT=10[/COLOR]
    to the value you want.

    There are literally thousands of pages on the net saying the same thing. Googling would have been a lot faster then posting and waiting for an answer.

  3. #3
    Join Date
    Jan 2007
    Beans
    327
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: [18.04.5] Grub Menu Timeout

    Hi CelticWarrior

    Thanks for the quick reply . The machine I'm setting up is for Mame and Retroarch only, so no other OS involved. I think the menu was added due to UEFI as I was unable to install the good old fashioned way . I'm sure the timeout was at least 20 seconds, so really want it to boot as quick as possible with the option (briefly) should I need to get into the settings. If I break things, hopefully Timeshift will come to my rescue.


  4. #4
    Join Date
    May 2013
    Location
    Galiza
    Beans
    3,597
    Distro
    Ubuntu

    Re: [18.04.5] Grub Menu Timeout

    UEFI or BIOS installs do NOT show the Grub menu with only Ubuntu installed.

    I was unable to install the good old fashioned way
    That's a good thing. Why would any sane person want the "old-fashioned way" in a modern UEFI machine?

    I'm sure the timeout was at least 20 seconds
    I'm sure the default is 10 seconds. Unless you changed it to 20 - in which case this whole thread would be nonsensical - then no, you're absolutely wrong about that. It's possible that you're considering the POST also but you shouldn't, the Grub timeout counts from the moment the POST is over and the firmware relays control to the OS. And while you can change the Grub timeout value, you CAN'T change the time your specific computer takes until it finally starts some bootloader.

  5. #5
    Join Date
    Jan 2007
    Beans
    327
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: [18.04.5] Grub Menu Timeout

    Quote Originally Posted by CelticWarrior View Post
    UEFI or BIOS installs do NOT show the Grub menu with only Ubuntu installed.
    I would also agree but in this case, only Ubuntu 18.04.5 is installed and was partitioned manually. Existing partitions deleted prior to install.

    That's a good thing. Why would any sane person want the "old-fashioned way" in a modern UEFI machine?
    Personally, I have found UEFI to be a PITA and for this setup, security isn't required.

    I'm sure the default is 10 seconds. Unless you changed it to 20 - in which case this whole thread would be nonsensical - then no, you're absolutely wrong about that. It's possible that you're considering the POST also but you shouldn't, the Grub timeout counts from the moment the POST is over and the firmware relays control to the OS. And while you can change the Grub timeout value, you CAN'T change the time your specific computer takes until it finally starts some bootloader.
    Having checked, the timeout was 30 seconds. This wasn't a one off as I re-installed Ubuntu twice with the same results. For some reason, I couldn't install grub (during installation) without having UEFI enabled in the BIOS. Having used mostly older equipment (non uefi), this may have been the reason as Ubuntu forces you to create an EFI partition. Thinking about it, this may have been due to having a GPT partition instead.


  6. #6
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    8,134
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: [18.04.5] Grub Menu Timeout

    Quote Originally Posted by Graham1 View Post
    Personally, I have found UEFI to be a PITA and for this setup, security isn't required.
    Using UEFI doesn't have anything to do with security, it's just less old and manky than BIOS.

  7. #7
    Join Date
    Jan 2007
    Beans
    327
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: [18.04.5] Grub Menu Timeout

    Quote Originally Posted by CatKiller View Post
    Using UEFI doesn't have anything to do with security, it's just less old and manky than BIOS.
    Tbh, I've never had any issues with the BIOS. UEFI caused issues with secure boot and signed usb keys.


  8. #8
    Join Date
    Jun 2008
    Location
    Byron, CA, USA
    Beans
    547
    Distro
    Ubuntu 20.04 Focal Fossa

    Post Re: Grub Menu Timeout

    FWIW, Canonical includes the following base settings for /etc/default/grub.ucf-dist (comments redacted):
    Code:
    GRUB_DEFAULT=0
    GRUB_TIMEOUT_STYLE=hidden
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="debug"
    GRUB_CMDLINE_LINUX=""
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
    #GRUB_TERMINAL=console
    #GRUB_GFXMODE=640x480
    #GRUB_DISABLE_LINUX_UUID=true
    #GRUB_DISABLE_RECOVERY="true"
    #GRUB_INIT_TUNE="480 440 1"
    For my Hot Rod gPC and a system I'm prepping for projector duty in a house of worship, I set GRUB_TIMEOUT=5 and GRUB_INIT_TUNE="480 440 1". The GRUB Menu has an independent default countdown.

    As of 29 December 2020 I'm still waiting on a reply to a question on configuring an Acer G43T-AM-based system with a Creative Technology CA0102-equipped audio card for boot parameters and whether I can use a 64-bit kernel with an audio card with a 31-bit DMA controller.
    Last edited by bcschmerker; December 30th, 2020 at 12:30 AM. Reason: Append relevant data.
    Video Drivers:
    nVIDIA® nForce® chipsets require discrete GPU's up to Kepler and appropriate nVIDIA Kernel modules.
    Most intel® ExpressSets™ and AMD® RS-Series are fully supported in open source.

  9. #9
    Join Date
    Jan 2007
    Beans
    327
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Grub Menu Timeout

    Quote Originally Posted by bcschmerker View Post
    For my Hot Rod gPC and a system I'm prepping for projector duty in a house of worship, I set GRUB_TIMEOUT=5 and GRUB_INIT_TUNE="480 440 1". The GRUB Menu has an independent default countdown.
    Yes, having changed GRUB_TIMEOUT, this didn't seem to make any difference or any other settings added .

    To resolve my issue, I ended up removing GPT and re-created my disk as MBR. Grub installed to the MBR without any issues and all working now.


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •