Results 1 to 6 of 6

Thread: apt/dpkg status-old file error

  1. #1
    Join Date
    May 2019
    Beans
    16

    apt/dpkg status-old file error

    when i try to install a package or upgrade or even dpkg -i
    i get the error E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem. which isnt anything unusual it happens when i stop apt while installing something but after running that command i get dpkg: error: error creating new backup file '/var/lib/dpkg/status-old': Operation not permitted
    i tried to make status-old with touch after running the command again it gets removed
    i tried copying status to status-old it gets removed
    when i run apt update sometimes it runs without any issues and the status file is there other times i get
    E: flAbsPath on /var/lib/dpkg/status failed - realpath (2: No such file or directory)
    E: Could not open file - open (2: No such file or directory)
    E: Problem opening
    E: The package lists or status file could not be parsed or opened.
    and status file file is called status-new so if i rename it to status apt update will work again
    distro is kali but because its based on ubuntu i thought i will post it here
    it was working like last night
    also just a quick info in /var/backups there is no dpkg backup nor there is a backup in /var/lib/dpkg
    Last edited by bardiamgtgc; December 21st, 2020 at 10:55 PM.

  2. #2
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    13,905
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: apt/dpkg status-old file error

    bardiamgtgc; Hello -

    Try:
    Code:
    sudo rm -fr /var/lib/apt/lists
    sudo mkdir -pv /var/lib/apt/lists/partial
    sudo apt update
    sudo apt upgrade
    MergeLists are a working tool of apt, part of the way it keeps track of which packages are in which repositories. It's the gears of a text-based database that apt relies upon. When corrupted, they can be safely deleted. Apt will recreate them during the next apt update.

    my bit to try and help
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  3. #3
    Join Date
    May 2019
    Beans
    16

    Re: apt/dpkg status-old file error

    hey thanks for your reply
    i tried doing this didnt really seem to work same errors

  4. #4
    Join Date
    May 2010
    Beans
    1,718

    Re: apt/dpkg status-old file error

    What is the full output of
    Code:
    sudo apt-get update
    sudo apt-get upgrade

  5. #5
    Join Date
    May 2019
    Beans
    16

    Re: apt/dpkg status-old file error

    if i dont rename status-new to status:

    root@localhost:/var/lib/dpkg# sudo apt-get update;sudo apt-get update >> output
    Hit:1 http://mirror.fsmg.org.nz/kali kali-rolling InRelease
    Reading package lists... Error!
    E: flAbsPath on /var/lib/dpkg/status failed - realpath (2: No such file or directory)
    E: Could not open file - open (2: No such file or directory)
    E: Problem opening
    E: The package lists or status file could not be parsed or opened.
    E: flAbsPath on /var/lib/dpkg/status failed - realpath (2: No such file or directory)
    E: Could not open file - open (2: No such file or directory)
    E: Problem opening
    E: The package lists or status file could not be parsed or opened.

    if i rename status-new to status it will be this:

    root@localhost:/var/lib/dpkg# apt update
    Hit:1 http://mirror.fsmg.org.nz/kali kali-rolling InRelease
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    3 packages can be upgraded. Run 'apt list --upgradable' to see them.
    root@localhost:/var/lib/dpkg# apt upgrade
    E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
    root@localhost:/var/lib/dpkg# dpkg --configure -a
    dpkg: error: error creating new backup file '/var/lib/dpkg/status-old': Operation not permitted

  6. #6
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    12,311
    Distro
    Ubuntu

    Re: apt/dpkg status-old file error

    Thread moved to Ubuntu/Debian BASED
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •