Results 1 to 9 of 9

Thread: Not able to press small "n" in terminal

  1. #1
    Join Date
    Dec 2020
    Beans
    3

    Not able to press small "n" in terminal

    hello,
    i am not able to press small n on terminal but able to press n everywhere else like browser and other application what should i do ?
    Last edited by akash-pandey; December 6th, 2020 at 12:14 PM.

  2. #2
    Join Date
    Aug 2011
    Location
    51.8° N 5.8° E
    Beans
    5,609
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Not able to press small "n" in terminal

    Sounds like somehow a keyboard shortcut was defined for the terminal using the n key. The terminal than hijacks the n keystroke and performs some action, without passing it on to the application running in the terminal (like the shell).

    Can you find anything about keyboard shortcuts in your (I assume) gnome-terminal? I use the xfce terminal myself, as I use Xubuntu.

  3. #3
    Join Date
    Sep 2009
    Location
    Pennsylvania
    Beans
    3,329
    Distro
    Xubuntu

    Re: Not able to press small "n" in terminal

    Is this a wireless keyboard? If so, I had one with a similar problem. It had worked for over a year and then the problem started. I tried it on another machine and it did the same thing. I had to replace it finally.

    If it wireless, can you hook up a wired keyboard to see if you have the same issue?

  4. #4
    Join Date
    May 2013
    Location
    Galiza
    Beans
    3,168
    Distro
    Ubuntu

    Re: Not able to press small "n" in terminal

    @Autodave

    Not an hardware (keyboard) issue because the OP is
    not able to press small n on terminal but able to press n everywhere else like browser and other application
    And being the lowercase "n" only also rules out hardware.
    And key failing can happen to any keyboard, why ask specifically about a wireless one?

  5. #5
    Join Date
    Oct 2005
    Location
    Lab, Slovakia
    Beans
    10,169

    Re: Not able to press small "n" in terminal

    I would first try a different terminal app, such as the good old xterm.
    If it has the same problem, look for a xmodmap configuration file in your home directory, maybe that is remapping the 'n'.
    Look in the usual Bash configuration files which may run when the terminal is started, such as described here https://www.stefaanlippens.net/bashrc_and_others/

  6. #6
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    11,712
    Distro
    Ubuntu

    Re: Not able to press small "n" in terminal

    Copy paste this into a terminal to see if 'n' it set as a shortcut
    Code:
    dconf dump /org/gnome/terminal/legacy/keybindings/
    if it is, you can copy/paste this to reset to the defaults
    Code:
    dconf reset -f /org/gnome/terminal/legacy/keybindings/
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  7. #7
    Join Date
    Dec 2020
    Beans
    3

    Re: Not able to press small "n" in terminal

    Quote Originally Posted by deadflowr View Post
    Copy paste this into a terminal to see if 'n' it set as a shortcut
    Code:
    dconf dump /org/gnome/terminal/legacy/keybindings/
    if it is, you can copy/paste this to reset to the defaults
    Code:
    dconf reset -f /org/gnome/terminal/legacy/keybindings/

    thank you so much.
    it works

  8. #8
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    11,712
    Distro
    Ubuntu

    Re: Not able to press small "n" in terminal

    Good to hear.

    For the record, Shortcuts can be set in the Preferences settings.
    Should be accessible by clicking on the Terminal name in the top panel of the desktop.
    Ubuntu has a mildly global menu setting for whatever app in is focus on the top panel.
    (Mildly because some apps are more verbose than others, so I felt mildly fit well to describe it)

    It should also be accessible by right clicking and selecting Preferences from a context window.

    Unfortunately, The preferences settings don't ever seem to have any easy way to reset shortcuts,
    only change them to another shortcut,
    which is why I posted to the go-around of using the dconf backend, fwiw.

    Ubuntu uses The GNOME desktop which uses dconf for the user's basic configuration system.
    The terminal happens to be a GNOME app, so it luckily has a dconf setting.
    More on dconf here: https://wiki.gnome.org/Projects/dconf


    If you feel the problem has been solved please mark this thread as solved:
    https://wiki.ubuntu.com/UnansweredPo.../SolvedThreads
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  9. #9
    Join Date
    Sep 2009
    Location
    Pennsylvania
    Beans
    3,329
    Distro
    Xubuntu

    Re: Not able to press small "n" in terminal

    I like to rule out hardware issues first. If another keyboard was available, this would have taken less than a minute. I have seen too many "wild goose" chases here and other places to not rule out the simple stuff.

    From my own experience, I had a wireless keyboard that wouldn't do 3 capital letters only.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •