Results 1 to 4 of 4

Thread: Broken apt install

  1. #1
    Join Date
    Jul 2007
    Beans
    48

    Broken apt install

    Hi,

    I installed 18.04 (I need that version for a build system), but it could not install packages:
    Code:
    $ sudo apt install git
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     git : Depends: liberror-perl but it is not installable
    E: Unable to correct problems, you have held broken packages.
    Code:
    $ sudo apt install liberror-perl 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Package liberror-perl is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    
    E: Package 'liberror-perl' has no installation candidate
    I've run apt update and apt upgrade to 18.04.5, the problem persisits, how can I fix it?


    Here is the sources.list:

    Code:
    $ cat sources.list
    # deb cdrom:[Ubuntu 18.04.2 LTS _Bionic Beaver_ - Release amd64 (20190210)]/ bionic main restricted
    
    # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
    # newer versions of the distribution.
    deb http://au.archive.ubuntu.com/ubuntu/ bionic restricted
    deb-src http://au.archive.ubuntu.com/ubuntu/ bionic main restricted
    
    ## Major bug fix updates produced after the final release of the
    ## distribution.
    deb http://au.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
    deb-src http://au.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
    
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team. Also, please note that software in universe WILL NOT receive any
    ## review or updates from the Ubuntu security team.
    deb http://au.archive.ubuntu.com/ubuntu/ bionic universe
    deb-src http://au.archive.ubuntu.com/ubuntu/ bionic universe
    deb http://au.archive.ubuntu.com/ubuntu/ bionic-updates universe
    deb-src http://au.archive.ubuntu.com/ubuntu/ bionic-updates universe
    
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
    ## team, and may not be under a free licence. Please satisfy yourself as to 
    ## your rights to use the software. Also, please note that software in 
    ## multiverse WILL NOT receive any review or updates from the Ubuntu
    ## security team.
    deb http://au.archive.ubuntu.com/ubuntu/ bionic multiverse
    deb-src http://au.archive.ubuntu.com/ubuntu/ bionic multiverse
    deb http://au.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
    deb-src http://au.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
    
    ## N.B. software from this repository may not have been tested as
    ## extensively as that contained in the main release, although it includes
    ## newer versions of some applications which may provide useful features.
    ## Also, please note that software in backports WILL NOT receive any review
    ## or updates from the Ubuntu security team.
    deb http://au.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse
    deb-src http://au.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse
    
    ## Uncomment the following two lines to add software from Canonical's
    ## 'partner' repository.
    ## This software is not part of Ubuntu, but is offered by Canonical and the
    ## respective vendors as a service to Ubuntu users.
    deb http://archive.canonical.com/ubuntu bionic partner
    deb-src http://archive.canonical.com/ubuntu bionic partner
    
    deb http://security.ubuntu.com/ubuntu bionic-security main restricted
    deb-src http://security.ubuntu.com/ubuntu bionic-security main restricted
    deb http://security.ubuntu.com/ubuntu bionic-security universe
    deb-src http://security.ubuntu.com/ubuntu bionic-security universe
    deb http://security.ubuntu.com/ubuntu bionic-security multiverse
    deb-src http://security.ubuntu.com/ubuntu bionic-security multiverse

    Thank you.

    Kind regards.
    Last edited by deadflowr; November 30th, 2020 at 09:15 AM. Reason: code tags

  2. #2
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    11,724
    Distro
    Ubuntu

    Re: Broken apt install

    Enable main.
    Generally, it's the only repository you really need to have.
    You have the main security and updates repositories enabled, but not all packages in main have security fixes or general updates.
    liberror-perl has never been updated on 18.04, so it has neither an -updates version nor a -security version, yet.

    To enable just run
    Code:
    sudo add-apt-repository main
    sudo apt update
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  3. #3
    Join Date
    Jul 2007
    Beans
    48

    Re: Broken apt install

    Thanks deadflowr, that did trick, wandering why the ubuntu 18.04 default apt source list did not add that one?

  4. #4
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    11,724
    Distro
    Ubuntu

    Re: Broken apt install

    It is the default.
    Somehow, something happened to your setup that disabled it.
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •