Results 1 to 3 of 3

Thread: 20.04 Scanner error

  1. #1
    Join Date
    Aug 2006
    London, UK

    20.04 Scanner error

    Since installing 20.04 I can not use the scanner that comes with my Brother MFC-J5330DW. The printer side works.

    LSUSB re the brother printer
    Bus 002 Device 005: ID 04f9:03d3 Brother Industries, Ltd MFC-J5330DW

    Error opening device: Brother 4: bus 14:dev 1
    2nd error showing as out of memory

    Xsane finds 2 devices with same devices. When I choose the usb option it reports invalid argument.

    How can I get the scanner to work?

  2. #2
    Join Date
    Mar 2014

    Re: 20.04 Scanner error

    I have had similar issues with an HP Multifunction. Worked fine in 18.04 and not with 20.04. I found by removing the USB cable and connecting the printer to the WiFi then setting it up as a network printer/scanner it all started working again.

    Worth a try.

  3. #3
    Join Date
    Jan 2019

    Re: 20.04 Scanner error

    My old all-in-one worked great with 18.04 and Simple Scan. After trying for most of a day to get the scanning function to work with Ubuntu 20.04 and Manjaro to no avail, I finally bit the bullet and paid for proprietary software that has drivers that work with pretty much any scanner. Problem solved. Not an ideal solution for everyone I realize.
    Last edited by kema77; November 30th, 2020 at 08:32 PM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts