Results 1 to 4 of 4

Thread: Black screen after GRUB menu, "common" fixes haven't helped

  1. #1
    Join Date
    Feb 2008
    Beans
    105

    Black screen after GRUB menu, "common" fixes haven't helped

    I have a Threadripper 2920x server with a GT 710 video card (and some SAS drives) running 18.04. Mostly this is a headless box I SSH into, which works fine. But I also have a monitor/keyboard on the rack, and very early on it developed an issue where it was not outputting video from the gt710 for troubleshooting.

    I can see the SAS bios loading and it gets to the grub menu. When I select Ubuntu the screen goes black. It is booting, as I can still ssh in and access the machine, I'm just not getting hard video out.

    I am not very fluent with GRUB editing or kernel flags but I have tried the following things
    • adding 'quiet splash' to the 'linux' line
    • adding 'nomodeset' to the linux line
    • adding 'vga=791' to the linux line
    • setting 'gfxmode 1024x768`
    • running `sudo ubuntu-drivers autoinstall` through SSH, which installed a bunch of nvidia packages


    As I said I'm not very fluent with editing settings like the above, so (I cringe to say this but) it is possible I did any of them "wrong" somehow, if things like parameter order matter. Mainly I put the kernel flags at the end of the linux line, I also tried them between 'ro' and the one extra param I have there for an SSD power saving mode workaround. I also tried 'nomodeset' without the 'ro' setting (?). I am willing to try any of them again.

    Code:
    $ lspci -k | grep -EA3 'VGA|3D|Display'
    42:00.0 VGA compatible controller: NVIDIA Corporation GK208B [GeForce GT 710] (rev a1)
            Subsystem: ZOTAC International (MCO) Ltd. GK208B [GeForce GT 710]
            Kernel driver in use: nvidia
            Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia
    Any ideas?
    Last edited by apokkalyps; November 16th, 2020 at 02:54 AM.

  2. #2
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Black screen after GRUB menu, "common" fixes haven't helped

    If you have not installed nVidia driver, then nomodeset is correct boot paramter to use.
    I normally remove quiet splash and now put in noplymouth. Then I see boot process and perhaps any errors or warnings that are also in log file.

    sed -i '/GRUB_CMDLINE_LINUX_DEFAULT/ s/"quiet splash"/"noplymouth"/' /etc/default/grub

    Your autoinstall of driver should have worked.
    But you can only have one driver installed. New driver does not replace and old driver, so you have to first purge any previous nVidia drivers.
    If first install, it now should boot. But you now do not want nomodeset as that prevents nVidia driver from loading.
    UEFI boot install & repair info - Regularly Updated :
    https://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  3. #3
    Join Date
    Feb 2008
    Beans
    105

    Re: Black screen after GRUB menu, "common" fixes haven't helped

    Thanks for the sanity checks. What actually ended up fixing it was updating my kernel. I noticed choosing older kernels in grub booted normally.
    4.19.19 and older did not have an issue
    4.19.29 was my most "current" kernel. When chosen through the list of older kernels in "Advanced options for Ubuntu" in grub, it would, rather than blacking out the screen, show text but the video only would freeze (cursor not blinking) after "Loading initial ramdisk..." although booting would continue and I could ssh into a working system. Choosing that same kernel through the default "Ubuntu" menu option (it being my newest kernel) and it would give me a black screen.
    4.19.127 (the last 4.19) had exactly the same behavior. Chosen through the default menu item when it was the newest installed would give me a black screen, chosen through the "Advanced options for Ubuntu" list, it would show a console that would hang at "Loading initial ramdisk..." while the system finished booting to an otherwise functional state behind the frozen video.
    4.20+ Didn't have any wierd problems like this.

    `lsb_release -a` says I'm on 18.04.5 and that point release goes out with kernel 5.4 so I went ahead and just upgraded to that, actually I fat-fingered ukuu and updated to 5.5. But that seems to be working so I don't see a reason to go back to 5.4 or forward to 5.6 or .7 or .8

  4. #4
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Black screen after GRUB menu, "common" fixes haven't helped

    This should show if nVidia driver integrated into your kernels:
    #What is installed
    dkms status
    UEFI boot install & repair info - Regularly Updated :
    https://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •