Results 1 to 3 of 3

Thread: 20.04 boots up too slowly

  1. #1
    Join Date
    Apr 2019
    Beans
    47

    20.04 boots up too slowly

    Recently upgraded from 18.04 to 20.04. Boot up is (I think) unnecessarily slow. So I read some forums and started some investigating. In a nutshell I discovered networkwaitonline service was a bit slow so i disabled for the boot process and then I discovered that apparently, gdm3 was also a big factor in the boot up being slow. So i switched display manager from gdm3 to lightdm and I have to say, it is a little quicker.

    My issue with the boot up is this. After I put in my encryption password, the screen stays as is for approx 20-30 seconds ( apologies because i haven't actually timed it ), then the screen dims a little. Then it goes completely blank for approximately another 20 seconds before the lightdm login page appears, and then...it still takes another 20 seconds or so before my desktop appears.

    How can I stop or minimize this which I believe is slowing the boot process up.

    I have added my systemd-analyze critical chain read out for you and also my grub read out in case it helps you.


    Graphical.target @53.831s
    └─multi-user.target @53.831s
    └─networkd-dispatcher.service @29.217s +24.612s
    └─basic.target @28.356s
    └─sockets.target @28.356s
    └─snapd.socket @28.351s +2ms
    └─sysinit.target @28.085s
    └─snapd.apparmor.service @27.121s +963ms
    └─apparmor.service @25.341s +1.753s
    └─local-fs.target @25.338s
    └─run-snapd-ns-canonical\x2dlivepatch.mnt.mount @51.809s
    └─run-snapd-ns.mount @44.151s
    └─swap.target @23.654s
    └─dev-mapper-ubuntu\x2d\x2dvg\x2dswap_1.swap @22.128s +1.526s
    └─dev-mapper-ubuntu\x2d\x2dvg\x2dswap_1.device @22.116s


    Default grub readout

    # /boot/grub/grub.cfg.
    # For full documentation of the options in this file, see:
    # info -f grub -n 'Simple configuration'

    GRUB_DEFAULT="0"
    GRUB_TIMEOUT_STYLE="hidden"
    GRUB_TIMEOUT="0"
    GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""

    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xe fefefef"

    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL="console"

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE="640x480"

    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID="true"

    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_RECOVERY="true"

    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"

    Thanks in advance guys. I had a similar issue with 18.04 but somehow with 20.04, it seems more must be done to speed up the boot process....I'm just not sure what else i can do.

  2. #2
    Join Date
    Jun 2020
    Beans
    11

    Re: 20.04 boots up too slowly

    i faced the same problem and the solution was that the ISO file was incomplete maybe it is your problem too?

  3. #3
    Join Date
    Jan 2013
    Beans
    14

    Re: 20.04 boots up too slowly

    You can always backup your files and do a fresh install, another thing you can do is see what programs are starting up when your OS starts up.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •