Results 1 to 5 of 5

Thread: Gnome Sound settings Subwoofer slider stuck at 0, but pavucontrol works fine

  1. #1
    Join Date
    Mar 2013
    Beans
    10

    Gnome Sound settings Subwoofer slider stuck at 0, but pavucontrol works fine

    [COLOR=#242729][FONT=Arial]I've been having this weird issue for the last few releases and finally getting really annoying. At least 18.10 thru now 20.04 where the Subwoofer slider is locked at 0 and cannot be moved. However if I use pamixer, pavucontrol, etc I can override the subwoofer level and it's working absolutely fine. However if I click back into the Sound settings, it instantly sets the sub back to 0 as that's where the slider is and indeed sub is then back to 0 until I override it again thru pavuntrol, etc. Where is this setting stored and/or what drives it?

    L4CT8.png

    t7ILb.jpg

    /etc/pulse/daemon.conf
    Code:
    ; daemonize = no; fail = yes
    ; allow-module-loading = yes
    ; allow-exit = yes
    ; use-pid-file = yes
    ; system-instance = no
    ; local-server-type = user
    ; enable-shm = yes
    ; enable-memfd = yes
    ; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
    ; lock-memory = no
    ; cpu-limit = no
    
    ; high-priority = yes
    ; nice-level = -11
    
    ; realtime-scheduling = yes
    ; realtime-priority = 5
    
    ; exit-idle-time = 20
    ; scache-idle-time = 20
    
    ; dl-search-path = (depends on architecture)
    
    ; load-default-script-file = yes
    ; default-script-file = /etc/pulse/default.pa
    
    ; log-target = auto
    ; log-level = notice
    ; log-meta = no
    ; log-time = no
    ; log-backtrace = 0
    
    ; resample-method = speex-float-1
    ; avoid-resampling = false
    ; enable-remixing = yes
    ; remixing-use-all-sink-channels = yes
    ; enable-lfe-remixing = yes
    ; lfe-crossover-freq = 0
    
    ; flat-volumes = yes
    
    ; rlimit-fsize = -1
    ; rlimit-data = -1
    ; rlimit-stack = -1
    ; rlimit-core = -1
    ; rlimit-as = -1
    ; rlimit-rss = -1
    ; rlimit-nproc = -1
    ; rlimit-nofile = 256
    ; rlimit-memlock = -1
    ; rlimit-locks = -1
    ; rlimit-sigpending = -1
    ; rlimit-msgqueue = -1
    ; rlimit-nice = 31
    ; rlimit-rtprio = 9
    ; rlimit-rttime = 200000
    
    ; default-sample-format = s16le
    default-sample-rate = 96000
    alternate-sample-rate = 48000
    default-sample-channels = 6 
    ; disable-lfe-remixing = no
    ; default-channel-map = front-left,front-right
    
    ; default-fragments = 4
    ; default-fragment-size-msec = 25
    
    ; enable-deferred-volume = yes
    deferred-volume-safety-margin-usec = 1
    ; deferred-volume-extra-delay-usec = 0
    
    remixing-produce-lfe = yes
    remixing-consume-lfe = yes # enable-lfe-remixing = yes
    /etc/pulse/default.pa:

    Code:
    #!/usr/bin/pulseaudio -nF
    #
    # This file is part of PulseAudio.
    #
    # PulseAudio is free software; you can redistribute it and/or modify it
    # under the terms of the GNU Lesser General Public License as published by
    # the Free Software Foundation; either version 2 of the License, or
    # (at your option) any later version.
    #
    # PulseAudio is distributed in the hope that it will be useful, but
    # WITHOUT ANY WARRANTY; without even the implied warranty of
    # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
    # General Public License for more details.
    #
    # You should have received a copy of the GNU Lesser General Public License
    # along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.
    
    # This startup script is used only if PulseAudio is started per-user
    # (i.e. not in system mode)
    
    .fail
    
    ### Automatically restore the volume of streams and devices
    load-module module-device-restore
    load-module module-stream-restore
    load-module module-card-restore
    
    ### Automatically augment property information from .desktop files
    ### stored in /usr/share/application
    load-module module-augment-properties
    
    ### Should be after module-*-restore but before module-*-detect
    # load-module module-switch-on-port-available
    
    ### Use hot-plugged devices like Bluetooth or USB automatically (LP: #1702794)
    .ifexists module-switch-on-connect.so
    load-module module-switch-on-connect
    .endif
    
    ### Load audio drivers statically
    ### (it's probably better to not load these drivers manually, but instead
    ### use module-udev-detect -- see below -- for doing this automatically)
    #load-module module-alsa-sink
    #load-module module-alsa-source device=hw:1,0
    #load-module module-oss device="/dev/dsp" sink_name=output source_name=input
    #load-module module-oss-mmap device="/dev/dsp" sink_name=output source_name=input
    #load-module module-null-sink
    #load-module module-pipe-sink
    
    ### Automatically load driver modules depending on the hardware available
    .ifexists module-udev-detect.so
    load-module module-udev-detect
    .else
    ### Use the static hardware detection module (for systems that lack udev support)
    load-module module-detect
    .endif
    
    ### Automatically connect sink and source if JACK server is present
    .ifexists module-jackdbus-detect.so
    .nofail
    load-module module-jackdbus-detect channels=2
    .fail
    .endif
    
    ### Automatically load driver modules for Bluetooth hardware
    .ifexists module-bluetooth-policy.so
    load-module module-bluetooth-policy
    .endif
    
    .ifexists module-bluetooth-discover.so
    load-module module-bluetooth-discover
    .endif
    
    ### Load several protocols
    .ifexists module-esound-protocol-unix.so
    load-module module-esound-protocol-unix
    .endif
    load-module module-native-protocol-unix
    
    ### Network access (may be configured with paprefs, so leave this commented
    ### here if you plan to use paprefs)
    #load-module module-esound-protocol-tcp
    #load-module module-native-protocol-tcp
    #load-module module-zeroconf-publish
    
    ### Load the RTP receiver module (also configured via paprefs, see above)
    #load-module module-rtp-recv
    
    ### Load the RTP sender module (also configured via paprefs, see above)
    #load-module module-null-sink sink_name=rtp format=s16be channels=2 rate=44100 sink_properties="device.description='RTP Multicast Sink'"
    #load-module module-rtp-send source=rtp.monitor
    
    ### Load additional modules from GConf settings. This can be configured with the paprefs tool.
    ### Please keep in mind that the modules configured by paprefs might conflict with manually
    ### loaded modules.
    .ifexists module-gconf.so
    .nofail
    load-module module-gconf
    .fail
    .endif
    
    ### Automatically restore the default sink/source when changed by the user
    ### during runtime
    ### NOTE: This should be loaded as early as possible so that subsequent modules
    ### that look up the default sink/source get the right value
    load-module module-default-device-restore
    
    ### Automatically move streams to the default sink if the sink they are
    ### connected to dies, similar for sources
    load-module module-rescue-streams
    
    ### Make sure we always have a sink around, even if it is a null sink.
    load-module module-always-sink
    
    ### Honour intended role device property
    load-module module-intended-roles
    
    ### Automatically suspend sinks/sources that become idle for too long
    # load-module module-suspend-on-idle
    
    ### If autoexit on idle is enabled we want to make sure we only quit
    ### when no local session needs us anymore.
    .ifexists module-console-kit.so
    load-module module-console-kit
    .endif
    .ifexists module-systemd-login.so
    load-module module-systemd-login
    .endif
    
    ### Enable positioned event sounds
    load-module module-position-event-sounds
    
    ### Cork music/video streams when a phone stream is active
    load-module module-role-cork
    
    ### Modules to allow autoloading of filters (such as echo cancellation)
    ### on demand. module-filter-heuristics tries to determine what filters
    ### make sense, and module-filter-apply does the heavy-lifting of
    ### loading modules and rerouting streams.
    load-module module-filter-heuristics
    load-module module-filter-apply
    
    ### Make some devices default
    #set-default-sink output
    #set-default-source input
    # load-module module-alsa-sink device=0,3
     load-module module-combine-sink channels=6 channel_map=front-left,front-right,rear-left,rear-right,front-center,lfe

    Last edited by slickymaster; April 4th, 2020 at 11:13 AM. Reason: removed large images

  2. #2
    Join Date
    Nov 2012
    Location
    Halloween Town
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Gnome Sound settings Subwoofer slider stuck at 0, but pavucontrol works fine

    Please do not post large images into your posts. Many of our users have slow internet connections and data limits. Large images can take a long time to load -- and may even cost a user extra money. Use the attachment functionality provided by the paperclip button above the text entry box.

  3. #3
    Join Date
    Mar 2013
    Beans
    10

    Re: Gnome Sound settings Subwoofer slider stuck at 0, but pavucontrol works fine

    Quote Originally Posted by slickymaster View Post
    Please do not post large images into your posts. Many of our users have slow internet connections and data limits. Large images can take a long time to load -- and may even cost a user extra money. Use the attachment functionality provided by the paperclip button above the text entry box.
    Wasn't aware, will be more careful on the next post!

  4. #4
    Join Date
    Jul 2020
    Beans
    1

    Re: Gnome Sound settings Subwoofer slider stuck at 0, but pavucontrol works fine

    I've had this issue also - it happens across different PCs with different sound cards and sound output via HDMI

  5. #5
    Join Date
    Nov 2012
    Location
    Halloween Town
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Gnome Sound settings Subwoofer slider stuck at 0, but pavucontrol works fine

    20.04 was released 8 months ago.

    Thread closed

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •