Results 1 to 7 of 7

Thread: Canít get Ubuntu to boot on Ryzen 5 3600 with Tomahawk B450 Motherboard

  1. #1
    Join Date
    Oct 2020
    Beans
    2

    Canít get Ubuntu to boot on Ryzen 5 3600 with Tomahawk B450 Motherboard

    Hello everyone, Iím kinda new to Linux and Iím really tired of Windows so I decided to try Ubuntu, but I keep getting the error ďamd-vi completion-wait loop timed out.Ē I have tried to modify the boot and add ďapci=offĒ but that didnít fix it. If thereís anyone who could help it would be greatly appreciated.

  2. #2
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Canít get Ubuntu to boot on Ryzen 5 3600 with Tomahawk B450 Motherboard

    you might check the 'secure boot' inside the uefi/bios and turn it off if not already done.
    https://www.howtogeek.com/175641/how...h-secure-boot/

  3. #3
    Join Date
    Oct 2020
    Beans
    2

    Re: Canít get Ubuntu to boot on Ryzen 5 3600 with Tomahawk B450 Motherboard

    I have tried that already and for some reason my pc is still not able to boot the latest version of Ubuntu or even some of the older versions

  4. #4
    Join Date
    Jun 2012
    Beans
    17

    Re: Canít get Ubuntu to boot on Ryzen 5 3600 with Tomahawk B450 Motherboard

    Hi, i recently switched to a tomahawk B550 with Ryzen 5 3600 and it runs great, I didn't have to do anything. I run 20.04LTS.
    How did you install ubuntu, or are you trying to boot from installation CD or USB?

  5. #5
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Canít get Ubuntu to boot on Ryzen 5 3600 with Tomahawk B450 Motherboard

    Have you updated UEFI and if SSD, SSD firmware?

    Some issues are common by Brand across multiple models.
    Some issues are common by chip set/CPU across multiple brands.

    These may offer some suggestions.
    MSI TRX40 PRO WiFi Motherboard
    https://askubuntu.com/questions/1269...pper-3960x-cpu

    Asrock B450 UEFI & Driver update to stop flickering.
    https://pcpartpicker.com/b/t4KBD3
    Asrock B450M Steel Legend - turn UEFI Secure Boot off
    https://askubuntu.com/questions/1183...n-3000-machine
    Gigabyte B450 Ryzen needs kernel & mesa drivers
    https://ubuntuforums.org/showthread.php?t=2408247 &
    https://ubuntuforums.org/showthread.php?t=2423649

    MSI B450 Tomahawk Max & MSI Nvidia GTX 1080 TI UEFI update & defaults
    https://ubuntuforums.org/showthread.php?t=2450961
    MSI Tomahawk B350 with Ryzen R5 1600 New UEFI required
    https://ubuntuforums.org/showthread.php?t=2390475
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  6. #6
    Join Date
    Jun 2007
    Beans
    14,326

    Re: Canít get Ubuntu to boot on Ryzen 5 3600 with Tomahawk B450 Motherboard

    First, Update the BIOS/EFI.
    If you still have issues, try disabling "SVM Mode" in your EFI to work around the issue. It's not ideal to keep SVM disabled if you run VM's, but maybe it will allow you to install Ubuntu and then you can turn it back on.

  7. #7
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    22,125
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Canít get Ubuntu to boot on Ryzen 5 3600 with Tomahawk B450 Motherboard

    I don't have a Ryzen 3xxx or MSI motherboard. Mine is a Ryzen 2600 and Asus ROG.

    Definitely ensure you have the most recent BIOS update.

    If you have more than 2 sticks of matched RAM, you may find they are not really the same speeds. I've had to relax some memory speed settings and increase the volts a tad to get 4 sticks working. Using the DOCP (AMD's term for XMP) memory profile doesn't always work. I'm running 3200 Mhz RAM at 2800Mhz to get a stable system.

    I've not seen the issue with SVM disabled. To me, if SVM didn't work, I'd not have any reason to keep that system.

    Getting a Ryzen system to boot and getting a system to be stable were all about the RAM settings for me. Instability would show up hours, even days later.
    Code:
    $ uptime 
     09:36:47 up 7 days, 11:08,  4 users,  load average: 11.73, 11.97, 11.38
    It is a busy system. All 12 threads (6-cores), working hard.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •